Pergunte aqui
1

Somarproduto com condicional

perguntadas 2019-04-03 22:53:09 +0100

imagem do gravatar de Iran Borges

updated 2019-04-22 00:06:13 +0100

imagem do gravatar de Schiavinatto

Boa tarde! Estou com uma fórmula que não consigo concluir pois ela resulta em erro. Já tentei diversas variações. Em uma matriz 6x2 (6 linhas e 2 colunas) tenho apenas as 2 primeiras linhas de cada coluna preenchidas.

A fórmula que tenho é

somarproduto((A1:A6>0)/(B1:B6>0)).

O que eu quero é a divisão dos valores informados na coluna A pelos valores informados na coluna B. Porém a fórmula resulta em erro quando existe alguma célula sem preencher. Preenchendo todas as células a fórmula me traz o resultado correto. Como faço para ela desconsiderar as células vazias?

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Vc quer somar de a1 até a6 e dividir essa soma pela soma de b1 até b6 ?

=SOMA(A1:A6)/SOMA(B1:B6)

qual a finalidade desse ">0" ?


A formula SOMARPRODUTO se usa assim, e não do modo que está tentando usar:

https://help.libreoffice.org/Calc/Arr...

imagem do gravatar de mrkalvinmrkalvin ( 2019-04-04 00:48:01 +0100 )editar

Bom dia! A fórmula soma irá realizar a divisão da soma total da coluna A pela soma total da coluna B e não é isto que eu quero. Eu necessito do seguinte: (A6/B6)+(A7/B7)+(A8/B8)....(An/Bn) desconsiderando as células que não estão com números, pois sabemos que 0/0 não existe.

Além do mais, no Excel e no Drive, conseguimos utilizar a fórmula SOMARPRODUTO com condição, da maneira que exemplifiquei acima. Só não estou conseguindo fazer no libreOffice, que deve ter outro formato.

imagem do gravatar de Iran BorgesIran Borges ( 2019-04-04 13:40:01 +0100 )editar

2 Respostas

1

respondidas 2019-04-04 00:41:48 +0100

imagem do gravatar de Schiavinatto

updated 2019-04-04 00:57:52 +0100

Ola @Iran Borges, seja bem vindo ao Grupo.

Aqui no teste deu certo...

=SOMARPRODUTO(SEERRO(A1:A6/B1:B6;0))

Desta maneira só vai usar no calculo os pares, se A e o respectivo B estiverem preenchidos.


Caso a resposta atendeu sua necessidade, por gentileza, click na bolinha Descrição da imagem a esquerda da resposta, para finalizar a pergunta.

editar assinalar como ofensivo Excluir Link mais

Comentários

Bom dia Gilberto! Eu necessito do seguinte: (A6/B6)+(A7/B7)+(A8/B8)....(An/Bn) desconsiderando as células que não estão com números, pois sabemos que 0/0 não existe. Se eu acrescentar a fórmula SEERRO, ela retornará o valor 0 tendo algumas células preenchidas e outras não. E não é isto que eu quero.

imagem do gravatar de Iran BorgesIran Borges ( 2019-04-04 13:42:12 +0100 )editar
1

Segue arquivo do teste, colunas A e B os dados C a fórmula acima e D feito individual e somado (que iguala a C ).

. Altere os números de A e B e confirme que esta certo....

. Descrição da imagem

imagem do gravatar de SchiavinattoSchiavinatto ( 2019-04-04 14:14:22 +0100 )editar

Gilberto, boa tarde!

Muito obrigado pela sua exemplificação. É exatamente o que eu necessito. Resolvido. Grato.

imagem do gravatar de Iran BorgesIran Borges ( 2019-04-08 20:49:47 +0100 )editar
0

respondidas 2019-04-04 14:21:16 +0100

imagem do gravatar de Conrado

updated 2019-04-04 14:22:04 +0100

Olá @Iran Borges

No seu caso, terá que usar fórmula matricial.

Copie esta fórmula em alguma célula, faça a alteração do seu range de células que queira calcular e depois tecle:

Ctrl + Shift + Enter

=SOMASES(A1:A5/B1:B5;B1:B5;"<>"&0;B1:B5;"<>"&"")

No fim a fórmula deve ficar na barra de endereço da seguinte forma:

{=SOMASES(A1:A5/B1:B5;B1:B5;"<>"&0;B1:B5;"<>"&"")}

Faça os testes e nos retorne com o resultado.

Caso a resposta atendeu sua necessidade, por gentileza, click na bolinha a esquerda da resposta, para finalizar a pergunta.

editar assinalar como ofensivo Excluir Link mais

Comentários

Boa tarde Conrado!

Tentei esta fórmula e também não deu certo. Retornou o erro "#valor!"

imagem do gravatar de Iran BorgesIran Borges ( 2019-04-08 20:46:39 +0100 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2019-04-03 22:53:09 +0100

Lidas: 1,723 vezes

Última atualização: Apr 04 '19