Pergunte aqui
0

Como calcular saldo buscando entrada e saída por lote e data de entrada?

perguntadas 2019-05-07 19:32:49 +0200

imagem do gravatar de Aline

updated 2019-05-08 16:06:28 +0200

Estou tentando criar uma planilha pra fazer controle de reagentes e preciso que o saldo seja calculado com base na data de entrada e no número do lote, as vezes temos um mesmo lote de reagente que entram em datas diferentes e portanto temos que usar a regra "o primeiro que entra é o primeiro que sai" já fiz duas tentativas, uma calcula por número de lote então soma tudo e fica com saldo as vezes maior do que entrou e a segunda retorna um valor diferente e não entendo porque. Será que alguém consegue me ajudar a resolver?C:\fakepath\CONTROLE DE MEIO DE CULTURA PRONTO PARA USO.xlsxC:\fakepath\CONTROLE DE MEIO DE CULTURA PRONTO PARA USO- Teste procura data de entrada.xlsx

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

1 Resposta

0

respondidas 2019-05-07 23:39:17 +0200

updated 2019-05-08 12:26:13 +0200

Ola @Aline, seja bem vinda ao Grupo.

Em seu arquivo em Entrada, insira uma nova linha 4 (pode ocultar depois) e na célula I5 cole esta fórmula:

Descrição da imagem

=SE(((SOMASE($A$4:H5;A5;$H$4:H5))-(PROCV(A5;Cadastro.$A$4:$F$20;5;0)))<0;0;SE(((SOMASE($A$4:H5;A5;$H$4:H5))-(PROCV(A5;Cadastro.$A$4:$F$20;5;0)))<=H5;H5-((SOMASE($A$4:H5;A5;$H$4:H5))-(PROCV(A5;Cadastro.$A$4:$F$20;5;0)));SE(((SOMASE($A$4:H5;A5;$H$4:H5))-(PROCV(A5;Cadastro.$A$4:$F$20;5;0)))>H5;H5;"")))

E arraste para baixo.

Em meu arquivo.ODS, esta funcionando, faça testes.

É obrigatório o arquivo estar ordenado por CÓDIGO / VALIDADE crescente.

Segue arquivo do teste.

Faça testes e de retorno...

ATENÇÃO => Na formula a planilha Cadastro foi prevista até a linha 20 ($F$20) altere conforme a necessidade.


Descrição da imagem

editar assinalar como ofensivo Excluir Link mais

Comentários

Bom dia! Primeiramente agradeço muito pela ajuda! A fórmula deu certo mas não está calculando corretamente.Por exemplo, o item grifado deu entrada em 4 unidades e consta em estoque no cálculo da planilha de entrada

C:\fakepath\Capturar.JPG

mas na planilha de saída a quantidade informada foi 2 unidades então o certo seria constar 2 unidades em estoque na planilha de entrada. Deu pra entender?

Descrição da imagem

imagem do gravatar de AlineAline ( 2019-05-08 15:49:13 +0200 )editar

Ok @Aline, erro meu, considerei, CÓDIGO e Validade, vou rever...................

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-05-08 16:17:31 +0200 )editar

@Aline, em sua própria planilha em Entrada.I4, cole a fórmula =H4-(SOMASES(Saída.$H$4:$H$20;Saída.$A$4:$A$20;A4;Saída.$C$4:$C$20;C4;Saída.$E$4:$E$20;F4)) araste para baixo.

Testar e retornar.......Grato.

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-05-08 16:44:22 +0200 )editar

Agora deu certo! Ficou top top. Nem sei como te agradecer, muito obrigada =)

imagem do gravatar de AlineAline ( 2019-05-08 20:59:38 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2019-05-07 19:32:49 +0200

Lidas: 27 vezes

Última atualização: May 08