Pergunte aqui
1

Criar botão para salvar historico

perguntadas 2019-06-14 20:37:14 +0100

Olá, eu gostaria de saber como criar um botão para salvar dados em outra celula!

Segue o exemplo abaixo:

Eu coloco um valor na celula e várias outras celulas irão fazer os calculos automaticamente, então eu quero um botão que ao clicar nele, ele vai copiar os dados e passar para as celulas de historico, mas quando eu alterar o valor, os dados vão mudar e quando eu clicar no botão novamente, os dados devem ser colocados uma linha abaixo, de modo que não substitua a anterior e também não pode repetir e nem deixar linhas em branco!

É possivel fazer isso? Seja com VBA ou não!

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

3 Respostas

3

respondidas 2019-06-16 04:03:31 +0100

updated 2019-06-16 04:10:44 +0100

Ola @rafaBrunnoS, dá sim....

Segue arquivo teste

.

Descrição da imagem


ATENÇÂO:: Caso queira dar mais detalhes a sua pergunta, use Descrição da imagem na pergunta ou Descrição da imagem abaixo. Grato.

Caso a resposta atendeu sua necessidade, por gentileza, click na bolinha Descrição da imagem a esquerda da resposta, para finalizar a pergunta.

editar assinalar como ofensivo Excluir Link mais
1

respondidas 2019-06-17 16:35:03 +0100

imagem do gravatar de Júnio Vieira

Bom dia, aproveitando o exemplo do Gilberto, segue outra forma de fazerC:\fakepath\1560651009593368.ods

editar assinalar como ofensivo Excluir Link mais

Comentários

Ok @Jùnio Vieira, muito boa a alternativa.

Só faltou corrigir a formula em B4: =SE(CONT.SE($Bancodedados.A:A;B3)>0;"Atenção: Valor repetido.";"")

De >1 para >0

Para acusar duplicidade.

imagem do gravatar de SchiavinattoSchiavinatto ( 2019-06-17 16:42:12 +0100 )editar

Boa tarde, Show Gilberto, bem observado!

imagem do gravatar de Júnio VieiraJúnio Vieira ( 2019-06-17 20:40:32 +0100 )editar
0

respondidas 2019-06-18 05:33:30 +0100

Muito obrigado vocês dois! Deu super certo! Ficou top de mais!

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2019-06-14 20:37:14 +0100

Lidas: 41 vezes

Última atualização: Jun 18