Pergunte aqui
1

Índice+Corresp = dúvida sobre uma segunda condição

perguntadas 2019-06-27 14:21:35 +0200

imagem do gravatar de Regisfreitas

updated 2019-06-29 19:22:12 +0200

Bom dia amigos, estou precisando de ajuda em uma questão q já me ocorreu várias vezes. nessa imagem abaixo tem o uso de um índice+corresp normal, onde quando eu entro com uma data no campo DIA (B17) e no campo ITEM (C17) o resultado desse cruzamento vai aparecer no campo RESULTADO pela fórmula =ÍNDICE(A1:G11;CORRESP(B17;A1:A11;0);CORRESP(C17;A1:G1;0)). Assim tenho o resultado de MESA NO DIA 05/07/19.

Índice+corresp normal

Agora minha dúvida é quando eu preciso q ele faça essa procura e há mais de uma célula igual, com uma segunda COLUNA para ser a filtragem igual o caso abaixo. Como eu consigo o resultado de MESA no DIA 05/07/19 no período DIURNO?

Descrição da imagem

Já quero agradecer à todos que fazem parte dessa comunidade.

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

1 Resposta

3

respondidas 2019-06-27 17:02:22 +0200

Ola @Regisfreitas, segue uma alternativa de solução...

Fórmula montada conforme imagem

=ÍNDICE(INDIRETO((ESCOLHER((CORRESP(D27;A1:H1;0));"A";"B";"C";"D";"E";"F";"G";"H"))&2&":"&(ESCOLHER((CORRESP(D27;A1:H1;0));"A";"B";"C";"D";"E";"F";"G";"H"))&21);CORRESP(1;(A2:A21=B27)*(B2:B21=C27);0))

O numero 2 e 21 que aparece na fórmula são a primeira e última linha de pesquisa.

Arquivo do teste

-----------------------------------------------------------------------------

ATENÇÂO:: Caso queira dar mais detalhes a sua pergunta, use Descrição da imagem na pergunta ou Descrição da imagem abaixo. Grato.

Caso a resposta atendeu sua necessidade, por gentileza, click na bolinha Descrição da imagem a esquerda da resposta, para finalizar a pergunta.

editar assinalar como ofensivo Excluir Link mais

Comentários

@Gilberto Schiavinatto , esta fórmula é matricial, correto? Se sim, importante Ctrl+Shitf+Enter

imagem do gravatar de ConradoConrado ( 2019-06-27 18:02:58 +0200 )editar

Resolvido perfeitamente Gilberto, muito obrigado!! Estou quebrando a cabeça aqui para entender como você usou o INDIRETO na fórmula e também eu não conhecia a função ESCOLHER.

imagem do gravatar de RegisfreitasRegisfreitas ( 2019-06-27 18:08:18 +0200 )editar
1

@Conrado, não é matricial, é simples.

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-06-27 18:13:47 +0200 )editar

@Regisfreitas, na planilha teste na coluna J em J11, tem a área que precisava encontrar, as linhas de baixo são passos para chegar a ela. O INDIRETO transforma texto em área reconhecida pela formula.

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-06-27 18:22:20 +0200 )editar

@Gilberto Schiavinatto Eu não consegui entender esse seu corresp ==> CORRESP(1;(A2:A21=B27)*(B2:B21=C27)). Você poderia me explicar essa forma de matriz de consulta, por favor?

imagem do gravatar de RegisfreitasRegisfreitas ( 2019-06-27 19:09:57 +0200 )editar

Achei que com o seu exemplo eu conseguiria criar ainda um terceira coluna de condição mas não estou conseguindo nem replicar sua fórmula. Além desse corresp ser diferente do q eu conheço, não estou encontrando onde você está indicando a LINHA do índice.

imagem do gravatar de RegisfreitasRegisfreitas ( 2019-06-27 19:25:30 +0200 )editar

@Regisfreitas, (A2:A21=B27)(B2:B21=C27) aqui indica o produto das colunas envolvidas, se quiser mais colunas e só acrescentar, por exemplo: (A2:A21=B27)(B2:B21=C27)*(C2:C21=D27).

A base da fórmula peguei aqui: https://ask.libreoffice.org/pt-br/que... pelo @Conrado

Caso queira entre em contato direto, e-mail aqui:https://wiki.documentfoundation.org/U...

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-06-27 19:45:32 +0200 )editar

PERFEITO! Mais uma vez não tenho com expressar minha gratidão!

imagem do gravatar de RegisfreitasRegisfreitas ( 2019-06-27 20:37:46 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2019-06-27 14:21:35 +0200

Lidas: 21 vezes

Última atualização: Jun 27