Expressão regular para selecionar fórmula e mesclar

perguntadas 2019-06-27 18:39:27 +0200

imagem do gravatar de Leandro Vieira

updated 2019-06-27 19:14:30 +0200

Olá, pessoal!

Estou precisando selecionar o intervalo que contenha a fórmula:

=SE(E(SOMASE(INDIRETO($C$2&".$a$195:$a$253");$A10;INDIRETO($C$2&".$i$195:$i$253"))=0;SOMASE(INDIRETO($C$2&".$a$195:$a$253");$A10;INDIRETO($C$2&".$h$195:$h$253"))=0);0;SE(SOMASE(INDIRETO($C$2&".$a$195:$a$253");$A10;INDIRETO($C$2&".$i$195:$i$253"))=0;SOMASE(INDIRETO($C$2&".$a$195:$a$253");$A10;INDIRETO($C$2&".$h$195:$h$253"));SOMASE(INDIRETO($C$2&".$a$195:$a$253");$A10;INDIRETO($C$2&".$i$195:$i$253"))))

Sendo mais objetivo, preciso localizar o início da fórmula =SE(E(SOMASE(INDIRETO($C$2&".$a$195:$a$253"); tudo que há até os quatro últimos parênteses "pois é relativo à célula da coluna" ))))

Tenho que excluir o sinal de igualdade da fórmula encontrada e mesclar com esta: =SE(ÉERROS(PLANILHA(INDIRETO($C$2&".$a$69")));0;

ou seja, precisaria de um resultado assim: =SE(ÉERROS(PLANILHA(INDIRETO($C$2&".$a$69")));0;SE(E(SOMASE(INDIRETO($C$2&".$a$195:$a$253");tudo que há até os quatro últimos parênteses "pois é relativo à célula da coluna" ))))

Já tentei, mas o que consegui até agora foi usando em LOCALIZAR: \=SE(E(SOMASE(INDIRETO($C$2.))))*

SUBSTITUIR: =SE(ÉERROS(PLANILHA(INDIRETO($C$2&".$a$69")));0;&

O resultado em I10, a primeira encontrada na coluna foi com erros, assim como as demais:

=SE(ÉERROS(PLANILHA(INDIRETO($c=se".$a9")));0;=SE(ÉERROS(PLANILHA(INDIRETO($c=se".$a9")));0;=SE(E(SOMASE(INDIRETO($C$2&".$a$195:$a$253");$A10;INDIRETO($C$2&".$i$195:$i$253"))=0;SOMASE(INDIRETO($C$2&".$a$195:$a$253");$A10;INDIRETO($C$2&".$h$195:$h$253"))=0);0;SE(SOMASE(INDIRETO($C$2&".$a$195:$a$253");$A10;INDIRETO($C$2&".$i$195:$i$253"))=0;SOMASE(INDIRETO($C$2&".$a$195:$a$253");$A10;INDIRETO($C$2&".$h$195:$h$253"));SOMASE(INDIRETO($C$2&".$a$195:$a$253");$A10;INDIRETO($C$2&".$i$195:$i$253"))))))

Desde já agradeço!

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Ola @Leandro Vieira, esta parecendo sopinha de letras, ha ha ha ha ......

No LOCALIZAR: \=SE(E(SOMASE(INDIRETO($C$2.))))*

Quer trocar SE(E(SOMASE(INDIRETO($C$2&

Por SE(ÉERROS(PLANILHA(INDIRETO($C$2&".$a$69")));0;&

Descrição da imagem

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-06-27 19:29:23 +0200 )editar

Na verdade não, no campo Outras opções seria habilitada a opção Expressões regulares, se observar no resultado desejado ,foi mesclado a fórmula =SE(ÉERROS(PLANILHA(INDIRETO($C$2&".$a$69")));0; com SE(E(SOMASE(INDIRETO($C$2&".$a$195:$a$253");...)))), e no resultado que até agora obtive no início saiu com erro mas as fórmulas foram mescladas.

imagem do gravatar de Leandro VieiraLeandro Vieira ( 2019-06-27 19:57:27 +0200 )editar

.

=SE(ÉERROS(PLANILHA(INDIRETO($c=se".$a9")));0;=SE(ÉERROS(PLANILHA(INDIRETO($c=se".$a9")));0;=SE(E(SOMASE(INDIRETO($C$2&".$a$195:$a$253");$A10;INDIRETO($C$2&".$i$195:$i$253"))=0;SOMASE(INDIRETO($C$2&".$a$195:$a$253");$A10;INDIRETO($C$2&".$h$195:$h$253"))=0);0;SE(SOMASE(INDIRETO($C$2&".$a$195:$a$253");$A10;INDIRETO($C$2&".$i$195:$i$253"))=0;SOMASE(INDIRETO($C$2&".$a$195:$a$253");$A10;INDIRETO($C$2&".$h$195:$h$253"));SOMASE(INDIRETO($C$2&".$a$195:$a$253");$A10;INDIRETO($C$2&".$i$195:$i$253"))))))

.

O erro que menciona na formula acima é =SE fora do inicio ?

.

Use Localizar ;=SE e substituir por ;SE

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-06-27 20:08:36 +0200 )editar

Também, além de ter repetido =SE(ÉERROS(PLANILHA(INDIRETO($C$2&".$a$69")));0;, foi com erro em =SE(ÉERROS(PLANILHA(INDIRETO($c=se".$a9")));0;

imagem do gravatar de Leandro VieiraLeandro Vieira ( 2019-06-27 20:13:39 +0200 )editar