Pergunte aqui
0

Contar palavras em células com textos, com ref. em outra célula.

perguntadas 2019-06-28 17:47:31 +0200

updated 2019-06-28 21:01:11 +0200

Conforme imagem abaixo, a formula conta D nas células, independente da posição.

Descrição da imagem

Porem a necessidade da contagem é uma variável que esta na célula C7, não consegui incorporar na formula, alguém tem alguma dica.

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

2 Respostas

1

respondidas 2019-06-28 20:33:33 +0200

imagem do gravatar de Conrado

updated 2019-06-28 20:34:23 +0200

@Gilberto Schiavinatto e @Júnio Vieira

Seguindo seu exemplo

Descrição da imagem

editar assinalar como ofensivo Excluir Link mais

Comentários

1

Ok @Conrado, perfeito,

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-06-28 20:47:59 +0200 )editar
2

respondidas 2019-06-28 18:54:36 +0200

imagem do gravatar de Júnio Vieira

updated 2019-06-28 20:25:38 +0200

@Gilberto com mesmo exemplo que vc utilizou, segue fórumla: CONT.SE($B:$B;""&C7&"")

Obs: para que a fórmula funcione deve marcar a opção "Permitir caracteres curingas em fórmulas conforme imagem anexa.C:\fakepath\Capturar.PNG

editar assinalar como ofensivo Excluir Link mais

Comentários

@Júnio Vieira, esta foi a primeira que tentei, o resultado é 1, só conta o D sozinho.

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-06-28 19:03:48 +0200 )editar

Tentei fazer a composição em texto ="=CONT.SE($B2:$B9;""*"&C7&"*"")", visualmente fica igual a célula da formula em D5, e usar com INDIRETO, mas não funcionou.

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-06-28 19:10:37 +0200 )editar

@ Gilberto esqueci de informar um detalhe, editei a resposta para ficar completa.

imagem do gravatar de Júnio VieiraJúnio Vieira ( 2019-06-28 20:26:21 +0200 )editar

@Júnio Vieira, já estava configurado.

O @Conrado, corrigiu a formula.

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-06-28 20:44:10 +0200 )editar

@Gilberto e @Conrado, olhando minha resposta realmente não sei o que aconteceu na minha planilha estava como o Conrado postou, mas que bom que deu certo.

imagem do gravatar de Júnio VieiraJúnio Vieira ( 2019-06-28 20:47:52 +0200 )editar

@Júnio Vieira, quando digitamos formulas no ask, precisamos ficar atentos, visualmente podem ficar diferentes. Percebi que qdo fui postar ao digitar a formula ficava diferente, por isso postei com imagem, como o @Conrado fez. Vivendo e aprendendo.

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-06-28 20:55:42 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2019-06-28 17:47:31 +0200

Lidas: 17 vezes

Última atualização: Jun 28