Pergunte aqui
1

Como conto 31 dias e não 30 dias, no mês de 31 dias?

perguntadas 2019-08-01 17:10:51 +0200

imagem do gravatar de Jamilson

updated 2019-08-01 17:16:30 +0200

C:\fakepath\formula2.png

Como eu conto 31 dias e não 30 dias, no mês de 31 dias? Já utilizei a formula com função DATADIF, e nada. neste modelo estou usando a função SE

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Ok, a função DATADIF esta certa, se o mês tem 31 dias e retira o dia 1 fica 30.

Se quiser a Diferença de data incluindo a data inicial deve-se somar 1.

Por exemplo em dias trabalhados, se começou a trabalhar dia 1 até dia 31 a DATADIF é 30 mas dias trabalhados é 31.

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-08-01 20:50:41 +0200 )editar

2 Respostas

0

respondidas 2019-08-01 17:30:40 +0200

imagem do gravatar de mrkalvin

updated 2019-08-01 17:31:01 +0200

Voce não poderia usar a fórmula abaixo? e formate a célula como data e para exibir só o dia mude o código do formato de DD/MM/AAAA para apenas DD

=FIMMÊS(A1;0)

em A1 coloque uma data ex: 04/03/2019

editar assinalar como ofensivo Excluir Link mais

Comentários

@Jamilson , complementando a resposta do @mrkalvin, para extrair o último dia apenas como resultado (ex.: 28, 30, 31) a fórmula será

=DIA(FIMMÊS(A1;0))

imagem do gravatar de ConradoConrado ( 2019-08-01 19:26:45 +0200 )editar
0

respondidas 2019-08-04 01:06:06 +0200

Ola @Jamilson, segue correção:

A formula em H4 =SE(E4="";"";SE(DIA(E4)=31;"1";""))

Altere para =SE(E4="";"";SE(DIA(E4)=31;"1";0))

Se Forçar Vazio ou espaço gera erro na formula.

Caso não queira ver Zeros na planilha, use Ferramentas / Opções / LibreOffice Calc / Exibr e desmarque [ ] Valores zero.

-----------------------------------------------------------------------------

ATENÇÂO:: Caso queira dar mais detalhes a sua pergunta, use Descrição da imagem na pergunta ou Descrição da imagem abaixo. Grato.

Caso a resposta atendeu sua necessidade, por gentileza, click na bolinha Descrição da imagem a esquerda da resposta, para finalizar a pergunta.

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2019-08-01 17:10:51 +0200

Lidas: 32 vezes

Última atualização: Aug 04