Pergunte aqui
0

Horas decimais positivas e negativas

perguntadas 2019-10-09 01:41:12 +0200

imagem do gravatar de Seiki2000

Boa noite,

Estou tentando resolver um situação mas não consegui. Tenho uma planilha de horas geradas em decimais. Exemplo 1,5 , 39,94 e também horas negativas exemplo -1,6. Obs. todas com vírgula.

Gostaria de saber como converter através de fórmula 1,5 para 1,3 ( 1 hora e 30 minutos) ou 30,94 para 30,56 (30 horas e 56 minutos) -1,6 para 1.36 (-1 hora e 36 minutos) Obs. o formato final pode ser outro, exemplo 01:30 ou -01:30 (1 hora e 30 minutos)

Obrigado,

Seiki

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

1 Resposta

2

respondidas 2019-10-09 02:59:29 +0200

imagem do gravatar de Leandro Vieira

updated 2019-10-09 03:00:03 +0200

Boa noite, seiki2000!

Neste caso você terá que utilizar a função TEXTO para converter os valores em um formato desejado, veja o exemplo da imagem:

Descrição da imagem

Na célula B20 foi inserida a fórmula =TEXTO(A20/24;"[HH]:MM:SS"), A20 sendo a célula que contém o valor a ser convertido para 24 horas, então dividimos; em valores maiores que 24 horas negativos ou positivos utilizamos o formato [HH]:MM:SS, basta copiar e colar nas demais.

Caso a resposta tenha atendido sua dúvida basta marcar em Descrição da imagempara organização do Ask!

Qualquer dúvidas, comente.

editar assinalar como ofensivo Excluir Link mais

Comentários

Boa noite,

Leandro, muito obrigado. Não imagina o quanto me ajudou...

imagem do gravatar de Seiki2000Seiki2000 ( 2019-10-10 01:03:22 +0200 )editar

Eu que agradeço pelo feedback!

imagem do gravatar de Leandro VieiraLeandro Vieira ( 2019-10-11 15:11:43 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2019-10-09 01:41:12 +0200

Lidas: 10 vezes

Última atualização: Oct 09