Pergunte aqui
1

Porque o procv não mostra mais de 1 resultado?

perguntadas 2020-05-25 17:45:30 +0200

imagem do gravatar de VitorNicollas

updated 2020-05-26 21:02:56 +0200

imagem do gravatar de Leandro Vieira

Descrição da imagem Gostaria de saber pq a função procv não mostra mais de 1 resultado. Como no exempla na imagem fiz o procv no nome gerente que relaciona a segunda coluna, me mostrou resultado Pedro, sendo que gerente tambem tinha vitor. Teria alguma outra função para essa funcionalidade? Procuro alguma função que mostre mais de um resultado.

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

1 Resposta

1

respondidas 2020-05-25 18:43:56 +0200

imagem do gravatar de Leandro Vieira

updated 2020-05-25 20:09:10 +0200

Olá @VitorNicollas!

A sintaxe da função só permite o retorno de um resultado, para resolver essa situação teria que criar uma fórmula com algumas funções, ou utilizar o "filtro padrão", porém esta opção seria muito repetitiva, então segue um arquivo para teste:

Arquivo para teste

Basicamente, copie e cole a fórmula =SE(B4=$E$4;CONT.SE($B$4:$B4;$E$4);"") da coluna ao lado da tabela que contém o nome e cargo dos funcionários, utilize o filtro que foi feito com "validação de dados", insira a fórmula =SE(ÉERROS(PROCV(H4;$A$4:$C$15;3;0));"";(PROCV(H4;$A$4:$C$15;3;0))) no campo Nomes e enumere sequencialmente ao lado e terá o retorno das informações que deseja.

Qualquer dúvida edite a pergunta ou deixe no comentário, caso tenha solucionado o problema marque o botão para finalizar a pergunta.

editar assinalar como ofensivo Excluir Link mais

Comentários

Quais foram as formulas que voce usou? Desde ja obrigado

imagem do gravatar de VitorNicollasVitorNicollas ( 2020-05-25 18:55:14 +0200 )editar
imagem do gravatar de SchiavinattoSchiavinatto ( 2020-05-25 19:09:18 +0200 )editar

Obrigado ..

imagem do gravatar de VitorNicollasVitorNicollas ( 2020-05-25 19:46:03 +0200 )editar

Conseguiu abri o arquivo para teste? Vou editar a resposta com as fórmulas

imagem do gravatar de Leandro VieiraLeandro Vieira ( 2020-05-25 20:02:15 +0200 )editar

Consegui Sim. Muito Agradecido.

imagem do gravatar de VitorNicollasVitorNicollas ( 2020-05-25 20:04:12 +0200 )editar

À disposição, para finalizar a pergunta como solucionada, marque o botão de certo na resposta.

imagem do gravatar de Leandro VieiraLeandro Vieira ( 2020-05-25 20:14:14 +0200 )editar

Sou novo no libreofice. Marquei. Estou com muitas dúvidas pra solucionar

imagem do gravatar de VitorNicollasVitorNicollas ( 2020-05-26 04:04:01 +0200 )editar

@VitorNicollas use a vontade o ask, estamos aqui para ajudar. Abraço.

imagem do gravatar de SchiavinattoSchiavinatto ( 2020-05-26 15:13:12 +0200 )editar

Obrigado..

imagem do gravatar de VitorNicollasVitorNicollas ( 2020-05-26 15:15:03 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2020-05-25 17:45:30 +0200

Lidas: 19 vezes

Última atualização: May 25