Pergunte aqui
0

como colocar nome da guia em uma célula

perguntadas 2013-11-08 16:49:06 +0100

imagem do gravatar de ChicoJer

updated 2013-11-08 17:18:53 +0100

imagem do gravatar de Olivier

Bom dia! Gostaria de saber como coloco o nome da guia em uma célula em tempo de execução.

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Esta informação textual, as Funções Categoria Planilha não da. Porém quando, em uma fórmula tem referência a outra planilha, ela a reconhece. Uma saída se realmente necessita desta informação, seria após todas as planilhas prontas montar uma TABELA por exemplo: (A1)=1 (B1)=Nomedaplanilhadaposição1 (A2)=2 (B2)=Nomedaplanilhadaposição2 etc etc. De um nome para esta tabela, por exemplo=Guias, e na célula que quer o nome da planilha com =PROCV(PLANILHA();Guias;2;0), você conseguira o nome da planilha. ======> Atenção se alterar o nome da planilha ou mudar a posição é necessário acertar a TABELA manualmente.

imagem do gravatar de SchiavinattoSchiavinatto ( 2013-11-09 04:22:31 +0100 )editar

3 Respostas

0

respondidas 2013-12-14 11:19:03 +0100

imagem do gravatar de Olivier

Crie uma função simples em Basic como

Function chico(nPlan as Integer)

REM O índice começa em zero!!!!

oPlanilha = ThisComponent.getSheets().getByIndex(nPlan -1)

chico = oPlanilha.Name

End Function

E coloque na célula

=CHICO(PLANILHA())

editar assinalar como ofensivo Excluir Link mais
0

respondidas 2013-11-28 16:37:28 +0100

imagem do gravatar de Helio Moreno

updated 2013-11-28 19:46:25 +0100

imagem do gravatar de Olivier

Você pode pegar com a função cél("filename";a1) segue uma exemplo. Em a2 digite a fórmula:


=EXT.TEXTO(CÉL("filename";a1);PROCURAR("$";CÉL("filename";a1))+1;NÚM.CARACT(CÉL("filename";a1) ))


Explicação

CÉL("filename";a1) retorna o nome do arquivo com o nome da planilha depois do $.

NÚM.CARACT(CÉL("filename";a1) ) retorna o número de caracteres na expressão "tamanho do texto"

PROCURAR("$";CÉL("filename";a1))+1 retorna o posição do $ somando mais um

EXT.TEXTO(CÉL("filename";a1);PROCURAR("$";CÉL("filename";a1))+1;NÚM.CARACT(CÉL("filename";a1) )) retorna somente do texto informado o nome da planilha, pois e mando ele pegar depois do $ até o final do texto informado que é o nome da planilha.

editar assinalar como ofensivo Excluir Link mais
0

respondidas 2014-10-17 14:21:42 +0100

Estou com o mesmo problema. No meu caso, eu tenho uma planilha com resumos de diversas outras planilhas que podem possuir diversos nomes diferentes.

Estou criando a planilha de modelo e tenho 3 colunas na de resumo. Nome do Elemento \ Nome da Planilha \ Fórmula Complexa

Essa fórmula complexa faz diversas de operações calculando de outra planilha. Preciso que a fórmula considere a coluna nome da planilha para poder pesquisar.

Ex: Modelo! (é o nome da planilha) Fórmula é: =SE(ÉERROS(ÍNDICE(Modelo!$D$3:$BA$3;1;CORRESP($C5;Modelo!$D$3:$BA$3;0) + 2));"";ÍNDICE(Modelo!$D$3:$BA$3;1;CORRESP($C5;Modelo!$D$3:$BA$3;0) + 2))

No caso eu queria trocar o Modelo! da fórmula pela referência da planilha, tipo: "D$3" por exemplo, assim, se o usuário mudar o nome da planilha ele muda a fórmula automaticamente.

Alguém sabe uma solução?

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

2 seguidores

Estatísticas

Perguntadas: 2013-11-08 16:49:06 +0100

Lidas: 15,361 vezes

Última atualização: Oct 17 '14