Pergunte aqui
0

Macros de modelo não abrem automaticamente no writer na versão 4

perguntadas 2013-02-26 20:17:02 +0100

imagem do gravatar de polikpt

Estou a mudar do MSOffice para o Libre, e ainda com a versão 3.6 converti os modelos antigos de MSOffice para libre. Estes modelos possuiem macros que usando caixas de dialogo preenchem informação no modelo.

  • Na a versão 3.6 conseguia abrir um modelo ODT e as suas macros, escolhendo a opção modelos e clicando em cima do modelo que pretendia (gestor de modelos).
  • Na versão 4 as macros gravadas não abrem, e se as tentamos executar pelos menus surge a informação: "Por motivos de segurança, não pode executar esta macro.Para obter mais informações, verifique as definições de segurança."

Notas: Nas configurações defini a segurança de macros como baixa, e tornei o directório onde os modelos vão ser lidos como confiável.

Nota Final: Se pelo explorer carregar directamente no modelo ODT, este abre as macros sem problemas.

Alguma sugestão?

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

1 Resposta

0

respondidas 2013-03-05 01:15:57 +0100

imagem do gravatar de Olivier

Aparentemente este comportamento está errado e pode se tratar de um bug. O seletor de modelos foi alterado na versão 4 e pode ser que este problema de segurança não tenha sido detectado nos testes.

Pedimos então que relate o erro em nosso site especializado de bugs:

https://bugs.freedesktop.org/

Clique em "Enter a bug" e escolha LibreOffice da longa lista. Siga preenchendo o formulário para o relato do erro encontrado. Forneça o máximo de detalhes sobre o erro.

Esperamos que nas próximas versões tenhamos o erro corrigido.

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2013-02-26 20:17:02 +0100

Lidas: 367 vezes

Última atualização: Mar 05 '13