Pergunte aqui
0

Como formatar linha de acordo com valor de células?

perguntadas 2013-09-11 23:51:37 +0200

imagem do gravatar de JNooby

updated 2013-09-11 23:54:34 +0200

Estou desenvolvendo uma planilha simples para movimento de caixa, estou com seu esqueleto e com algumas dúvidas, uma delas é a respeito de como formatar uma linha de acordo com o valor ou informação de outra célula?

EX. Se minha célula C3 = RECEITA, toda linha "3" vai ficar com a fonte na cor azul; Se não, toda linha "3" vai ficar com a fonte vermelha.

A fórmula que cheguei (e não funcionou) foi essa: =SE(B3=1;ESTILO(A3:H3;;K1);SE(B3=0;ESTILO(A3:H3;;K2)))

Obrigado!

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

2 Respostas

0

respondidas 2013-09-12 18:04:20 +0200

imagem do gravatar de JNooby

Muito obrigado Oliver pela contribuição! Consegui resolver o problema usando Formatação Condicional como indicado, mas consegui a explicação em outro site ([Link do BabooFórum onde encontrei a resposta])(http://www.babooforum.com.br/forum/index.php?/topic/689557-como-colorir-linhas-no-excel-conforme-valor-da-celula/).

Usei Formatação Condicional dessa forma:

CONDIÇÃO 1: "a formula é" "$B3="RECEITA"" e aplico o estilo desejado.

A segunda condição faço com $B3="DÉBITO" e aplico o estilo desejado.

Pronto! Está melhor explicado no outro link e também pode-se criar mais condições.

editar assinalar como ofensivo Excluir Link mais
0

respondidas 2013-09-12 02:40:00 +0200

imagem do gravatar de Olivier

Utilize formatação condicional! Foi feita para isso.

Veja na Ajuda.

Obs. Você não poderá aplicar formatação condicional sobre uma linha (ou coluna), somente sobre células ou intervalos.

editar assinalar como ofensivo Excluir Link mais

Comentários

Ok, porém fiquei na mesma... Onde uso e como uso a formatação condicional para obter o resultado que desejo? Recorri aqui ao fórum pois não quis pesquisar na "ajuda" do programa.

imagem do gravatar de JNoobyJNooby ( 2013-09-12 15:32:45 +0200 )editar

Consegui usar a Formatação Condicional, mas ainda não atingi meu resultado... Quando a utilizo ela checa e edita as próprias células, porém o que preciso é que cada célula da linha cheque a C3, se for "RECEITA" o intervalo fica azul, se for "DÉBITO" fica em vermelho. Alguma dica?

imagem do gravatar de JNoobyJNooby ( 2013-09-12 17:17:42 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

Estatísticas

Perguntadas: 2013-09-11 23:51:37 +0200

Lidas: 20,458 vezes

Última atualização: Sep 12 '13