Pergunte aqui
0

CONT.SES para textos com caracteres curingas

perguntadas 2020-08-27 05:47:53 +0200

updated 2020-08-27 13:53:56 +0200

imagem do gravatar de Schiavinatto

Olá a todos!

Estou com um problema que está quebrando a minha cabeça... hehe

Tenho uma planilha que faço o acompanhamento de processos, e em uma das colunas lanço todos documentos produzidos para cada processo, como são muitos documentos, acabo lançando todos da mesma célula para cada processo, obviamente.

Sempre lanço da seguinte forma: "Data - Nome do documento - Descrição", para lançar um novo clico em Ctrl+Enter e assim por diante

Descrição da imagem

Ocorre que estou tentando gerar um relatório anual automático, para que ele me diga quantos documentos foram produzidos no mês de janeiro do ano corrente (01/2020).

Procuro pelo texto "01/20 - Despacho... Minuta de Ofício" (Tudo na mesma linha), mas só consigo o valor correto utilizando "expressões regulares", utilizando o texto "01/20 - Despacho.+Minuta de Ofício", considerando sempre a primeira parte do texto e a segunda na mesma linha.

=CONT.SES(A2:A5;CONCATENAR("01/20 – Despacho.+Minuta de Ofício")) = 1

Por caracteres curingas, utilizando o texto "01/20 - Despacho *Minuta de Ofício", conta até os valores em que o termo "Minuta de Ofício" fica em linhas seguintes, muitas vezes nem pertencendo a outros meses.

=CONT.SES(A2:A5;CONCATENAR("01/20 – Despacho")&("Minuta de Ofício")) = 3

Resumindo, eu quero que com "caracteres curingas" eu consiga obter o mesmo resultado que obtenho utilizando "expressões regulares", ou seja que só conte os casos em "01/20 - Despacho" e "Minuta de Ofício" estejam na mesma linha.

Segue anexo uma planilha de exemplo, lembrando que para alternar entre os cálculos por expressões regulares ou caracteres curingas, deve ser ir em "Ferramentas-Opções".

Inicialmente, eu estava utilizando "expressões regulares" para toda a planilha, entretanto, surgiu um problema em que fui obrigado a utilizar caracteres curingas.

Desculpa, caso tenha sido confuso... hehehe Obrigado pela atenção! C:\fakepath\CONT.SE com caractere curinga - Railton.ods

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

@Railton dos Santos Vasconcelos, acredito que não vá conseguir, pois existe 3 células com a informação, o CONT.SES não tem como saber se é a mesma linha, a analise é por célula.

Sugiro repensar o modo de lançar, se for em colunas fica mais correto.Descrição da imagem

imagem do gravatar de SchiavinattoSchiavinatto ( 2020-08-27 16:08:31 +0200 )editar

1 Resposta

0

respondidas 2020-09-19 15:57:05 +0200

imagem do gravatar de Jedison

updated 2020-09-19 16:20:34 +0200

Talvez a solução seja você criar colunas adicionais. Se as expressões que você procura aparecerão sempre no início (ou na mesma porção) dos seus textos, você pode usar as funções de texto [(DIREITA(), ESQUERDA() ou EXT.TEXTO()] para que a procura seja feita somente nesse determinado trecho, associadas às funções de procura [PESQUISAR()] para indicar a presença de cada uma das expressões. Por exemplo:

(PESQUISAR("01/2020 - Despachos"; ESQUERDA(A1;50) ; 1)>0) * (PESQUISAR("Minuta de Ofício"; ESQUERDA(A1;50); 1)>0)

Essa fórmula (ou semelhante, e que poderá ficar depois em uma coluna oculta ou até mesmo em outra aba) informará o resultado (1) em cada texto checado que contiver todas as expressões buscadas. Um SOMA(C1:C50) indicará quantas vezes o conjunto apareceu.

Um complicador (que vi agora relendo a sua pergunta) é que um mesmo processo terá várias informações sobre os documentos, que você separa com CRTL+ENTER. Daí teria que estabelecer um limite de quantas vezes isso acontece em cada processo, criando colunas distintas. Daí você pode usar a mesma função PESQUISAR() para localizá-la [use a função CARACT(10)] dentro do texto da célula, para saber onde deve começar e terminar cada checagem, e daí usar o EXT.TEXTO() em vez de ESQUERDA(). A partir disso, criar tantas colunas quantas necessárias para a função anterior de consulta. O resto, acho que você já entendeu. Se não, pergunte.

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

2 seguidores

Estatísticas

Perguntadas: 2020-08-27 05:47:53 +0200

Lidas: 21 vezes

Última atualização: Sep 19