Início LibreOffice mais rápido!!!!!

perguntadas 2013-12-08 01:30:39 +0200

updated 2013-12-08 01:37:13 +0200

Só compartilhando,

Vi em Yahoo perguntas, alguém questionando, porque o LO era tão grande (quase 532 MB), e se existia algum equivalente mais leve. Responderam para usar Apache OpenOffice (4.0.1), compactado 174 MB e instalado ± 300MB, fiquei curioso, baixei instalei, e é verdade, inclusive abria bem mais rápido que o LO 4.1.2.3 (WinXP) instalado.

Abri os dois diretórios de instalação, e comecei a comparar arquivos e pastas. No LO de imediato tem a pasta fonts, no OO não tinha, então joguei as fonts do LO para o diretório do Win, e deletei a pasta. Em seguida notei que determinadas pastas do LO tinham dezenas/centenas de pasta que referenciava a linguagens diferentes de pt-BR, então percorri todas as pastas e deletei todos arquivos ou sub-pastas que não fossem pt-BR.

Resultado o LO (atualmente com 411 MB) esta abrindo bem mais rápido, agora igual ao OO.

Pergunta: Será que na hora de instalar fiz algo errado, ou todos arquivos que deletei ( calculo ± 5 mil ), realmente vem com a instalação ?

Alguém sabe esclarecer ?

============ .

link pergunta: http://br.answers.yahoo.com/question/index?qid=20131206120621AAxhptw

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Não achei a pasta fonts no LO... (Win7). E creio que as fontes que vem no LO são instaladas no sistema do Win7 por que estão disponíveis para todos os aplicativos. Sobre as pastas que referenciavam outros idiomas, seria a pasta de autocorreção?

imagem do gravatar de OlivierOlivier ( 2013-12-08 11:07:08 +0200 )editar

Há de se tomar certo cuidado com medições sem métricas definidas. Há muitas variáveis envolvidas e fazer um uma comparação científica pode levar tempo e recursos. Por exemplo, invocar na segunda vês o LO pode ser mais rapido por que as dll's já estão na memória....

imagem do gravatar de OlivierOlivier ( 2013-12-08 11:10:16 +0200 )editar

Tem como indicar onde achou os 5000 arquivos a mais no LO?

imagem do gravatar de OlivierOlivier ( 2013-12-08 11:11:07 +0200 )editar

Olivier, creio que descobri o meu erro. Há algumas versões atrás, qdo tentava instalar o arquivo.msi diretamente da erro, não me recordo o numero que informava, pesquisei na internet e achei a informação para instalar com o comando (no WinXP) Iniciar / Executar / msiexec /a Caminhodoarquivo\arquivo.msi, este comando funciona, mas só pergunta o local da instalação. Por curiosidade instalei o LO42, ficou o Tamanho em disco 1,13 GB com 69.121 arquivos. (continua)

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2013-12-09 01:12:33 +0200 )editar

Fiz o processo de limpeza da instalação, como mencionei anteriormente, o Tamanho em disco caiu para 427 MB e 4.337 arquivos. Como não tinha o que fazer, tentei a instalação como fazia antes do arquivo de instalação ser .msi . Cliquei nele e mandei executar, para meu espanto, iniciou o processo de instalação e deu a opção de instalar ou não as linguagens extras, escolhi não, o processo continuou. A instalação ficou com 453 MB e 7924 arquivos. (continua)

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2013-12-09 01:21:17 +0200 )editar

Comparei as duas instalações e reparei que a segunda instalação esta com quantidade de arquivos bem superior a instalação primeira após processo de limpeza. Na pasta //share/autocorr ele manteve todos os arquivos, na pasta //share/autotext ele manteve todas as subpastas vazia exceto as pt e pt_BR. não comparei o restante para descobrir o que ainda esta a mais. Em tempo a pasta fonts também não instalou. Parte do que esta a mais, é que a instalação manteve arquivos pt e pt-BR.

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2013-12-09 01:34:40 +0200 )editar