Fórmulas do Libreoffice do Windows que não funciona no Ubuntu [fechado]

perguntadas 2021-02-07 19:56:30 +0200

imagem do gravatar de Babá Marulo

updated 2021-02-12 04:23:39 +0200

imagem do gravatar de Schiavinatto

A formula abaixo funciona no Calc libre do Windows, porem não funciona no Ubuntu, alguém poderia me dizer como soluciono isso?

=SE(E(J5="FÉRIAS";BV2:BX7);PROCV(D20;BV2:BX7;2;FALSO());SE(E(J5="PATERNIDADE";BV2:BX7);PROCV(D20;BV2:BX7;3;FALSO());SE(E(J5="CONVALESCENÇA";BV2:BX7);PROCV(D20;BV2:BX7;3;FALSO());SE(E(J5="NÚPCIAS";BV2:BX7);PROCV(D20;BV2:BX7;3;FALSO());SE(E(J5="INSTALAÇÃO";BV2:BX7);PROCV(D20;BV2:BX7;3;FALSO());SE(E(J5="ESPECIAL";BV2:BX7);PROCV(D20;BV2:BX7;3;FALSO());SE(E(J5="LUTO";BV2:BX7);PROCV(D20;BV2:BX7;3;FALSO());SE(;BV2:BX7))))))))

Anexado o arquivo, tem duas planilhas, onde uso a primeira "Papeleta", com base nas informações constantes no "Dados", tem Validação na parte do Nome (Fulano de Tal), a qual faz alterações em alguns itens através de fórmulas, no meu computador em casa que é Windows tudo funciona, porém no trabalho que é Ubuntu e a versão do Libre é meio diferente, acredito desatualizada, e cheia de restrições por ser empresa, alguns itens não funciona, principalmente a parte da fórmula citada acima no DESMUNICIADO que dá um Erro que não me recordo o qual agora, então acredito que ou é incompatibilidade com o Ubuntu ou o Libre muito antigo, precisando ser atualizado, mas como sou leigo no assunto, gostaria de ter opiniões de especialista. Aproveitei e mandei uma planilha de Controle de Acesso, feita por um amigo aqui do Fórum, que tá dando erro aqui qdo tento abrir, e será que também não funcionaria no Ubuntu! Desde já agradeço ajuda.

https://ask.libreoffice.org/upfiles/1...

https://ask.libreoffice.org/upfiles/1...

editar alterar tag assinalar como ofensivo reabrir mesclar Excluir

Fechado pelo seguinte motivo Pergunta duplicada por Babá Marulo
data do fechamento 2021-02-28 22:34:48.929309

Comentários

Ola @Babá Marulo, poste um arquivo exemplo, só formula é difícil analisar sem os parâmetros.

Edite sua pergunta e com o ícone clipe anexe o modelo.

Acusa algum erro ?

imagem do gravatar de SchiavinattoSchiavinatto ( 2021-02-07 23:41:50 +0200 )editar

@Schiavinatto meu querido acabei de editar e enviar.

imagem do gravatar de Babá MaruloBabá Marulo ( 2021-02-08 01:02:41 +0200 )editar

No primeiro arquivo tem uma inconsistência em uma macro: No modulo LancarDados a macro NovaAcao tem uma variável com o mesmo nome da Macro. Aqui da esse erro na abertura do arquivo.

A formula acima onde esta, na planilha?

Abri em Linux Mint 19.3 LibreOffice 6.4.7.2.

imagem do gravatar de SchiavinattoSchiavinatto ( 2021-02-08 01:52:39 +0200 )editar

@Schiavinatto está na planilha PAPELETA, parte abaixo onde está escrito DESMUNICIADO, SIM ou NÂO, justamente a fórmula é de acordo com alguns dados ela tem que aparecer, SIM ou NÂO, no Windows está certinho, porém no Ubuntu aparece como Erro,,,!

imagem do gravatar de Babá MaruloBabá Marulo ( 2021-02-08 02:07:15 +0200 )editar

@Schiavinatto deu pra entender aí o que desejo, editei de novo, excluir o arquivo Papeleta e incluir de novo corrigida, com dados de nomes os últimos diferente, justamente para a parte da fórmula do DESMUNICIADO funcionar no caso os últimos nomes em situação de Férias tem que aparecer SIM, demais e todas as situações é NÃO!

imagem do gravatar de Babá MaruloBabá Marulo ( 2021-02-08 02:22:43 +0200 )editar

Sobre o erro que a macro acusou na abertura do arquivo:

A variável esta com o nome da Macro.

Descrição da imagem

imagem do gravatar de SchiavinattoSchiavinatto ( 2021-02-08 04:10:14 +0200 )editar

É DESMUNICIADO = SIM; quando for FÉRIAS e ( CB ou MN )

o restante é NÃO,

conforme a Tabela: BV2:BX7

Se for isso a formula é =SE(E(J5="FÉRIAS";OU(D20="CB";D20="MN"));"SIM";"NÃO")

imagem do gravatar de SchiavinattoSchiavinatto ( 2021-02-08 04:27:47 +0200 )editar

@Schiavinatto meu querido vou testar no trabalho, e depois dou uma resposta, muito obrigado pelas informações de ambas as dúvidas!

imagem do gravatar de Babá MaruloBabá Marulo ( 2021-02-10 02:19:52 +0200 )editar