We will be migrating from Ask to Discourse on the first week of August, read the details here

Pergunte aqui
0

Procv de outro ficheiro calc

perguntadas 2021-04-15 18:03:56 +0200

imagem do gravatar de davidleal

updated 2021-04-19 23:55:12 +0200

imagem do gravatar de Schiavinatto

Viva.

Estou a criar uma folha de Calc onde vai buscar os valores de outro ficheiro calc mas no final da formula ele acrescenta automaticamente mais dois (). O que se passa?

FALSO())

esses dois () não fazem parte da formula original.

$A$2:$I$100;2;FALSO())

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

1 Resposta

1

respondidas 2021-04-15 21:34:34 +0200

imagem do gravatar de Schiavinatto

updated 2021-04-15 21:37:46 +0200

Use =PROCV($A$2:$I$100;2;0)

O zero final equivale a FALSO

  • 0 significa que listas esta desordenada ( busca exata )
  • 1 significa que lista esta ordenada ( se não encontrar exata pega por aproximação )

Se indicar 1 e a lista estiver desordenada a resposta não é confiável, portanto sempre uso 0, se não encontrar exata gera #N/DISP ( Erro: Valor não disponível ).

Ajuda:

https://help.libreoffice.org/6.4/pt-B...

editar assinalar como ofensivo Excluir Link mais

Comentários

Eu testei também com zero e realmente funciona! Só fiquei na dúvida por que razão ele coloca mais entre parênteses na formula se aquela formula com o "falso" faz parte da sintaxe.

imagem do gravatar de davidlealdavidleal ( 2021-04-17 18:04:22 +0200 )editar

Acho que a célula estava formatada como valor lógico.

Eu sempre uso 0 ou 1 é mais pratico.

imagem do gravatar de SchiavinattoSchiavinatto ( 2021-04-17 18:57:03 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2021-04-15 18:03:56 +0200

Lidas: 17 vezes

Última atualização: Apr 15