Pergunte aqui
0

Projeto Prevenção Incêndio

perguntadas 2015-08-08 14:20:52 +0200

imagem do gravatar de GuilhermeCervantes

Olá me chamo Guilherme e estou com uma dúvida "filosófica".

Estou fazendo um programa no Calc que me diz para vários tipos de ocupação qual os sistemas de Prevenção de Incêndio que devo prever, está tudo muito tranquilo mas quero transformar ele num TCC de Eng. Civil e tornar ele programa de fato. O programa é simples depois de definido algumas características da edificação ele deve escolher os sistemas e decidir dentro de um mar de condições se deve ou não ter esses sistemas. No LibreOffice Calc é uma questão de trabalho duro mas relativamente simples definir cada condicional e está funcionando.

A pergunta está se para tornar essa solução mais segura e profissional vale apena passar para o BASE e fazer um banco de dados com todas essas condicionais? É possível todas essas condições ou devo continuar? Quero que no futuro esse seja o sistema de minha empresa.

a idéia é

1 . Definir a edificação e suas caraterísticas

2 . Com a edificação definida escolher dentro de muitas condições de NBR e outras normas os sistemas

3 . Gerar relatórios e Laudos

Ps: não tenho medo de arregaçar as mangas e aprender LibreOffice Base ou qualquer outro sistema!

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

2 Respostas

0

respondidas 2015-08-18 23:12:00 +0200

Guilherme, sugiro ficar no Calc: sua ideia inicial,

1 . Definir a edificação e suas caraterísticas

2 . Com a edificação definida escolher dentro de muitas condições de NBR e outras normas os sistemas

3 . Gerar relatórios e Laudos

Em 1 . Criar tabelas; em 2 . Usar funções, por exemplo: SE, PROCV, DESLOC, SOMASE, CONT.SE etc, consultando as tabelas; em 3 . Formatar relatórios para autopreenchimento com as informações resultantes.

Posso ter ajudar, no meu perfil tem e-mail direto.

editar assinalar como ofensivo Excluir Link mais
0

respondidas 2015-08-17 19:49:11 +0200

imagem do gravatar de Beto

updated 2015-08-18 13:00:26 +0200

Acho que a função SE(Teste; ValorEntão; ValorSenão) deveria dar conta de algo assim. Ex: =SE(A1=20;"Opção Certa";"Opção Errada")

Esta função pode ser recorrente inclusive, testando duas células como A1 e B1 (por exemplo), se as mesmas contem os valores 20. Ex =SE(A1=20;SE(B1=20;"as duas estão Certas";);"Erro em uma das células")

Sucesso em seu projeto!

Ops, esqueci de dizer o principal, na minha experiência com o base muitos anos atrás, foi frustrante, só corrupção de arquivo. Perdi muito trabalho, não sei o que era ou por que dava isto, mas perder um banco de dados algumas vezes de dá medo suficente de tentar de novo... O calc, acho uma excelente ferramenta.

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2015-08-08 14:20:52 +0200

Lidas: 51 vezes

Última atualização: Aug 18 '15