Pergunte aqui
0

Função criada =BETO() não tranforma strings em fórmula

perguntadas 2015-11-27 19:33:47 +0100

imagem do gravatar de Beto

updated 2016-02-02 21:20:23 +0100

Fiz uma concatenação (utilizando a função =CONCATENAR()) de strings que resultava em =PROCV(AA3;Planilha1.A3:B5120;2;0), e depois utilizei a função criada pelo nosso colega Olivier, para me ajudar: =BETO(), e percebi que ela só está funcionando com números (a exemplo da função =INDIRETO().

Abri um arquivo onde tinha a função gravada e ao abri-lo dá o erro da figura abaixo. Acho que deu alguma incompatibilidade com a versão 4.

No caso das strings a função =BETO() devolve: =procv(AA3;Planilha1.A3:B5120;2;0), com a função em minúsculas. Basta tirar um parêntese e adicioná-lo de novo que a célula reconhece o texto como fórmula...

Aqui temos a função gentilmente criada pelo nosso colega Olivier.

Descrição da imagem

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

1 Resposta

1

respondidas 2015-11-28 18:12:31 +0100

imagem do gravatar de Olivier

Refiz a situação com um exemplo e só consegui que funcione usando o nome em inglês da função PROCV, que é VLOOKUP.

Isso porque na API do LibreOffice a propriedade Formula ( e portanto o método setFormula() ) só vale para os nomes originais em inglês.

Todo dia uma novidade....

editar assinalar como ofensivo Excluir Link mais

Comentários

"Todo dia uma novidade..." Exatamente... através da extensão Xray acabo de descobrir que existe a propriedade FormulaLocal que se mostra "tolerante" às fórmulas em pt-br. Exemplo:

oCelula.FormulaLocal = "=SOMA(A1:A10)"
imagem do gravatar de GrafenoGrafeno ( 2016-05-08 18:06:07 +0100 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2015-11-27 19:33:47 +0100

Lidas: 123 vezes

Última atualização: Feb 02 '16