Pergunte aqui
0

formatar lista de validação onde as datas são mostrados como números

perguntadas 2015-12-10 17:33:40 +0100

imagem do gravatar de Leandro Vieira

updated 2016-05-04 05:00:54 +0100

Olá pessoal! Estou criando uma planilha, e utilizei o recurso validação com a seguinte fórmula: SE(D8="";data1;DESLOC(data1;CORRESP(D8;data1;0)-1;0;CONT.SE(data1;D8);1)) me surgiu um obstáculo, que foi o seguinte:

Descrição da imagem

A célula D8 é a que está abaixo do campo "Data". Outro sim, como faço para contar as datas maiores que a da célula D8?

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Leandro, por gentileza, poste o arquivo acima em alguma nuvem, tentei simular o exemplo acima e não consegui....

imagem do gravatar de SchiavinattoSchiavinatto ( 2015-12-16 22:53:41 +0100 )editar

Enviei o link para o seu e-mail.

imagem do gravatar de Leandro VieiraLeandro Vieira ( 2015-12-18 00:27:47 +0100 )editar

1 Resposta

0

respondidas 2015-12-18 02:10:58 +0100

updated 2015-12-18 02:34:40 +0100

É fácil: Vá em D8, copiar, vá em G8 e Editar / Colar especial..., na coluna Seleção só marque [V] Formatos e OK. Era só problema de formatação, como em D8 estava certo só copie para G8.

Descrição da imagem.....Descrição da imagem

Falta a contagem: estou analisando...... a formula é: =CONT.SE(data1;">"&D8)

editar assinalar como ofensivo Excluir Link mais

Comentários

Na verdade, gostaria de utilizar a fórmula que citei, aninhada a que me indicou para contar as datas maiores que D8 "=SE(D8="";data1;DESLOC(data1;CORRESP(D8;data1;0)-1;0;CONT.SE(data1;">"&D8);1))". Porém me retorna número decimal, não mais o formato numérico das dadas, Copiando e colando o formato da célula D8 não retornar o resultado que preciso, que no caso seria retornar todas as datas do intervalo "data1" maiores que D8.

imagem do gravatar de Leandro VieiraLeandro Vieira ( 2015-12-20 18:45:20 +0100 )editar
1

A célula D8 nomeei para DataSeleção (para ficar mais fácil usa-la), na aba Levant. de estoque na célula D2 montei a fórmula =SE(D9>DataSelecao;D9;"") e copiei até CT2. Esta área dei o nome de Datamaiores. E formatei esta área com a cor do texto em branco (a informação fica invisível). Na célula G8 da aba Resumo em Dados / Validação em Critérios/Permitir [Intervalo de células] [V] Mostrar e Ordenar. e Origem [Datamaiores].O resultado desejado é esse???

imagem do gravatar de SchiavinattoSchiavinatto ( 2015-12-23 02:19:15 +0100 )editar

@Leandro Vieira, com certeza existe uma maneira de fazer esta seleção por fórmula, mas nos meus testes não cheguei a uma solução. Favor comentar...

imagem do gravatar de SchiavinattoSchiavinatto ( 2015-12-23 02:22:49 +0100 )editar
1

Agradeço pela solução, que resolveu meu problema. Gostaria de marcar este comentário como a resposta correta, ou se for possível colocá-lo no lugar da resposta anterior. O estranho é que, a fórmula citada em meu comentário funciona perfeitamente com palavras e números somente com o formato das datas e que houve este erro, que é um ponto a ser aperfeiçoado no programa.

imagem do gravatar de Leandro VieiraLeandro Vieira ( 2015-12-23 14:37:15 +0100 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2015-12-10 17:28:33 +0100

Lidas: 166 vezes

Última atualização: May 04 '16