Pergunte aqui
0

Onde está o erro na fórmula?

perguntadas 2016-04-22 03:16:33 +0200

imagem do gravatar de Walseley

updated 2016-04-27 05:56:42 +0200

Estou preparando um trabalho no Calc, é tipo uma folha de pagamento. São cinco planilhas e os cálculos são feitos entre elas. O problema está em aninhar SE e PROCV. O resultado da busca só aparece na primeira comparação, sendo que nas demais o resultado é R$ 0,00. Já tentei E e OU junto ao SE e, também 0 e 1 na ordem do PROCV. Nada deu resultado satisfatório.

A fórmula, que é passada da linha 11 até a 76, compara "ano de admissão" (B11) na plan1 com "ano" (F11 a L11) na plan2, se a comparação for verdadeira faz busca de "hierarquia" (F11) da plan1 na matriz (C12:L25) e retorna "valor do salário" (Índice 4 a 10) da plan2, senão recomeça comparando "ano de admissão" com "ano-1" e assim vai em sete sequencias.

Segue a fórmula:

=SE(B11=$'AS - Ajustes Salariais'.$F$11;PROCV(F11;$'AS - Ajustes Salariais'.$C$12:$L$25;4);SE(B11=$'AS - Ajustes Salariais'.$G$11;PROCV(F11;$'AS - Ajustes Salariais'.$C$12:$L$25;5);SE(B11=$'AS - Ajustes Salariais'.$H$11;PROCV(F11;$'AS - Ajustes Salariais'.$C$12:$L$25;6);SE(B11=$'AS - Ajustes Salariais'.$I$11;PROCV(F11;$'AS - Ajustes Salariais'.$C$12:$L$25;7);SE(B11=$'AS - Ajustes Salariais'.$J$11;PROCV(F11;$'AS - Ajustes Salariais'.$C$12:$L$25;8);SE(B11=$'AS - Ajustes Salariais'.$K$11;PROCV(F11;$'AS - Ajustes Salariais'.$C$12:$L$25;9);SE(B11=$'AS - Ajustes Salariais'.$L$11;PROCV(F11;$'AS - Ajustes Salariais'.$C$12:$L$25;10))))))))

Por favor, onde estou errando? Qual a solução para o problema?

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Oi, @Walseley é possível disponibilizar as planilhas, se houver dados confidenciais altere-os...fica mais fácil analisar diretamente na planilha.

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2016-04-22 04:32:15 +0200 )editar

@Walseley você comenta "....compara "ano de admissão" (B11) na plan1 com "ano" (F11 a L11) na plan2, se a comparação....", menciona duas planilhas, mas na fórmula divulgada só aparece referencia para a planilha "AS - Ajustes Salariais". Se disponibilizar a planilha, com certeza um de nós vai achar o erro.......................

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2016-04-23 02:34:43 +0200 )editar

Gilberto, acabei de mandar a planilha por e-mail para você dar uma olhada. Fico muito grato pelo auxílio.

imagem do gravatar de WalseleyWalseley ( 2016-04-23 05:42:48 +0200 )editar

2 Respostas

0

respondidas 2016-04-26 02:06:23 +0200

updated 2016-04-26 02:07:29 +0200

  1. Crie tabela: ano | coluna ; 2010 | 4 ; 2011 | 5 ; 2012 | 6 ; 2013 | 7 ; 2014 | 8 ; 2015 | 9 ; 2016 | 10.
  2. Nomeia a tabela criada: "anocoluna"
  3. Na aba [ AS - Ajustes Salariais ] nomeie a área "C12:L25" para: "AjustesSalariais"
  4. Na aba [ RESUMO GERAL ] na célula H11 a formula é: =PROCV('RESUMO GERAL'.F11;AjustesSalariais;PROCV('RESUMO GERAL'.B11;anocoluna;2;0);0) , em substituição a sua fórmula, e replicar para baixo.

Seguiu o arquivo em devolução.

editar assinalar como ofensivo Excluir Link mais

Comentários

Gilberto, ótima solução para o problema. Obrigado pela ajuda. Resolvido meu problema, além de fazer crescer meu conhecimento sobre Calc.

imagem do gravatar de WalseleyWalseley ( 2016-04-26 04:38:25 +0200 )editar
0

respondidas 2016-04-22 14:56:11 +0200

imagem do gravatar de Olivier

Use o analisador de fórmula do LibreOffice Calc 5.1 para descobrir onde sua formula está pegando:

Descrição da imagem

editar assinalar como ofensivo Excluir Link mais

Comentários

Caro Oliver, no assistente não aparecem erros conforme mostrado acima, simplesmente responde ao primeiro range da pesquisa e zera os demais segmentos.

imagem do gravatar de WalseleyWalseley ( 2016-04-23 02:33:37 +0200 )editar

A imagem é ilustrativa e não foi para resolver. Olhe nas partes da fórmula da sua planilha que estão dando erro. O assistente permite desmembrar o problema até achar a parte que está errada.

imagem do gravatar de OlivierOlivier ( 2016-04-23 11:59:15 +0200 )editar

Vou tentar por aqui, mas sou um pouco inexperiente no Calc. Enviei minha planilha para o e-mail do Gilberto que ficou de dar uma palinha, se houver interesse, posso enviar para que você dê uma olhada. É um trabalho para a faculdade e a exigência é básica mas resolvi complicar um pouco e estou sofrendo com a falta de experiência. Agradeço imensamente o repasse de conhecimento.

imagem do gravatar de WalseleyWalseley ( 2016-04-23 19:10:06 +0200 )editar

Caro, Walseley, coloque seus arquivos onde qualquer um possa baixar e ajudar, caso não tenha um repositório pegue este convite do Dropbox e compartilhe o arquivo. Dá para fazer isto através do Google, do Mega, todos são gratuitos

imagem do gravatar de BetoBeto ( 2016-04-25 14:30:41 +0200 )editar

Beto, positivo, a idéia dos repositórios é excelente para podermos repassar nosso arquivos. É que eu ainda estou aprendendo a caminhar por essas plagas. De qualquer forma, obrigado pela força.

imagem do gravatar de WalseleyWalseley ( 2016-04-26 04:32:46 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2016-04-22 03:16:33 +0200

Lidas: 363 vezes

Última atualização: Apr 27 '16