Pergunte aqui
3

Usar caracteres coringa em fórmulas

perguntadas 2016-06-10 19:53:18 +0200

imagem do gravatar de Tales Tomaz

updated 2016-07-31 16:01:11 +0200

imagem do gravatar de Grafeno

Olá,

No Excel dá para fazer uma fórmula e utilizar caracteres coringas (como * e ?). Entretanto, estou tentando criar uma fórmula semelhante no Calc e não estou conseguindo.

Vocês sabem como isso funciona no Calc?

O que eu quero no Excel seria assim: CONT.SE(A1:A5;"A*"). Essa fórmula retornaria o número de vezes em que ocorre uma célula cuja primeira letra é A.

Alguma pista?

Agradeço a ajuda!

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

2 Respostas

3

respondidas 2016-06-10 20:42:37 +0200

imagem do gravatar de Leandro Vieira

Sim, primeiro veja se a opção no menu FERRAMENTAS/ OPÇÕES/ LIBREOFFICE CALC/ CALCULAR está configurada para essa busca:

Descrição da imagem

Depois use "A.*"

Descrição da imagem

editar assinalar como ofensivo Excluir Link mais

Comentários

Obrigado! Funcionou mesmo. Mas agora me surgiu uma outra questão: se eu montar a planilha dessa forma e abir no Excel (preciso compartilhar o arquivo), o Excel irá conseguir ler a fórmula? Tentei no Google Spreadsheets e ele não conseguiu ler/converter. E outra questão que ficou é que eu tentei usar a mesma ideia do ponto antes do "?" e não funcionou. É diferente para esse curinga? (Ex. no Excel: CONT.SE(A1:A5;"A???")

imagem do gravatar de Tales TomazTales Tomaz ( 2016-06-10 20:58:36 +0200 )editar
3

Complementado a resposta do @Beto, a versão 5.2 do LibreOffice Calc (Agosto 2016) virá com os caracteres coringa compatíveis com o Excel e esta restrição será levantada. Permanecerão as duas opções de expressões regulares. https://goo.gl/AWJ26n

imagem do gravatar de OlivierOlivier ( 2016-06-10 21:04:15 +0200 )editar

Bom saber! Boa notícia mesmo para a próxima versão. Obrigado!

imagem do gravatar de Tales TomazTales Tomaz ( 2016-06-10 21:08:59 +0200 )editar
2

As expressões regulares do LibreOffice Calc são muito mais poderosas que as do Excel, mas também são bem mais komplikadas de lembrar se não usá-las todo dia. Busque "Expressão regular" na ajuda para a lista extensa delas.

imagem do gravatar de OlivierOlivier ( 2016-06-10 21:10:45 +0200 )editar

Dei uma olhada agora e fiz uns testes. Parece muito mesmo. Imagino que não existam todas essas opções para Excel, né? A questão pra mim acaba sendo mais compatibilidade, porque tenho que trocar arquivos frequentemente com colegas de trabalhos e eles só usam Excel. Mas aos poucos vai dando certo.

imagem do gravatar de Tales TomazTales Tomaz ( 2016-06-10 21:18:21 +0200 )editar

Agradeço tales-tomaz pelo feedback!

imagem do gravatar de Leandro VieiraLeandro Vieira ( 2016-06-13 13:58:22 +0200 )editar
3

respondidas 2016-06-10 20:52:20 +0200

imagem do gravatar de Beto

Use a seguinte fómula =CONT.SE(C1:C15;"A"&".*") , Para mim, dá caractere_coringa_calc.odscerto. Boa sorte.

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2016-06-10 19:53:18 +0200

Lidas: 1,140 vezes

Última atualização: Jun 10 '16