Pergunte aqui

Perfil de Sulphur Firedot - atividade

2020-07-19 20:13:33 +0100 Medalha recebida  Pergunta famosa (fonte)
2019-01-13 15:53:40 +0100 Medalha recebida  Pergunta notável (fonte)
2019-01-12 21:13:07 +0100 Marcada como a melhor resposta How to make dictionary corrections use correct apostrophe?

I have LibreOffice Writer set to convert straight apostrophe's (', i.e. U+0027) to curly ones (’, i.e. U+2019). The "Replace" box is checked in Tools -> AutoCorrect Options... -> Localized Options -> Single Quotes. This works for the most part.

A problem, however, is that when I misspell a contraction or possessive, the dictionary suggests the correct word—but with the straight apostrophe. If I type "wouldnt" for instance, it suggests "wouldn't", not "wouldn’t", as it should.

How can I make the dictionary list the correct word with the correct (curly) apostrophe? Maybe there's some setting I'm missing?

I'm currently using LO Writer 6.1.4.2 in Ubuntu 16.04, though I've had this problem since time immemorial.

2019-01-12 17:13:02 +0100 Medalha recebida  Pergunta popular (fonte)
2019-01-12 01:30:57 +0100 Perguntou How to make dictionary corrections use correct apostrophe?

How to make dictionary corrections use correct apostrophe? I have LibreOffice Writer set to convert straight apostrophe'

2014-09-06 04:38:49 +0100 Medalha recebida  Pergunta boa (fonte)
2014-07-28 06:32:52 +0100 Medalha recebida  Pergunta famosa (fonte)
2014-07-28 05:49:37 +0100 Respondeu uma pergunta Always enable printing in reverse page order

It needs to be changed in the OS printer settings, so this answer only applies to Ubuntu or other distributions that use the same GNOME printer settings. In System Settings, select Printers. Then right-click on the individual printer you want to change and go to Properties. Select Job Options from the right hand side, then under Common Options click the arrow next to More. Finally there will be a setting Output order, which can be changed to Reverse.

2014-07-28 05:43:40 +0100 Medalha recebida  Pergunta notável (fonte)
2014-03-07 03:45:50 +0100 Resposta comentada Always enable printing in reverse page order

If I check it, it works, but only while LibreOffice is open—then it is reset and off once again. But perhaps this is a setting that depends upon the printer and its drivers, not LO?

2014-03-07 03:44:25 +0100 Medalha recebida  Pergunta popular (fonte)
2014-03-01 02:03:45 +0100 Perguntou Always enable printing in reverse page order

When printing (in Writer, Calc, Draw, etc.), a box can be checked to have the last page printed first ("Print in reverse page order"), so that a multi-page document is ordered correctly when the printing is done.

Is there a way to always have this enabled? It's annoying when I forget to check the box and a long document needs to be manually collated. I'm currently using LibreOffice 4.1.3.2 on Ubuntu 13.10 if that matters.

2014-03-01 01:50:23 +0100 Medalha recebida  Torcedor (fonte)
2013-08-05 11:14:40 +0100 Medalha recebida  Pergunta famosa (fonte)
2013-08-05 11:14:40 +0100 Medalha recebida  Pergunta notável (fonte)
2013-06-19 00:34:46 +0100 Medalha recebida  Pergunta boa (fonte)
2013-06-05 12:07:11 +0100 Medalha recebida  Pergunta popular (fonte)
2013-02-11 18:23:18 +0100 Medalha recebida  Acadêmico (fonte)
2013-02-11 18:23:01 +0100 Resposta comentada Automatically place en (not em) dashes between numbers

It is unfortunate, but it looks like manually inserting en and em dashes is the best option. Those options look good, though I found what was easiest was to just set a compose key in my OS instead, so it works across all programs (Ubuntu 12.04: System settings -> Keyboard layout -> Options).

2013-02-08 00:06:24 +0100 Pergunta comentada Automatically place en (not em) dashes between numbers

Ah, gotcha. Thanks!

2013-02-08 00:05:52 +0100 Resposta comentada Automatically place en (not em) dashes between numbers

Thank you, but my AutoCorrect options are the same as yours. This help page notes the rules LibreOffice uses for converting hyphens to dashes, which apparently trump that option (it would do me little good anyhow, since I need both en & em dashes).

2013-02-08 00:01:48 +0100 Medalha recebida  Estudante (fonte)
2013-02-07 23:47:10 +0100 Medalha recebida  Editor (fonte)
2013-02-07 22:27:28 +0100 Perguntou Automatically place en (not em) dashes between numbers

When two hyphens (--) are placed between two numbers, LibreOffice changes them into an em dash, as it does between two words. The problem is that I use the Chicago style for all my work, which stipulates that an en, not em, dash should be used between numbers (like pages numbers and dates).

I want it to create an en dash instead.

I found this answer which shows how to convert them all, but it would be wonderful if it was automatic so I didn't have to periodically run that command. My workaround is to type number, space, --, number, and then go back and delete the space, but that's getting pretty tiring!

Note that the em dash should still be placed between two words (the default is correct here), so: word(em dash)word / number(en dash)number.

Thanks!