Cannot open Apple Pages documents

Using Office Libre version Using MacOS most current OS. Tried to open up a Pages document in Office Libre writer. It does not open. Tried more than one Pages document.
Any suggestions?
The tag for writer would not work so used tag that doesn’t fit.
Here is some more information per first comment request:
Via Finder I am not given option to select LibreOffice writer. It isn’t even listed as I scroll applications. But when I search in the applications dialog window it will show LibreOffice greyed out. I cannot select it.

If I open Libre office (which does run on computer), and do File > Open and select the Pages document: Libre “opens” the file technically as the name of the file is at the top of the window. BUT the document is blank. Nothing is there. Same result whether I just select document I know is *.pages or use the filter and then select.

  • How did you try to open (File - Open; via click in Finder on filename)?
  • Does LibreOffice run at all (without opening a file)?
  • Do you get any error messages?
  • Did you try to File -> Open and selecting Apple Pages (*.pages) in field Filter of the dialog?

Please do not use Add Answer but edit your original question to enhance the details of your question. Thanks in advance …

(PS: Modified tags)

Thanks for the update … Could you upload a sample .pages file?


seems you got hit by #tdf12357

Ok. But the link does not seem to offer a solution. Is there any fix? Thanks.

Read the link, and if there is a fix, then it is tracked in the bug report.

Will this be fixed? I checked the link, this is chinese to me. I have hundreds of .pages files i need to open.

What is Chinese with Status NEW which obviously is not equal to Status FIXED? Are you expecting other users of LibreOffice watching the status and inform you, if a fix is avalable?

image description

You have no reason to get irritated. New? February ‘19, or march 20’ for that sake, isn’t new. The link doesn’t give any information about this bug actually being taken care of. How am I suppose to know that open cases actually are followed up? My question was simply “will this be fixed”.

This problem is still not fixed.
If you don’t have a solution, please do not direct people to click on a link that leads to NO solution.
I haven’t programmed for 20 years but I can’t believe it’s this hard to solve this problem.
Apple is a giant corp. More and more people are sending their docs in .pages format.

Apple is a giant. Why does it choose to use proprietary formats? To lock its customers in.

This is a great answer to OP’s question.

I have the same problem.
Read the bug-report at #tdf12357 and see that it is being addressed at this moment: status FIXED (2021-05-16). Probably next release of LO will contain the fixed file.

You are right: there was recently (2021-05-18) a new release 0.1.10 of libetonyek, so hopefully it would land in the version 7.2 (still needs a commit to LibreOffice core to happen).

I’ve read high and low about this issue and finally got it working.

I’m running

  • Linux Mint 20.1 (based on Ubuntu 20.04)
  • LibreOffice
  • libetonyek 0.1.9

This issue seems to have been fixed in libetonyek 0.1.10, but that wasn’t included in the LibreOffice I installed by default.

I found the .deb package for the latest version here:

After installing this I can now see the content of .pages files