Delete a named range or at least set its proper range

I have found old questions on named ranges saying that I can delete a range by using Insert > Named Range or Expressions then using the delete button. On my Libre Office version 6.0.7.3 there is no delete button. All I can do is paste using that facility.

How do I delete a range.

I am having trouble with a named range. If I go to the top left of a sheet, Manage names dialog box, selects the whole column for a named range; the range shown in Named Range or Expressions shows the range as $0:$0 yes full column. However if I select from Data > Select Range I get O1:O108 which is what I want. My problem is that on another sheet a formula looks for this named rangeand gives results based on $O:$O.

I have tried deleting the range Data > Define Range (the only delete option I can find) but to no avail.

Any advice please?

Select Data>Set Range from the menu. In the “Set Database Area” dialog box, mark the name of the area to be deleted and click on “Delete”.

My version of Libre Office does not have Data>Set Range. I have Data > Define Range but there is not “Set Database Area” dialog box there.

I have used the “Define range” to delete the named range. Yes it is deleted from Data but the range still exists in Managed Names and shows in “Named Range or Expressions” How do I delete the range in these dialogs?

OK may have answer to delete range. In Menu > Sheet > Named Range or Expressions I can delete a named range. There are TWO places where Named Range or Expressions appears! Data and Sheet.

Now delete Range Name in Sheet then recreated in Data. Now formula works.

My version of Libre Office (6.0.7.3) does not have Data > Set Range . What version of Libre Office does have that facility?

With me Windows 10, Version 1809, 64-Bit | LibreOffice, Version: 6.2.0.3 (x64). Sorry, it is a translation from a German UI. It should be similar.

If I want to update Libre Office I am offered 6.1.5 not the later 6.2.0.3 you have.How I will update to 6.1.5 to see if that makes a difference. I see I can download 6.2.0.3 but for power users only?? Will try BTW mine is a 32bit setup.

Now updated to 6.2.0.3 but still no Data > Set Range