How to insert Greek and Hebrew characters into documents written in English using LibO 6.0.2

With my latest update, I can no longer directly insert characters from Biblical languages into my commentaries. This ability is necessary for my work. How do I get it back? I am using LibreOffice Writer 7 on Ubuntu.

What are “commentaries”? How do you inserted the characters in the previous version?

Please edit into your question your operating system and version, important information for the issue you’re having. Did you update LibO along with any other changes? It’s difficult to see how simply updating LibO could have this effect, since “international” keyboards are (normally) taken care of by the OS. Or (as implied in Regina’s comment), were you using some special, third-party keyboard?

Are you using a font that supports Greek and Hebrew characters? See link text . For example, this was inserted as Liberation Sans Greek ἓὧὠ. and this with LO sans Latin ᶙᶎᵷ, on a PC using Windows 7 and LO (I don’t understand these languages so I apologise if either has an unfortunate meaning). Are they OK on your PC?

Choose menu Insert - Special Character….

There was a change of names in version (see tdf#113590).

Add Answer is reserved for solutions. If you think the answer is not satisfactory, add a comment below, or click edit (below your question) to add more information. Thanks.

Check the mark (Answer markCorrect answer mark) to the left of the answer that solves your question.

If the answer helped you, you can mark the up arrow (Upvote mark) that is on the left (to vote, you need to have karma of at least 5).

I type Biblical Greek in LO under Ubuntu. I install ibus:

$ sudo apt-get install ibus ibus-m17n m17n-db m17n-contrib ibus-gtk

Include ibus in startup applications. Then go to settings-language&region-InputSources-Add-Other-greekAncientTo1453-add

set ‘Keyboard input method system’ to ibus

Toggle Greek keyboard entry by typing Super-Space. The keyboard mappings are fairly standard.

Thank you. This is the best answer so far.