[Impress] Presentation mode in second screen locked

Hi all,

I’m using LibreOffice (x64) on a Windows 10 laptop, and I’m having a problem with Impress.

I’ve a second monitor connected to the laptop.

When I switch to presentation mode, the laptop monitor (screen 1) starts the console, and the external monitor (screen 2) shows the presentation in full screen. But the presentation in the second monitor is locked, that is, I can’t switch from the first slide. On the lower right corner of this monitor, it shows this symbol, that I’ve never seen:

If I switch the presentation to monitor 1 and console to monitor 2, everything works fine.

Also, opening this presentation in the same laptop and same external monitor on Linux (dual boot machine), it works fine. And on Windows, the broken behaviour happens with all Impress presentations, not only with this one.

So it seems that I must have clicked in some kind of combination of keys and blocked the presentation. But I can’t find anything about this kind of issue.

Any hint?

Thank you very much!

On my desktop with two screens it works without any problems. It does not matter on which screen the presentation is requested.


With me Windows 10 Home; Version 2004; 64-Bit | LibreOffice, Version: (x64).

Hi ebot,

It worked also here for long time, and because of that I believe it could be some kind of keys combination I [or my daughter] have done.

@PedroNGV , have you checked the settings under Slide Show>Slide Show Settings... menu?

image description

Yes @Hrbrgr, I’ve everything like you. Also Tools → Options → LibreOffice Impress → General seems ok. I’ve compared with Linux version that’s fully functional, and are all equal.

If I understood it correctly, the error only occurs under Windows 10.

  • Are possible (graphic) drivers not up-to-date?
  • How current are your Win10 updates?

It’s a bit of a fog.

Hi @Hrbrgr

In fact, I have updated my win10 and my nvidia drivers last week, so the reason could be that.