Is it possible to adjust the scrolling speed in all LibreOffice apps?

Horizontal and vertical scrolling speeds are fast.

Within Calc: vertical scrolling jumps ~40 rows; horizontal scrolling jumps ~20 columns
Within Writer: vertical scrolling jumps half a page

My goal is to make scrolling become less rapid

Operating system properties for scrolling have been reviewed. The discussed scrolling speeds do not carry over into either Chrome or Microsoft Office applications.

Please provide direction to necessary sections of coding or Option settings (although I have already done a quick review of LibreOffice Option settings)

Thank you for reviewing this topic

Nate

Which OS are you using?

I consider that scrolling speed is controlled by your OS.

I have just started using Libreoffice with a new Dell XPS laptop and noticed the too-fast-scrolling myself with the trackpad. I tried to upvote but since I just joined I was unable to.

LibreOffice is awesome but the most annoying feature is how poorly it handles mouse scrolling. I generally use a touchpad and scrolling is so chaotic it almost makes me want to go back to Word. I checked around the forums and the devs seem to think they fixed this bug. I do not experience this problem with any other program. It is definitely a bug with LibreOffice.

It’s 2017 & this problem persists. I just switched to LibreOffice from OpenOffice ( Windows 8.1), & scrolling speed with my trackpad is so fast it’s useless: I must use the down arrow. I adjusted the trackpad settings, and yes, that slows it down, but also in all other apps where it was normal. So now those apps are painfully slow. Using an external USB mouse works fine. This must be a bug in LibreOffice, and I hope there is a developer who takes on fixing it! Thank you all for your hard work.

I recently spoke with the developer of Smooze (a configurable mouse/scroll manager for macOS) to see if anything could be done about the horizontal scroll in LibreOffice. Unfortunately, it seems that LibreOffice has its own scroll implementation which is NOT controlled by the OS. This should really be considered a serious UX/UI deficiency and should be tended to.

I’m actually having a slightly opposite issue with my El Capitan mac and LO 5.3… where trying to scroll “down” or “right” is painfully unresponsive unless I mash it. But scrolling “up” and “left” is as responsive as it is in all other apps. Clearly the scrolling implementation in LO is buggy, lacking, broken. I hope they do fix it, as its the one thing right now blocking me from bailing entirely on MSO and going to LO.

You might have a recent mouse with “Smooth scrolling” feature (or similar)… it is implemented sending much more wheel events and then scrolling less for each one on the application side, and in Chrome a plugin is installed for that effect. I know I de-activated mine because the applications response to the “new” events was not consistent and in the end I prefer to have the old “blocky” scroll which works everywhere than having “smooth” scrolling but only in a subset of applications.

I am having this issue with a Logitech MX2 Anywhere mouse.

It didn’t happen with my old Microsoft mouse.
This mouse has no issues with other applications.

I would suggest that this is an ongoing problem, and it appears to be device-specific? (I’ve noticed a lot of folks talking about the trackpad, mainly.)

I wanted to upvote this, but couldn’t, because I’m new. (I’ve been a user for over a year, but I’m new to the forums.)

Did you want to state that none of the answers already given did work for you? If so, upvoting anything wouldn’t be ueseful or resonable at all.

If you suspect it’s a bug of LibO, you need to go to bugs@libreoffice.org and find out if the bug is already reported. If so you can comment on it there, if not you can create a report.

(This thread was visited thousands of times in more than 4 !/2 years and nobody linked to a bug. The many “metoo” contributions won’t help anybody. This is not a bug tracking site)

Agreed. I have filed bug report #130303 for this problem in Windows, today 30jan20

I am having the same problem in OS X. I can’t use scrollwheels. Too painful. Too painful by far. I use a special scrolling app. I have reasonable scrolling speeds in other apps, but now suddenly have lightning-fast migraine-worsening scrolling speeds, and no control in LibreOffice.

If you have the same problem why didn’t you rather upvote the original question rather than providing a non answer?

If you are on linux (and maybe even on a mac) then this might set your scrolling speed slower (copy paste it into a terminal window):

env SAL_USE_VCLPLUGIN=gtk libreoffice --writer

It sets the environment variable ‘SAL_USE_VCLPLUGIN’ to the value ‘gtk’ and then launches libre office writer.
From what I understand this changes how libre office looks and behaves on input. So it changes how it gets the mouse input and makes the speed functional.

If you are on linux (and maybe even on a mac) then this might set your scrolling speed slower (copy paste it into a terminal window):

env SAL_USE_VCLPLUGIN=gtk libreoffice --writer

It sets the environment variable ‘SAL_USE_VCLPLUGIN’ to the value ‘gtk’ and then launches libre office writer.
From what I understand this changes how libre office looks and behaves on input. So it changes how it gets the mouse input and makes the speed functional.

I dont know if this will work for calc.

Go to Tools > Options, and under LibreOffice, choose View. Set the Middle mouse button dropdown to Automatic scrolling. After doing this I found it was still fast but not so fast as to be unusable.

I can confirm that this answer helps a lot, I had Middle mouse button set to Paste from clipboard and scrolling was terrible (very high speed and extremely sensitive to change vertical/horizontal direction); then I followed this suggestion and scrolling is usable now: fast but not “furious” and no unexpected changes in vertical/horizontal directions.

I found changing that option to ‘No Function’ may have made it marginally slower. For me, the error is predominantly when clicking and dragging or Ctrl+scrolling (zooming). My fingers need to remain fixed on the trackpad and transfer pressure, and still it isn’t reasonably controllable. I feel a bug report coming on.
Ubuntu 18.04LTS (been happening for years on various LTS versions)

Mine was already set this way, and the scrolling is still insanely fast.