most recent .msi installation wants 6.2.2.2

Installation msi for both available versions (as of today), when installing looks for previous version (which is no longer available). See below. I tried renaming the 6.3 version to 6.2, 6.2.2, etc., to no avail. Any ideas?

image description

Hello,

please do the following

  1. Download https://downloadarchive.documentfoundation.org/libreoffice/old/6.2.2.2/win/x86_64/LibreOffice_6.2.2.2_Win_x64.msi to C:\Users\HP PC\Desktop
  2. Rename the file LibreOffice_6.2.2.2_Win_x64.msi to LibreOffice_6.2.2_Win_x64.msi
  3. Install new version 6.3.1 as usual

Background: There seems to be a problem with Windows Installer cache and Windows requires the old msi package to deinstall the existing version while installing the new version.

Hope that helps.

Your link allowed me to re-install. Really appreciate that, Opaque.

Great - Please consider to click the check mark (:heavy_check_mark:) next to the answer (turns to green), to show that the answer is correct and/or helped to fix a problem .