Prevent dialogs to open or save files from showing every last hidden folder?

Every time I am going to retrieve, open or save a file, I get my user data files and all the hidden folders (in Linux these are start with a dot) where it’s not likely I will be looking for an ordinary document. How do I turn this off?

Did you already try the option to use the system’s dialogues for Open/Save?
See > Tools > Options > LibreOffic > General

I tried the answer below for this question - but in Version: there is no open/save dialog option.
Does anyone know if it has moved or been removed or is the answer only valid on a more recent version of LibreOffice? I’m using LibreOffice on a Devuan Linux system.

There obviously were some versions not offering the mentioned option, among them 6.1.4 and 6…5. I couldn’t test with every version, but V 6.4.5 gave the choice again, and the versions 7.x.y also do.(so far).

Hello @Cecilieaux,

There are 2 types of FilePicker Dialogs that you can use in LibreOffice :

1) LibreOffice Open/Save Dialog

The LibreOffice Open/Save Dialog does not show hidden files/folders.

To use the LibreOffice Open/Save Dialogs, check the checkbox Use LibreOffice dialogs in the menu Tools : Options… : LibreOffice : General : Open/Save Dialogs.

2) System FilePicker

The System Filepicker does show hidden files/folders, but only if that setting is set in your system itself.

In Ubuntu ( and hopefully in your flavor of Linux ) you can turn the display of hidden files and folders On/Off by pressing CTRL+H inside your Files browser.

Afterwards the System FilePicker in LibreOffice should just follow this system setting.

HTH, lib

1 Like

The Ctrl+H keypress is most probably the answer to the OP’s question, since they work on Linux.

OMG! I had gone to Thunar for my file managing and had forgotten I had set ‘show hidden files…’ in Dolphin. Your post was just the kick in the head I needed. Thanks.

Ok I’ve been exploring - this is LibreOffice - on Linux. The option referred to in the other answer doesn’t exist, but we can set LibreOffice /Open/Save dialogue by going to Tools → Options → LibreOffice → Advanced

On that page click on Open Expert Configuration and a new window opens up. In the Search box at the top type
UseSystemFileDialog and at the bottom of selected output, there should be the UseSystemFileDialog variable which is a boolean and will be set to true. Click on that line to highlight it, and then click on EDIT button below to switch the setting to false.