Read only content cannot be changed, no modifications will be accepted

I found a solution for this problem. This happened to a particular cell while I was editing a table. I could get rid of it changing the size of the cell. I grabbed the top edge of the cell and dragged it down, and then I could edit it again. I don’t know if it will work for you, but it did for me. Nothing else did work, except for changing the size of the cell.

I found an answer that worked for me here:

  1. Select at least one character prior to the field, all the field, and
    at least one character after the
    field.
  2. Cut this content.
  3. Paste it back as unformatted text.
  4. Manually remove the “#” before and after the re-pasted content.
  5. Manually reformat any character styles that were present in the
    original field i.e., bold, italic,
    etc.

The field is lost by doing this, but
at least you have the content.

Got good hint from this answer…
Try repasting the contents in the starting field (or cell as in table). It worked for me.
Weird problem, and solution even more weird, :slight_smile:

Thank you so much.

Did not work for me. What worked for me is this solution: uncheck the following option Tools / Options / LibreOffice Writer / Compatibility / Protect form

I solved my problem with protected forms by unsetting an option in the Options dialog:

Tools > Options … > LibreOffice Writer > Compatibility > Remove the tick mark from the " Protect form " line.

1 Like

THANK YOU! It really should be listed here: Protecting Content in LibreOffice Writer - LibreOffice Help

After half an hour of searching this is the answer for me!

I also got this problem after importing a Word “.doc” file with some embedded form objects ( check boxes ).

The file opens up just fine in Word, where I can check and uncheck the check boxes and edit the content with no problem.

But after importing and loading it into LibreWriter, the status bar showed “read only” and when trying to edit the contents a message popped up saying “Write-protected content cannot be changed, no modifications will be accepted”. Check boxes could still be checked / unchecked, though.

The solution involving sections ( “Format” → “Sections” ) didn’t work, because it was grayed out ( → no sections ).

Finally, the solution that worked for me was the one about “protected form”:

  • Go to “Tools” → “Options
    → “LibreOffice Writer” → “Compatibility” → “Protect
    form
  • Make sure the “Protect form
    option is unchecked.

Now you can check / uncheck the check boxes and edit / modify the contents of the document.

( Using LibreOffice 5.1.6.2 and Ubuntu 16.04 LTS )

Thank you - for me it was “Protect form” and “Cursor in Protected Areas”

What else should ‘Read Only’ mean? One must have applied the setting and should have known what he (f/m) does.

If needs arise to cancel protection: There are different containers of text that can be protected (tables by every singel cell; frames - just to name two examples). Thus a refined design of using protection in a document / template is possible. A global switching off of protections will not be available.

I think the documents should be analised with the help of the navigator to identify the containers concerned - and, of course, the templates should be reworked to get documents as intended.

Editing: In a comment above “jerquee” linked in a thread from another forum on LibreOffice. There “jonhayes” had attached an example file to his post. Having studied that a bit with the help of an XML-editor I think the most likely cause of the problem is carelessly pasting content copied from non-odf source and containing incompatible or unsufficiently specified field-types. For better understanding you may refer to “owengs”'s contributions to this thread. The bug in LibreOffice should be to not refuse accepting pasted contents that cannot be thoroughly validated for one or another reason. We experience just another aspect of the “compatibility dilemma” enjoyed to the full by an unfortunately powerful competitor.

I don’t know how old this chain is as a year isn’t associated with the dates but in October 2021, using Ubuntu 20.10, I’m having the same problem as the OP and I did not select any setting to lock the document or make it read only. I simple created a document with some cut and paste HTML, saved it and exported as an editable PDF.

When I closed and reopened the document I realized it wasn’t showing the outlines as when the document was being created and I noticed I could not change the typeface. I got the dreaded “read only” message when I tried typing something.

My 7.0.6.2 version doesn’t have the formatting aid option mentioned in the chain (Tools → Options → LibreOffice Writer → Formatting Aids) nor does it have Tools → Options → LibreOffice Writer →Compatibility.

I just wonder if there’s documentation from the maintainers about locking and unlocking documents.

My solution was to copy and paste all my content into a new file so as to make edits.

This software simply made a promising attempt to find the most idiotic date formats. There seems to be a not yet finally decided competition. “Aug '14” Is meant to mean “one day of august 2014”. My answer above was posted more than 7 years ago, At that time the software still was askbot (but already also used the funny “format”).

1 Like

If the document is set as Read Only that is probably because you opened it directly from an email attachment (and therefore it is stored in a Temporary folder, where you don’t want it to be). The proper way to edit a document is to Save the attached file to some organized folder you own and then Open the document for Editing.

Another important reminder: NEVER get an x.x.0 version. It will (most probably) have bugs and regressions. You should get the version with the highest 3rd digit (currently 4.2.6)

Example: in the Download page (at the very bottom) you will see

LibreOffice is available in the following released version

4.1.6
4.2.5
4.2.6
4.3.0

You should get either version 4.2.6 or 4.1.6 (older, with less features which you might or not need, but equally bug free)

Recommending any other version to your customers is doing a bad service to them, to the project and especially to yourself (because, as usual, if you recommend anything, any problem in the software is your fault and people expect YOU to fix it :slight_smile: )

I imported a form from an RTF file, which included a table, which had some part of its cells somehow protected. Saving this as .odt file did not help.

What did help is the following:

  • Save to a different format (e. g. MS Word 97/2000/XP/2003 (.doc)), that eventually does not support this protection.
  • Close LibreOffice Writer.
  • Open the new file (e. g. the .doc file) with LibreOffice Writer and test if the removal of the protection has been successful.
  • Save back to a .odt file.

I imported a DOC file whose content was protected. (And Insert → Sections, Format → Sections didn’t work, because it was grayed out. Neither did saving without a password and/or in the ODT format.)

What worked was the following:

  • Under Tools → Options → LibreOffice Writer → Formatting Aids → Protected Area activate “Ignore protection”.

Notes:

  • That will also remove protection from Table of Contents, etc. (if it was created as protected)
  • One might want deactivate it again after editing, to prevent unintended edits in future
  • I think I had to restart LO on the first activation, but couldn’t reproduce it later (doc becomes editable immediately) - your mileage may vary

Cannot upvote yet, but thank you nevertheless.

Thanks
For mac option was named “Protect form” and it was under
Tools → Options → LibreOffice Writer → Compatibility

@Kanape Thanks, it works for me on Linux too

This is what worked for me (tried the “clip from one char before…” suggestion above but that just refused me as well) :-

  1. Re-SAVE the document from Libreoffice in the “OPENOFFICE DOCX” format (the one right down at the bottom of the format selector - NOT Windows DOCX) ;

  2. The close and Open the resulting document anew: the locked section is now unlocked.

Small disruption to some centring but nothing problematic.

Good luck all