Screen painting is slow, scrolling is over-aggressive, overall operation is slow and sometimes jerky

Screen painting is slow enough to be observed. Single, two or three mouse clicks on page-up and page-down areas on the scrollbar cause numerous page-up or page-down reactions, leading to scrolling well past the intended location and ongoing struggle to go to a desired location in Calc and Base (not Writer).

Just upgraded (using downloaded installers) from LibreOffice_5.2.3_Win_x86 to LibreOffice_5.3.4_Win_x64 (Version: (x64), Build ID: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3 CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; Locale: en-US (en_US)). Operating system is Windows 7 64-bit. The prior version of LibreOffice was uninstalled before the newer version of LibreOffice was installed. I’m using a notebook computer with trackpad, all special features disabled except tap to click.

I had just started using Base with its native database engine and found scrolling to be over-aggressive. Clicking the scrollbar’s line-down or line-up arrowhead worked fine, but a click or two (whether with the mouse’s physical button or with a touchpad tap to click) on the scrollbar’s page-up or page-down area would result in numerous page-up or page-down reactions, scrolling well past the intended destination, with scrolling taking place with significant delay. The database would often scroll near or to the bottom, or near or to the top. Navigation through the database was clumsy. Luckily, neither Calc nor Writer were affected.

So I upgraded to 5.3.4. Now screen painting is noticeably slow overall; Base continues to scroll over-aggressively as described; and Calc shows this type of over-aggressive scrolling, too. The overall slowdown feels sluggish, and gets especially bad when View > Data Sources is used to access a table from Calc, a table with about 100 records and 10 fields. Writer is slower to paint the screen, too, but it does not exhibit the over-aggressive scrolling behavior.

To get Calc to work faster I have started a new profile; I have unchecked the selection for using the Java runtime environment; I have increased the image cache to 512MB, memory per object to 15MB, and number of objects to 75 (I do not embed graphics in my documents or database); I have disabled OpenGL (later re-enabled it); I have allowed use of OpenCL (with and without OpenGL, later disabled it); and I have made sure not to start other applications. Slow screen painting and over-aggressive response to mouse page-up and page-down click events continue and no improvement is observed.

Screen painting is sufficiently slow that, when going through Tools > Options, you can watch the individually selected windows “unfurl”, you can experience the window get populated with its UI elements. Graphics acceleration has been on throughout. Slow screen painting affects Calc throughout its operation. It also has an observable effect on Writer.
Applications other than those in LibreOffice are not affected.

What would you like me to try to help isolate the cause? What can I do to restore the speed of screen painting speed of LibreOffice 5.2.3 to LibreOffice 5.3.4? How can over-aggressive responses to mouse page-up and page-down events be limited to one response per click? Thank you for your help!

(Note: I do not have a “Scroll Lock” button on my notebook’s keyboard)

(Update: Accessibility - assistive technology tools have not been selected)

I have this same problem (this sescribe)

I do not face this problem on my Windows 10 x64 laptop (and write this to help narrow down the issue).

When I had a similar problem (too sluggish response, very slow screen refreshing program windows etc.) with Blender 3D (a few months ago), I found out it was the nVidia graphics driver, so would you please confirm that LibreOffice is running on Integrated Graphics (if you have a separate graphics card)?

If you do have a separate graphics card, would you then try running it on your the nVidia (or whatever exclusive graphics card you have) driver, and report back the result? If relevant, please make sure the graphics card driver is updated.

Notebook computer with Intel HD Graphics 4000 display adapter. Drivers are updated with Windows Updates, when needed. No other application shows this slowness. Thanks for the suggestion, it just doesn’t seem to apply in this case. Something else is going wrong, and many others are experiencing something similar and posting their own questions.

I have the same problem with Calc version 5.4.0 but using and old version, 5.2.6 portable, speed is as expected. I have windows 10 with AMD athlon X4 and NVIDIA GTX650 graphics card.


I tried in another computer. HP laptop core i5 with Intel display adaptor and similiar results. I tried 4 versions:

Id. de compilación: 8f96e87c890bf8fa77463cd4b640a2312823f3ad
Subprocesos de CPU: 4; Versión de SO: Windows 6.2; Renderizado de IU: predeterminado;
Configuración regional: es-ES (es_ES); Calc: group

Id. de compilación: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3
Subproc. CPU: 4; SO: Windows 6.2; Repres. IU: GL; Motor de trazado: HarfBuzz;
Configuración regional: es-AR (es_ES); Calc: group

Id. de compilación: 7556cbc6811c9d992f4064ab9287069087d7f62c
Subproc. CPU: 4; SO: Windows 6.2; Repres. IU: GL;
Configuración regional: es-AR (es_ES); Calc: group

Versión: (x64)
Id. de compilación: 7556cbc6811c9d992f4064ab9287069087d7f62c
Subproc. CPU: 4; SO: Windows 6.19; Repres. IU: predet.;
Configuración regional: es-ES (es_ES); Calc: group

And both versions are much slower than previous versions when I press av. pag.

Just upgraded to 5.4.1 (also tested 5.4.2 from testing/) and I also experience lots of slowness on Windows 10, from the scrolling to the overall UI.

All of this does not happen on a old 32bits WinXP computer (AMD Sempron & Nvidia onboard GPU)

Windows 10 is 64bits, on an Intel Core i5, 6GB of RAM, onboard Intel GPU and dedicated nVidia Graphic Card (9600GT) (can’t update drivers anymore as the product is no longer maintained)

Tested LibO installer 32 and 64bits on Windows 10, both on nVidia and Intel GPU, with and without OpenGL, it’s all the same slowness, both on scrolling and overall UI. LinO 5.2.7 and 5.3.6 seems to work ok, but not as snappier as on WinXP.

Could it be a problem with that composite thing (dwm?) on Windows 10 ? If it could be disabled…

I have the same problem, I think. Just updated from 5.xxsomething to Scrolling is really weird.

I do have an nVidia graphics card, but I don’t understand the advice in the last post. Is there an option in LibreOffice that where you can specify if it should use the graphics driver or not?

(NB: nothing on my graphics driver was updated. It was just LO that was updated and then this started. The previous version didn’t seem to have this problem.)


  1. open LibreOffice (soffice.exe)
  2. open the File menu (Alt + F)
  3. press and keep pressed the Down arrow

The menu selection will cycle through the menu items of the File menu, however this very simple action will already use ~70% of a single i7 CPU core clocked at 3.2 GHz.

This can be reproduced both in normal and in safe mode, with and without anti-aliasing, with and without hardware acceleration, with and without OpenGL.

Configuration: LibreOffice (x64) on Windows 10 x64 (GPU: Nvidia GTX 1060 (mobile), integrated graphics is disabled)

Not sure what version I was on (it was V5 though), but I’ve just upgraded to (X64), and I now have the same problem.
System: Windows 10-X64, Dell M4500 laptop (quad core i5 2.53GHz), 4GB, nVidia Quadro FX880M

Hi all.

Got the same problem in 2 workstations, extremely slow with basics scrolling.
OpenCL/GL or antialiasing on/off… no difference.
I were on 5.4.1 now i installed (testing version), with OpenGL off everything is smooth as it should be.
Disisntalled and installed without rebooting windows (10).

Back in July 2017, after upgrading LO 5.2.7 (x32) to 5.3.4 (x64), I noticed a pronounced lag in Calc when scrolling up or down a spreadsheet. There was also a significant lag when doing a large copy/paste operation into a spreadsheet. I thought more RAM might help, so I added 4GB more (8GB total), but still no joy.

Today I upgraded to LO (x64) and the slowness problem has finally been resolved! Woo-hoo!

Same issue here.

Win10 64bit with NVidea Graphics GTX 1060

Recently upgraded to and since then Calc has been slow to draw page.

Version: (x64)
Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
CPU threads: 6; OS: Windows 6.19; UI render: GL;
Locale: en-GB (en_GB); Calc: group

edit: Just updated manually to 4.3.2 and the issue is resolved. The auto updater didnt suggest the new version though?

Just resolved my same issue completely. If you do a custom install instead of the typical try uninstalling then reinstall using the typical option. That may clear it up. If not everything i did was uninstalled x64 custom install; installed x86 typical install; uninstalled; installed x64 typical. Was like night and day in performance. Seems either something doesn’t get installed or the ui is looking for something in the languages i had unchecked for a leaner install.

Is it fixed? Currently I’m on Version: (x64) and it works like magic. I have same problem with newer version too.

Solved the problem.
got the solution from here

black listing opengl completely solve my problem, although 4.2 version is still rocket fast then 5.4

all following entry to share/opengl/opengl_blacklist_windows.xml

In Microsoft Mouse and Keyboard Center, select your device, and then select Basic settings. Depending on the mouse model you are using, select Wheel or Touch Strip. Select Identify programs that don’t scroll correctly.

@dwarka , to prevent you to spam all requests adressing this scroll issue with a possibly very limited solution for only a few users:

1.) Microsoft Mouse and Keyboard Center is only available for users of a Microsoft Keyboard or Mouse. In a Windwos 7 / 8 / 8.1 / 10 without that there is no option for this. As well not in Linux.

2.) Most of the requests deal with the use of a touchpad, not scrolling with a mouse.