Setting document language in Calc

I cannot select the language for the whole spreadsheet in Calc. As a result, I have a spreadsheet where all words are underlined in red simply because it is in a different language. In Calc, when I select the whole spreadsheet (or don’t select it) and choose Tools | Language from the menu, I have only two options: Hyphenation and More Dictionaries Online. In contrast, when I select Tools | Language in Writer, I have options For Selection, For Paragraph and For All Text. In each of those I can select dictionaries for the two languages installed on my computer. How do I set the spreadsheet language in Calc?

Modify the language on default style, there are to places on numbers tab for the cell format and font tab for the text. It is the base style on the spreadsheet.

Menu/Styles/Manage Styles [F11]

For an entire spreadsheet document this is certainly the better solution than changing the text language individually for all cells…

Calc is not Writer :slight_smile: In Calc, you should set the language in the cell properties dialog (Format → Cells from the menu or Ctrl + 1) on the Font tab.