Table of contents - its Double! once Normal, second in Hyperlink

Iǘe created a table of Contents,
the document looks good, till I save / close it. When I reopen the document, I have a second table of contents dierctly underneath it, in Hypertext, If I delet it, save and open the document again, the Hypertext comes back.

If I don’t delet the Hypertext stuff, and save / close / open then I have anoter Hypertext table of contents and then another and so on…

Any Ideas?
Thanks in advance

OP: @T5K

There is two bugs reported in relation:

IMO better use the native format .odt.
If you need to exchange files with other who only can work with a MS format try with .doc (Microsoft Word 97/2000/XP/2003). But only to send other people, not for work.

fdo#46025 and fdo#46060 both have status of NEW; it unclear when they’ll have priority to be fixed. Using ODF format (.odt) or .doc as a workaround is probably the best bet for the foreseeable future.

A work around I’ve found for this is to save the file in .DOC format. Writer handles it without problem, the only snag I’ve found is if I take the file into MS Word the table does not update while in word, but then updates itself when it goes back into Writer so… anyway this trick might work for you if you need to have the table of contents work in Word

To get some help, is better inform about:

  • Operating system.
  • LIbreOffice version.
  • File format to save, native odt or doc, docx, other.

I don’t know a lot about computers and am trying to create a table of contents in libre office. Have tried their help, but it’s crap, and I’ve been unable to get it to do anything except produce the words “table of contents”. Can anybody explain this in simple language? Honestly, it’s like mud.

Follow-up: Table of Contents option too confusing