What is this font, and how do I get rid of it?

In LibreOffice, I installed a bunch of new fonts from the Google Font Directory and got rid of all the existing fonts. Everything’s worked fine with the new fonts so far. But, there is one entry that I would like to get rid of:

I can’t figure out what script that is, or which file it corresponds to in the fonts I’ve installed, and I can’t find it in the font manager either. (It also came bundled with Linux Mint.) Somebody please help?

Have you check in menu Tools → Extension Manager?

Update: the fonts are Padauk and Padauk Book; they are packaged for Ubuntu. This is what you want to look for if you want to take them off your system.

Original answer follows

What I can tell you is that the script you’re looking at in the graphic you provided is the Burmese/Myanmar script. What I can’t tell you (of course!), is which font it is. But maybe knowing that much will enable you to identify it. (FWIW, I use Linux Mint, and don’t have a match on my system.)

Perhaps check a listing of Burmese unicode fonts: try Myanmar Unicode Fonts; or the Myanmar Language unicode page; or the Myanmar Wikipedia font support page. Also, this Q&A from AskUbuntu treats a Myanmar font problem.

Hope that helps … and good luck!

Thanks. Yeah, knowing that it’s Burmese/Myanma will probably help a lot.

So now that I know it’s Padauk, my question becomes why it shows up as that garbled name in the font repository.

So now that I know it’s Padauk, my question becomes why it shows up as that garbled name in the font repository.

Have you tried Google in case it a known problem? And not actually a LibO problem.

The Characters on the right hand side look like one of the South Asian (Tamil, Indian, Vietnam, Thailand)character sets. On my English LibO system fonts such as Gautama, Kelage, Malliga, Tanga (spelling may not be exact) fit in that area. They look the closest.
If you select your font in writer, and the font is actually working, it will tell you the Name of the font. As will INSERT > SPECIAL CHARACTERS.

If the font is actually broken, you may just have to go through the fonts one by one. You could start by try finding the ones mentioned above in the font library. As it is the font appears to be corrupted. Sorry not to help further.

The font name is those symbols at the left, which is why I’m confused.

I’d tried Googling the font name, and “how to find font files in LibreOffice”. Predictably, neither one worked.