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 RipX Manual 
Much of RipX is described by the Interactive Help box 
which can be activated from the Help menu.  

 It is also a good idea to watch the walkthrough YouTube videos available from Help > YouTube Videos. 
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RipX: DeepPlayer, DeepRemix & DeepAudio 

RipX is a module-based audio platform. The following modules are currently available:  

• DeepPlayer – Available for free, play back audio that has already been converted into RipX’s Rip 
(.rip) file format to see and hear the work of others.  

o To create and edit Rips, obtain a 1-month free trial or paid license from hitnmix.com and 
use the code that you receive to activate one or more of the following modules from 
RipX’s Help menu. 

• DeepRemix – This adds essential tools for separating audio files into vocal, instrumental, bass and 
drum stems and creating songs from samples using a variety of powerful effects.  

• DeepAudio – This includes the DeepRemix module and adds advanced tools for manipulating 
audio, all the way down to its deepest harmonic, amplitude and frequency levels. 

In the following, chapters with headings prefixed either by DeepRemix or DeepAudio concern the module of 
that name.  DeepRemix chapters are essential reading for everyone but may also contain a small amount of 
information about the DeepAudio module where relevant.  DeepAudio chapters can be skipped by those who 
do not have a DeepAudio license.   

Opening, Ripping & Exporting Audio/Video 

Opening & Ripping Audio 

RipX can open MP3 (.mp3), FLAC (.flac), Ogg (.ogg), CD track (.cda), WAV (.wav), MIDI (.mid) and Rip (.rip) 
audio files.  When RipX opens an audio file, it converts it into a Rip file. It is then listed in the RipList Panel in 
the top-right corner of the RipX window.  A Rip is an audio file that has been source separated ‘Ripped’ into 
individual notes, harmonics, frequencies, amplitudes, phases and time slices by RipX.  Rip files are created in a 
process called ‘Ripping’.  

To open one or more audio files, click File>Open, press X /Ctrl+O, drag & drop them onto RipX 
or click on the large folder button that is shown when no Rip is open in RipX.  

MIDI and Rip files will open straight away.  

For other types of audio, if the filename includes, or is, a stem name, for example drums.wav or 
mysong_vocals.flac, RipX will offer to automatically rip, optimizing separation for the type of stem named. 
Otherwise, a dialog box will appear offering a range of options.   

• DeepAudio only: Select the type of recording that is being opened.   
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o When Single Instrument / SFX is selected, options are made available that allow the type 
of instrument/special effect (SFX), to be specified.  This helps RipX to optimize the Rip file 
it produces for that specific instrument/SFX and lets it know that it should put all notes in 
the same layer for that instrument/SFX.  A time range can also be chosen.  Leave this blank 
to open the entire track. 

o If  you  are  opening  a  full  mix  containing  multiple  instruments  and  other  sounds,  select 
Multiple  Instruments  &  Sounds.    The  options  that  are  available  when  this  option  is 
selected are described below.  

 

• DeepRemix or DeepAudio with Multiple Instruments & Sounds selected: 

o Select the type of recording that is being opened.   

o Choose which instrument(s) you would like to extract from the audio.  The available options 
are Voice, Bass, Other Sounds & Instruments, and Drums & Percussion.   

▪  When it creates the Rip file, RipX will assign notes/unpitched sounds performed by the 
various instruments to appropriate color-coded Layers which are listed in the Layers 
Panel at the bottom-right of the RipX Window.  

▪  If  you  only  need  to  create  stems  from  the  audio  (e.g.,  for  your  DAW  or  for  DJing 
purposes),  check  Save  Stems  Only.    No  Rip  file  is  created.    Instead,  WAV  stems  are 
placed  inside  RipX/Stems  (or  a  location  set  in  RipX/File>Preferences…)  within  your 
user account’s Documents folder. 

• To  generate  one  vocal.wav  stem  plus  one  containing  all  other  audio  (called 
instruments.wav), choose Voice only. 

• For other file formats, uncheck Save Stems Only and use File>Export once the 
file has been ripped. 

▪  Windows only: If you have an NVIDIA graphics card with at least 8GB (10GB 
recommended) graphics memory and CUDA support, plus at least 16GB RAM installed, 
RipX can use its power to rip significantly faster. 

• You will need to have the NVIDIA CUDA Toolkit v11.0 (free download) 
installed.  If  your  system  meets  these  minimum  requirements  to  use  CUDA, 
RipX  will  show  a  message  about  where  to  download  the  toolkit  if  it  is  not 
already installed. Note that it needs to be exactly v11.0. 

• Once installed, RipX will use your graphics card automatically – you will notice 
reduced time estimates shown in the ripper options dialog. It is recommended 
that you use the Highest setting. 
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• Graphics cards with the recommended 10GB VRAM supported include 
GeForce 1080 Ti / 2080 Ti / 3080 / 3090. 

• Some graphics cards with 8GB of VRAM are also supported. However, you may 
need to be using only a single monitor, with no other apps running. A 
checkbox  CUDA  Acceleration  (uncheck  if  fails)  will  be  added  to  the  Ripper 
options,  and  you  should  uncheck  this  if  RipX  crashes  or  does  not  complete 
separation whilst ripping. These cards include NVIDIA GeForce 1070 / 1080 / 
2070 / 2080 / 3070. 

• Click Rip to proceed.   

Whilst  the  audio  is  being  ripped,  a  progress  bar  appears  in  the  RipList 
Panel (top-right of the RipX window), showing the name of the track and 
how  much  time  is  remaining.    Right-click  on  the  progress  bar  and  click 
Cancel  Ripping  to  cancel  it.  If  ripping  multiple  instruments,  once  they 
have been separated, the Ripper app will open to analyze each.   

Once  finished,  the  Rip  will  be  listed  in  the  RipList  panel  with  an  open 
folder  icon  to  the  left  of  its  name.    Click  on  it  to  view  the  separated 

audio’s  layers,  notes  and  unpitched  sounds.    Right-click  on  the  name  of  the  Rip  in  the  RipList  Panel  to 
rename it, remove it from the RipList, delete it from your hard drive, open the folder in which it is stored, 
or set its time signature.  

Add  a  background  image  to  your  Rip  by  dragging  &  dropping  a  JPEG  or  PNG  file  onto  it.    (This  can  be 
removed by right-clicking on the name of the Rip in the  RipList Panel and clicking Remove Background 
Image.)  

Preparing Rips for Editing 

Due to the complexity of separating audio, you may find instrumental parts are not always placed in the 
correct layer. However, this is easy to fix: 

• Select the audio to move. 

• Then from the Layers Panel at the bottom-right of the RipX window, hover over the layer you 
would like them to be in and click the arrow icon that appears to the left of the layer name. 

• If the layer does not exist, click Add Layer first. 

• You can then use the keyboard shortcut M to continue transferring selections to this layer. 

RipX automatically works out where bar lines should be placed. However, if you plan to work with rhythmic 
aspects of audio, you should first ensure they marked out correctly: 

• Starting from the first bar line, go through and check the position. If incorrect, click 
and drag the triangular handle beneath it to the correct place. RipX will automatically 
update bar lines that follow. 

• Continue through the Rip until they are all correctly placed. 
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Exporting Audio 

 

From the File menu, use Export X /Ctrl+E to export Rips in a range of audio formats, including MP3, WAV, 
FLAC, OGG, MIDI (containing all pitch and amplitude changes within notes) and MIDI Notes (containing just the 
overall pitch and amplitude for each note).  Rips can also be exported as Stem (.stem.mp4) files for DJ apps like 
Native Instruments Traktor.  Depending on the selected file format, choose from a selection of bit-depths and 
sample rates as well as between Stereo and Mono.   

Also choose whether to export the entire rip, a selection of it, or a loop that’s marked within it (see Note & 
Time Selections and Loops).  Note that since MIDI files contain bar position information, the exported MIDI 
file of a selection or loop will start from the preceding bar line.  If you would like it to start from the first note 
in the selection, you should move the bar line to its start before exporting.  (A bar line can be moved by 
clicking & dragging the handle beneath it.)   

Finally, choose whether you would like to export the Rip as a single file or as separate stems or layers.  Right-
click on the name of a layer in the Layers Panel (bottom-left of the RipX window) to change the stem group to 
which it is assigned.  In the same menu, you can hover the mouse pointer to the right of one of the stem 
names and click on the pencil icon that appears to rename that stem.   

Video Import & Export (macOS only) 

RipX can import MP4, M4V & MOV video files that use the following video codecs (those that we have tested 
are marked by an asterisk *): 

Apple Animation Codec 
Apple Intermediate Codec 
Apple ProRes* 
AVCHD (including AVCCAM, AVCHD Lite, and NXCAM) 
DV (including DVCAM, DVCPRO*, DVCPRO50*, DVCPAL*) 
H.264* 
HDV 
HEVC 
iFrame 
Motion JPEG (OpenDML only)* 
MPEG-4 SP 
Photo JPEG* 
XAVC-S  

 
In addition, RipX can import AVI video files that use the Motion JPEG codec. 
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Once a video file has been Ripped, the audio is displayed as normal, and the video is displayed in its own 
window which can be resized by clicking & dragging its corners.  If you close the video window, it can be 
reopened by clicking on the Rip.  
 
The video automatically plays back in sync with the audio during playback, including when playing back 
selections and loops (see Note & Time Selections and Loops).  However, note that the video will no longer 
be in sync with the audio if any time edits are made (such as deleting time selections or changing the tempo of 
the Rip).  RipX is not designed to edit the video.   
 
Videos can be exported as MP4 and MOV files by clicking File>Export or pressing X /Ctrl+E. 
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DeepRemix: The Cursor, Selections, Groups & Effects 

The Cursor 

The cursor is a white vertical line that sets, amongst other things, the time at which playback begins (unless 
there is a loop marked in the Rip – see below) and the time at which copied/cut notes are pasted.  When a Rip 
is opened, the cursor is located at the start.  Its position can be adjusted as follows:  

• Click on a blank part of the Rip to place the cursor at that time.  

• Press the Left/Right arrow key to move it to the previous/next beat marker.  

o Hold down X /Ctrl whilst doing so to move it to the previous/next bar line.  

o Hold down z  /Alt whilst doing so to nudge it slightly to the left/right.  

Note & Time Selections 

Two types of selection can be made in RipX:  

• In a note selection, notes/unpitched sound are selected but not the time that 
they occupy.  For example, this means that deleting a note selection will not 
affect any other notes or unpitched sound at the same time as it, and will leave 
behind silence if there is nothing else at the same time.  

• In a time selection, a length of time is selected together with all notes and 
unpitched sound within it.  Deleting a time selection will not leave behind any 
silence and will shorten the Rip by the length of time that was deleted.  

A note selection can be made in the following ways:  

• Click on a note or unpitched sound to select only that note/unpitched sound.  (This deselects 
anything else that was selected.) 

o X /Ctrl+Click on a note/unpitched sound to add it to an existing note selection.  

o x /Shift+Click on a note/unpitched sound to add that note and all notes in between it and 
an existing note selection to add them to that selection.  

• Click & drag the mouse pointer over notes/unpitched sound to select them with a selection 
rectangle.   

o Hold down z /Alt whilst doing this to only select those parts of the notes/unpitched sound 
that are within the rectangle.   

o DeepAudio only: Check Fine Selection in Audioshop when using its Move/Resize tool to 
reverse this behavior (see DeepAudio: Audioshop & Other Tools).  

• Double-click on a note/unpitched sound to quickly select all parts of notes and unpitched sound 
that is inside that bar.  (Parts of notes/unpitched sound that are outside the bar are not selected.)  

A time selection can be made in the following ways:  

• Click & drag over the background of the Rip, without passing the mouse pointer over any notes or 
unpitched sound (unless a substantial amount of time has already been selected).   
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• Click on the background of the Rip at one point of time and then x /Shift+click on the background 
of the Rip at another point of time to select all time in between.  (This is particularly useful when 
selecting long sections of audio.)  

• Double-click on the background of the Rip within a bar to quickly select all time within that bar.  

• Hold down x /Shift and then press Left/Right to select all time from the position of the cursor to 
the previous/next beat marker.  

o Also hold down X  whilst doing this to instead select all time from the position of the 
cursor to the previous/next bar line. 

• Hold down x /Shift and press Left/Right to extend or shorten an existing time selection to the 
nearest beat maker.  

Groups 

Notes and unpitched sound can be grouped together so that they can be selected and 
edited as a single object.  For example, this is particularly useful when copying & pasting 
a vocal phrase from one Rip to another.  Grouping the phrase once it has been pasted 
will allow it to be more easily tweaked to fit the timing and key of the surrounding audio.  

• To group notes/unpitched sound, select them and then click Audio>Group or press X /Ctrl+G.  A 
box is shown around them whose color depends on the color of the layer(s) to which they belong.  

• Select the group by clicking on one of its notes/unpitched sounds.  

• Change the pitch of the entire group by clicking & dragging it up/down.  

• Change the time of the entire group by clicking & dragging it left/right. 

• Click & drag the left/right edge of the box to change the time at which the group starts/ends.   

• Hold down z  /Alt whilst clicking or clicking & dragging over a grouped note/unpitched sound to 
select it independently of the rest of the group.  (See DeepRemix: Essential Step-By-Step 
Editing Instructions for more information on how to edit notes and unpitched sound.) 

• Right-click on a grouped note/unpitched sound and click Hide Grouped Audio, or press z  /Alt+G, 
to hide the grouped notes/unpitched sound in the box.  This also causes the group box to always 
be displayed and allows them to be selected and moved by simply clicking & dragging the box 
instead of its contents.  Right-click on the box and click Show Grouped Audio, or press z  /Alt+G, 
to show them again.  

• Select grouped notes/unpitched sound and click Audio>Ungroup or press x X /Ctrl+Shift+G to 
ungroup them.  

Applying Adjustments & Effects to Selections 

Above the Rip and to the right of the Play button is the Adjust / Effects menu.  This contains a number of 
powerful tools and effects that can be quickly applied to all notes within a note or time selection.  It can also 
be accessed by z  /Alt+Right-Clicking on a selection.  

• Click on the name of an item in the menu to apply a default amount of the adjustment/effect to 
the selection.  
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• Use the slider to adjust how strongly it is applied to the selection 
and, where appropriate, in which direction.  

• Remove any adjustment/effect applied by clicking the name of 
the item.  

o Note: These are applied on top of other edits so vibrato, 
for example, would remain applied after any further 
pitch adjustments.   

o Note: Pitch effects cannot be applied to unpitched 
sounds. 

Most of the adjustments/effects in this menu are self-explanatory.  Below is 
a brief description of those that may be less-so.  

• Level – Adjusts the volume of the selection.  

• Low Pass – Applies a filter to the selection that only allows 
frequencies to be heard that are below a specific frequency that can be set with the slider.  

• High Pass – Applies a filter to the selection that only allows frequencies to be heard that are above 
a specific frequency that can be set with the slider.  

• Pitch To Scale – Moves the pitches of notes in the selection towards the nearest pitches that lie on 
any musical scale that has been applied to the bar(s) that they are in.  If no musical scale has been 
applied, it moves them towards the nearest semitone.   

o You can click Set Musical Scale at the bottom-left of the Rip to choose a musical scale for 
all bars in the Rip or, if any scale changes have been added (see below), only those up until 
the first scale change. 

o Once a musical scale has been set, move the mouse pointer to the right of a bar-line 
handle (beneath the bar line) and click Add Scale Change to choose a musical scale for all 
bars from that bar line onwards or, if any scale changes have been set at later bar lines, 
only those up until the next scale change.  

o Tip: To apply a musical scale to a specific layer, first solo that layer (by clicking the S icon to 
the left of its name in the Layers Panel) or lock all other layers (by right-clicking on its 
name and clicking Lock All Others) then set/add the scale with Auto Pitch To Scale 
selected.  

• Harmony – Adds a harmonizing note to each selected note at an interval of a third above it, or one 
or two octaves above/below it, as specified with the slider.  (The key of the Rip is used to 
determine whether the third should be major or minor.)   

o Note: Harmonizing notes are displayed as separate thinner notes but can only be adjusted 
with the Harmony effect’s slider.  They cannot be selected or edited like other notes.  

• Delay – Applies delay to all notes in the selection with a separation that is a fraction of a bar, as 
specified with the slider.  

• Randomize – Once applied to a selection, different adjustments/effects are applied to its 
notes/unpitched sounds at random, each time they are played back.  For a more detailed 
description of this feature, see Randomize.   
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RipX applies these adjustments/effects to notes and unpitched sounds each time they are played back but 
they can be set in stone (e.g. to add layers of effects or reduce the amount of work your computer has to do 
during playback) by selecting audio and clicking Audio>Render Adjustments & Effects or pressing z  /Alt+R.  
(DeepAudio only: Doing this will also allow their effects on the harmonics of the notes to be edited with 
Audioshop’s Harmonic Editor – see DeepAudio: Audioshop & Other Tools.) 
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DeepRemix: Essential Step-By-Step Editing Instructions 

Here follow instructions for the various types of editing you can do with DeepRemix.  (For information about 
the advanced editing techniques that are additionally available with the DeepAudio module, see DeepAudio: 
Advanced Editing Techniques.)  The following is separated into main categories like Pitch, Rhythm and 
Unpitched Sound, with more specific techniques within.  

Pitch 

Chromatically edit pitch  

• Ensure that Snap To Semitone Guides is checked in the View menu and 
then click & drag a note, selection of notes and/or their parts up/down to 
raise/lower their pitches by a number of semitones.  

• Alternatively, press Up/Down to adjust the pitch of a selection.   

• Hold down X /Ctrl whilst doing this to shift the selection up or down by 
an octave.  

• Note: To edit the pitch of a note selection by any number of semitones, 
there must either be no scale applied to the bar that contains it, or that 
scale must be chromatic (see below).  

Edit pitch over a musical scale 

1. Choose the bars to which the musical scale will apply:  

o Click Set Musical Scale at the bottom-left of the Rip to choose a 
musical scale for all bars or, if any scale changes have been added 
(see below), only those up until the first scale change. 

o Then, move the mouse pointer to the right of a bar-line handle 
(beneath the bar line) and click Add Scale Change to choose a 
musical scale for all bars from that bar line onwards or, if any 
scale changes have been set at later bar lines, only those up until 
the next scale change.  

2. Choosing the musical scale:  

o Click Detect for RipX to automatically determine the scale from 
the pitches of notes (major and minor keys only).  

o Manually select the scale by choosing the letter from which it 
starts on the left and the type of scale on the right.  

o Click Clear to remove the selection.   

o Ensure that Auto Pitch To Scale is not checked unless you would 
like notes to be automatically snapped to the scale.  

o A useful tool for creative inspiration, click Randomize for the scale to change every time 
playback, or a loop begins. This automatically selects Auto Pitch To Scale. For a more 
detailed description of this feature, see Randomize. 
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3. If you intend to edit pitch by clicking & dragging, ensure that Snap To Semitone Guides is checked 
in the View menu.  With this, any edits made to the pitch of a note by clicking & dragging it 
vertically, or by pressing Up/Down whilst it is selected, will shift it up or down only through pitches 
that are on the chosen scale as indicated by the semitone guides.   

o Applying Pitch To Scale, Quantize Pitch or Flatten Pitch to notes from the Adjust/Effects 
menu will cause them to snap to these guides.   

Finely edit pitch 

• Hold down z  /Alt whilst clicking & dragging a note, selection of notes and/or their parts up/down 
to raise/lower their pitches by minute amounts, less than a semitone.   

o Tip: First zoom in on pitch by positioning the mouse pointer over the area you would like 
to zoom in on and using the mouse wheel whilst holding down x X /Ctrl+Shift.  
Alternatively, click & drag vertically over the piano keyboard in the region of pitch that 
you’d like to zoom in on. 

o Tip: Once zoomed in, scroll vertically by using the mouse wheel whilst holding down 
x /Shift or by using the vertical scrollbar to the right of the Rip.  

• Where no musical scale has been set, use Pitch To Scale in the Adjust/Effects menu to quickly 
correct the pitch of selected notes and/or parts of notes that are out of tune.  

o Tip: Snap all notes in the Rip to the nearest semitone by clicking Set Musical Scale at the 
bottom-left of the Rip, choosing a Chromatic scale and ensuring that Auto Pitch To Scale is 
checked in the same menu. 

• DeepAudio only: See DeepAudio: Advanced Editing Techniques to learn how to finely adjust a 
note’s pitch over time.  

Quickly flatten, slide, or add constant vibrato to pitch  

• Remove all variation in pitch across all selected notes and/or their parts by clicking Flatten Pitch in 
the Adjust/Effects menu.   

o Click Flatten Pitch again to remove this effect.  

o Click & drag the slider button left/right to reduce/increase how much they are flattened. 

o Tip: Use Flatten Pitch to reduce or remove vibrato from a note.  (DeepAudio only: Any 
associated vibrato in volume can be removed with Audioshop’s Smooth Region Tool – see 
DeepAudio: Audioshop & Other Tools).  

• Make all selected notes and/or their parts slide in pitch by using the slider next to Slide Pitch in 
the Adjust/Effects menu.   

o Click & drag the slider button to the right/left to slide the pitch up/down.  

o Subsequently click & drag the slider button in the opposite direction to reduce the amount 
of slide or reverse the direction of the slide.  

o Click Slide Pitch to remove this effect.  

o DeepAudio only:  See DeepAudio: Advanced Editing Techniques to learn how to apply 
slides with finer control and more complicated contours.  
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• Add a pitch vibrato of constant amplitude/strength and period to selected notes and/or their parts 
by using the slider next to Vibrato in the Adjust / Effects menu.  

o Click & drag the slider button to the right/left to increase/decrease the amplitude of the 
vibrato. 

o Click Vibrato to remove it.  

o DeepAudio only: See DeepAudio: Advanced Editing Techniques to learn how to add 
more realistic vibrato and clone vibrato (and other pitch variations) from notes performed 
by real musicians.  

Rhythm  

Edit rhythm by moving the starts of notes 

• Tip: Use the mouse wheel whilst holding down X /Ctrl to zoom in on time and see additional 
vertical guidelines that mark divisions of the beat.  Alternatively, click & drag horizontally over the 
Timeline located above the Rip. 

• Click & drag a note left/right so that it starts and ends sooner/later. 

o Tip: Use this for shorter notes (e.g. violin pizzicato) where the sustain of the note is not as 
important as its attack.   

• Click & drag the start of a note left/right so that it starts sooner/later without affecting when it 
ends.   

o Tip: Use this for longer notes where the sustain of the note is an important part of its 
effect (e.g. long sustained notes played by strings).  

• Note: The starts and ends of notes will automatically snap to the beat markers (which mark the 
beats and their divisions) if Snap To Beat Markers is checked in the View menu.  Hold down z  
/Alt whilst clicking & dragging to reverse this setting.  

• Delete the start of a note by holding down z  /Alt whilst clicking & dragging over it and then 
pressing Delete.  

o DeepAudio only: Check Fine Selection in Audioshop when using its Move/Resize Tool  to 
select parts of a note without having to hold down z  /Alt (see DeepAudio: Audioshop 
& Other Tools).  

o Tip: Use this with notes that do not have a strong attack or in cases where the resulting 
change in attack is desirable, not noticeable in the full mix, or otherwise unimportant.  

• Select multiple notes then click & drag the end of the selection to change the speed of its rhythm 
without affecting the tempo of the music that contains it.   

o Tip: Group the notes together first – see Groups.  

• DeepAudio only: See DeepAudio: Advanced Editing Techniques to learn how to change the 
rhythmic feel of one or more bars.   

Edit rhythm by adding/removing notes  
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• Copy a selection of one or more notes then paste them between the starts of existing notes to 
increase the speed of the rhythm.  

o Tip: Add a strum to each chord in a sequence of guitar chords by copying & pasting the 
sequence to the right of itself.  While the pasted notes are still selected, click & drag to the 
left the slider button next to Level in the Adjust/Effects menu to decrease their volume 
for added realism.   

o DeepAudio only: See DeepAudio: Advanced Editing Techniques to learn how to draw 
new notes between other notes. 

• Select notes between the starts of other notes and press Delete to decrease the speed of the 
rhythm.  

Note Duration, Tempo & Time 

Edit note duration 

• Click & drag the end of a note so that it ends earlier/later without affecting where it starts.   

o Note: The end of a note will automatically snap to beat markers if Snap To Beat Markers is 
checked in the View menu.  Hold down z  /Alt whilst clicking & dragging to reverse this 
setting. 

• Copy & paste a note so that it immediately follows itself then join the two notes together by 
selecting them and clicking Audio>Join or pressing X /Ctrl+J.  

o Tip: This works best with notes whose characteristics (e.g. pitch, volume & timbre) do not 
differ by much between their starts and ends.   

Edit tempo 

• Before working with the tempo of any Rip, ensure that its bar lines are correctly positioned.  A bar 
line can be moved by clicking & dragging the handle beneath it.  Subsequent bar lines update 
automatically so it is best to start with the first and work forwards through the Rip.   

• The BPM (beats per minute) can be viewed in a few different ways:  

o The overall BPM of a Rip is displayed to the right of its name at the top-right of the RipX 
window and when the mouse pointer is hovered over it in the RipList Panel.   

o When the mouse pointer is placed over a bar-line handle, the BPM of the preceding bar is 
shown to the left of it. This updates as the bar-line handle is dragged left or right.  

o DeepAudio only: To view in the toolbar the tempo of the bar currently under the mouse 
pointer, click Tempo Info in the Tools / RipScripts>Tempo submenu. 

• Change the tempo from the cursor onwards or for all 
selected bars by right-clicking on the background of the Rip 
when nothing is selected and clicking Change Tempo.  
(DeepAudio only: Change Tempo is also available from the 
Tools / RipScripts>Tempo submenu.)  Enter a new number 
of BPM (beats per minute) and click Audio To Selection 
(which applies to all bars  from the cursor if nothing selected) or Apply To Rip.   
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• When copying & pasting notes between Rips with different tempos, use x X /Ctrl+Shift+V to 
paste the notes and they will be automatically adjusted to fit the destination tempo.  

o Tip: Quickly swap between the current and previously displayed Rip by pressing 
^/Ctrl+Tab. 

Edit time 

• Make a time selection (see Note & Time Selections) then press Delete to delete the time and 
everything in it.  Notes and unpitched sounds either side of it will move together in time.  

• Copy & paste time by selecting it then pressing X /Ctrl+C, clicking on the background at the time 
at which you would like to paste, and pressing X /Ctrl+V.  Unlike notes and unpitched sound, 
pasted time is inserted, causing notes/unpitched sounds either side of it to be shifted further apart 
in time.  

• Quickly duplicate a time selection to the next visible beat marker by pressing X /Ctrl+D.  The 
distance of the selection from the preceding beat marker is maintained and the duplicated time is 
stretched to fit with the destination BPM.  Any notes or unpitched sounds at the destination that 
are not locked or muted from the Layers Panel are deleted.  

• DeepAudio only: Use Equalize Bar Lengths from the Tools/RipScripts>Tempo submenu to set all 
bars to be the same length as bar 2.  

Volume & EQ 

• Change the overall volume of a selection of notes by 
using the slider next to Level in the Adjust/Effects 
menu.  

o Click & drag the slider to the right/left to 
increase/decrease the volume. 

o Double-click slider to reset its position.  

• Change the overall volume of an entire layer by using 
the slider next to the name of that layer in the Layers 
panel (in the bottom-right of the RipX window).  

• Change the overall volume of the entire Rip by using the slider next to Master in the Layers panel.  

• Mute or solo a layer by clicking the M or S button to the left of its name.  

• The EQ and stereo panning of each layer, and of the entire Rip, can be adjusted as follows:  

1. Hover the mouse pointer over that layer, or Master, in the Layers panel.  

2. Click on the arrow that appears to the left of its slider.  

3. Use the sliders that appear beneath.   

4. Click the arrow again to hide these sliders.  

• DeepAudio only: See DeepAudio: Advanced Editing Techniques to learn how to apply fades 
and other volume envelopes to selections of notes and how to remove volume vibrato and other 
fluctuations from a note. 
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Unpitched Sound 

• Unpitched sound is any sound without a definite pitch.  This includes unpitched percussion, certain 
special effects and sibilants (e.g. vocal sss, sh, f & t sounds).   

o Sibilants are displayed at the pitch of the surrounding vocals to which they belong so that 
they are easy to select and edit together with them.  

o Other unpitched sounds are shown at the bottom of the Rip. 

• Select unpitched sound by clicking on it or by clicking & dragging a selection rectangle over it.  
Select all unpitched sound in a Rip at once by clicking Edit>Select All Unpitched or by pressing 
X z /Ctrl+Alt+A. Then edit it in the following ways:   

o Click & drag it horizontally to move it forwards or backwards in time.   

o Click & drag the ends of it to change its duration.  

o Delete it by pressing Delete.   

o Cut or copy & paste it by pressing X /Ctrl+X or X /Ctrl+C then X /Ctrl+V. 

o From the Adjust/Effects menu, apply adjustments/effects (that do not relate to pitch).  

o Note: It is not possible to click & drag unpitched sound up or down to change its 
frequency.  

• DeepAudio only: See DeepAudio: Advanced Editing Techniques to learn about an easier way 
to edit unpitched sound.  
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DeepRemix: Playback, Loops, Randomize & Ripples 

Playback 

• To start playback, click the Play button  or press Spacebar. 

• Playback can be stopped either by clicking the Stop playback button or by pressing Spacebar once 
again.   

• If a cursor is displayed, playback starts from the position of the cursor unless there is a loop set 
(see below) and the cursor is outside that loop.  

• If audio is selected and there is no loop set, only the selection is played back. 

• Click the button to the left of the Play/Stop button or press Enter to return playback to the start of 
the Rip.  

• Edits and effects can be applied to a Rip whilst it is playing back, creating a live performance.  This 
is particularly effective when playing back a loop (see below).  

Loops 

 

The Loop bar, located just above the Timeline above the Rip, can be used to create loops.  

• Set a loop region in various ways: 

o Click & drag over the Loop bar from left to right.   

o Make a selection of notes or time and press L to mark a loop that covers that selection.   

o Double-click on the Loop bar to set a loop over the bar in which you double-clicked.  

o Move the loop forwards or backwards in time by clicking & dragging it along the Loop bar.   

o Click & drag the edges of the loop to resize it 

o Click outside of the loop in the Loop bar or press L to cancel it.   

o Note: The loop will automatically snap to the beat markers if Snap To Beat Markers is checked 
in the View menu.  Hold down z  /Alt whilst clicking & dragging to reverse this setting.   

• Start and stop playback (see above) to hear the loop play back.  Playback begins from the start of 
the loop or from the cursor if it is inside the loop.  

• Each time playback returns to the start of the loop, experiment with applying different edits and 
effects to the notes within the loop.   

o See below to learn how to make DeepRemix apply a different random selection of 
adjustments, effects and musical scales to the loop each time its playback restarts.  

• You can also right-click on a selection of notes and/or unpitched sound and click Split At Loop 
Marker (or press x X /Ctrl+Shift+J) to split them at the points where they cross the start and end 
of the loop marker.  
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Randomize 

RipX can apply a random selection of adjustments, effects and musical scales to notes/unpitched sounds each 
time they are played back.   

Randomize Adjustments / Effects  

• Make a note or time selection and then click Randomize in the Adjust / Effects menu. 

• Click & drag the slider button to the right/left to increase/decrease the level of randomization. 

• Click Randomize to remove this effect. 

• Once Randomize has been applied to a selection, click on the Dice icon to the right of any other 
effect's slider to include/exclude that effect from being randomly applied.  

• For each included effect (marked by a Dice icon), click & drag its slider button right/left to 
increase/decrease the level of randomization with which it is applied.   

• For higher Randomize levels, the effect levels are continuously adjusted during a note's playback.  

• If you copy & paste notes with Randomize applied, the copy will contain the latest effects set in 
stone.  Note that this does not record effect variations within a note. 

o Tip: Try typing L to create a loop marker for the selection (see above) and hit Play.  At the 
start of each loop, new effects will be applied, and repeated loops will be kept in a Ripple 
under the Rip in the RipList Panel (see below).  

Randomize musical scales 

• Click Set Musical Scale in the bottom-left corner of the window.  

• Click Randomize in the menu that opens.   

• In the same menu, Auto Pitch To Scale is automatically selected, meaning that the pitches of all 
notes will automatically snap to the randomly selected scale each time playback is started.  

• To apply random scales to a selection of notes, uncheck Auto Pitch To Scale and apply the Pitch To 
Scale effect to them.  

• Once a scale has been set, scale changes can be added by hovering the mouse pointer to the right 
of a bar-line handle (beneath the bar line) and clicking Add Scale Change.  From there, select 
Randomize again to have multiple random scales in the same Rip, or choose a fixed scale.   

• Uncheck Randomize to prevent RipX from making any further random changes to the musical 
scale and click Clear to remove it.  

Ripples 

 

When experimenting with edits, adjustments and effects during looped playback, RipX makes a recording of 
the live audio, stored as a Ripple beneath the Rip in the RipList Panel.   
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• Stop playback and then click on the Ripple to view it, play it back or make edits to it.   

• If there is part of a Ripple that you particularly like, make further use of it by copying & pasting it 
into a new or existing Rip.  (Press X /Ctrl+N to create a new Rip.) 

• You can also loop a bar in a Ripple, producing 2nd, 3rd and further Ripples, by editing different 
elements of the bar each time. 

• Important: To keep a Ripple you like, click the Tick icon to the left of the Ripple’s name to save it 
with the Rip. This is required to prevent Ripples from building up over time (in case you are not 
interested in this automatic feature), and Ripples will otherwise be overwritten each time a new 
Ripple is created in the same Rip.   

• Click the arrow icon to the left of the name of a Rip in the RipList Panel to hide/show its Ripples.  
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DeepRemix: Useful Keyboard & Mouse Shortcuts (macOS/Windows) 

Left/Right Move cursor to previous/next beat marker.  

X /Ctrl+Left/Right Move cursor to previous/next bar line.  

z  /Alt+Left/Right Nudge cursor slightly to the left/right.  

Click+drag  Multiple select whole notes & unpitched sounds or, by clicking & dragging 
over an empty region, select a period of time.   

 z Click+drag   
Alt+click+drag  Multiple select parts of notes & unpitched sounds. 

Double-click background Select all time in same bar. 

Double-click note Select all notes in same bar but not parts of them that extend outside of it.  

Double-click loop bar Set loop marker over bar.  

 x Click background   
Shift+Click background Select time from the position of the cursor to this point.  

 x Left/Right 
Shift+Left/Right Select time from the position of the cursor to the previous/next beat marker. 

Also extends or shortens an existing time selection to the nearest beat maker. 

 Xx Left/Right 
Ctrl+Shift+Left/Right Select time from the position of the cursor to the previous/next bar line.  Also 

extends or shortens an existing time selection to the nearest bar line. 

Up/Down   Shift the selected notes up/down a semitone or one pitch up/down in a scale. 

 X Up/Down    
Ctrl+Up/Down    Shift selected note up/down one octave. 

 z Drag note  
Alt+drag note  The opposite of the current Snap To Beat Markers or Snap To Semitone 

Guidelines setting is applied during pitch and time adjustment, so you can 
toggle snapping without accessing the View menu. 

 Xx V   
Ctrl+Shift+V  Paste cut/copied notes/unpitched sounds and fit to destination tempo (BPM). 

 X D  
Ctrl+D  Duplicate selected notes or time to the next visible beat marker, adjusting for 

any changes in tempo and maintaining the distance from the preceding beat 
marker.  If time is duplicated, any notes or unpitched sounds at the 
destination that are not locked or muted from the Layers Panel are deleted. 

 X G   
Ctrl+G   Group selected notes/unpitched sounds to edit them like a single object. 

 z Click note   
Alt+Click note   Select single note/unpitched sound in group to edit independently of the rest. 
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 Xx G    
Ctrl+Shift+G  Ungroup selected notes/unpitched sounds. 

 z G   
Alt+G   Hide notes in group so that the group can be quickly selected and moved by 

clicking anywhere within its box.  Press to show them again.  

 X J    
Ctrl+J   Join selected notes/unpitched sound together. 

 Xx J    
Ctrl+Shift+J  Split selected notes/unpitched sound at the points where they cross the start 

and end of a loop marker.  

Xz   C 
Ctrl+Alt+C Copy selected notes/unpitched sound/time into a RipCut stored beneath the 

Rip in the RipList Panel for quick convenient access to favorite sounds.   

 Xx M    
Ctrl+Shift+M  Unmute all layers.  

Scroll Wheel  Scroll time. 

 x Scroll Wheel   
Shift+Scroll Wheel   Scroll pitch. 

 X Scroll Wheel   
Ctrl+Scroll Wheel   Zoom time in/out. 

 Xx Scroll Wheel   
Ctrl+Shift+Scroll Wheel   Zoom pitch in/out. 

^/Ctrl+Tab   Swap between the current and previously displayed Rip. 

Esc Cancel note & unpitched sound drags/longer editing actions/playback/note, 
unpitched sound & time selections/menus. 

Right-click Rip Open a menu that includes various editing options and tools at the position of 
the mouse pointer.   

 z Right-click selection   
Alt+Right-click selection Open the Adjust / Effects menu at the position of the mouse pointer. 

Click+drag 
barline handle Realign barlines with beats without changing the duration of notes. 

Click arrow icon next to layer name   

Assign notes to a different layer by selecting them and clicking the arrow icon 
next to its name in the Layers Panel at the bottom-right of the window. 

 X O    
Ctrl+O   Open Rips, CD tracks, MP3s, WAV, FLAC, OGG & MIDI files. 

 X E   
Ctrl+E  Export part or all of a Rip as a Rip, MP3, WAV, FLAC, OGG, MIDI, or Stem file.  

Choose to export it as a single file or as separate stems/layers.  
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DeepAudio: Audioshop & Other Tools 

Audioshop  

 

Audioshop is located in the tool bar area below the menu bar and consists of the tools described below.  Each 
tool can be selected by clicking on one of the 10 buttons shown on the left-hand side of the above screenshot.  
The area to the right of these buttons contains appropriate instructions and options that vary, depending on 
which tool is selected.  When the first tool is selected (as shown in the above screenshot), this area contains an 
array of buttons for quick access to other useful tools which are also described below.   

We will often refer to these tools, including Audioshop as a whole, as RipScripts.  RipScripts are tools 
specifically written for RipX with the Python 3 programming language.  More information about them, and 
how to write your own, can be found in DeepAudio: RipScript Editor.  

For convenience, Audioshop’s tools can also be accessed via a menu that appears at the location of the mouse 
pointer when right-clicking within a Rip.  They can also be quickly selected by pressing a number key between 
0 and 9.  The number keys from 1 to 9 select the first nine tools as appropriate and 0 selects the last of them.  
Audioshop’s tools are as follows: 

 Move/Resize Tool 

 

Use this to click & drag notes up or down in pitch and to click & drag notes/unpitched sounds left or 
right in time.  Click & drag the edges of notes and unpitched sounds to resize them.  When this tool is 
selected, a Fine Selection checkbox is shown to the right of Audioshop. Check this box to select parts of 
notes/unpitched sounds when clicking & dragging a selection rectangle over them (hold down z  /Alt 
whilst doing so to select entire notes and unpitched sounds).  

 Edit Unpitched Tool 

 

Conveniently displays all unpitched sound spread over the entire Rip, from its top to its bottom.  Click & 
drag to select a region of unpitched sound and edit it.  Pitched sounds/notes are shown in the 
background for reference only and cannot be selected or edited.  RipX automatically chooses an 
appropriate contrast with which to display unpitched sound.  This can be adjusted to a fixed setting by 
unchecking Auto and choosing a different contrast with the slider.   

Draw Sound Tool 

 
Use this with the Sound Palette to draw notes and other sounds.  The Sound Palette is located beneath 
the menu bar, to the right of the Audioshop toolbar.  (Note: On small screens, or if the RipX window has 
been resized to a small size, Sound Palette may appear beneath Audioshop.)  
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In Sound Palette, choose a palette and then an instrument or other sound sample within that palette to 
draw with.  Change the volume level of the sample by clicking & dragging the Level slider left or right.  
Click the Play button directly to the right of that slider to audition it.  In the options to the right of 
Audioshop, choose whether to draw the sample at its original pitch or at the pitch at which the mouse 
pointer is located.  (If a palette’s instrument contains multiple notes at different pitches, the pitch of the 
first note to be added to that instrument will be used as the original pitch.)  Also choose whether or not 
to always draw the entire sample.  Click & drag from left to right to create a new note.  Drag back to the 
left once started to cancel. 
A selection of instrument samples is included with RipX in the Primary and Primary Drum Kit palettes 
but you can add your own instrument samples directly from a rip as follows:  

1) If you wish to include associated unpitched sounds with a note, first select them in addition to 
the note by X /Ctrl-clicking or dragging over them and then use Audio>Group (X /Ctrl+G). 

2) Ensure the note is assigned to the correct layer for the instrument by selecting it and then 
clicking on the arrow icon next to the layer name in the Layers Panel (bottom-right of window).  

3) Click on the pitched note and click the + button in the Sound Palette toolbar. 

4) Repeat for differently pitched notes if required, each around an octave apart. RipX 
automatically generates missing pitches as and when they are needed.  Quickly switch between 
the Rip and the palette by clicking on the pencil icon to the left of the + button.  

5) The new instrument will be automatically selected for you to draw with right away.  A palette is 
automatically created for it with the same name as the Rip from which the sample was taken.  

It is also possible to import your own samples of sounds (such as drums, speech & sound effects) from 
audio files by clicking the Import Samples         button in the Sound Palette toolbar:  

1) Browse to the folder where the audio files are located.  

2) Select only those audio files that you would like to be included in the same category (e.g. Drums 
or Special Effects).   

3) Click Open and wait for all of the audio files to be ripped.  As ripping completes, they are 
automatically added to a new Imported Samples palette listed in the RipList Panel.   

o The Imported Samples palette can get filled up pretty quickly and slow down the 
selection of samples within it.  It is therefore recommended that you rename it to 
something appropriate from time to time so that it starts afresh the next time samples 
are imported. 

o Apart from the palettes included with RipX, a palette can be renamed, removed from 
the RipList Panel or deleted by right-clicking on it and clicking on the appropriate item in 
the menu that opens. You can quickly open the currently selected instrument in the 
RipList panel by clicking on the pencil icon to the left of the + button. 

o Palettes are stored as Rip files and can be re-opened like any other Rip file (e.g. by 
clicking File>Open).  

o To view the samples within a palette, click on the arrow icon to the left of its name and 
click on each of the listed instruments to view its contents.  



© Hit’n’Mix Ltd 2009-2021 

 
26

  

Split Tool  

Split a note or unpitched sound into two by clicking on it at the point at which you’d like it to be split.  
Notes can also be split whilst other tools are selected by right-clicking on them and clicking Split Here or 
Split At Loop Marker.  

Join Tool  

Click on the edge of a note where it touches another to join those two notes together.  Click & drag 
across a sequence of touching notes to join them all together.  

Replace Sound Tool 

 

In the Sound Palette toolbar (to the right of the Audioshop toolbar), choose a palette and then an 
instrument (or other sound sample within that palette) and click on notes to replace their sounds with 
that of the chosen replacement sound.  Quickly apply to multiple notes by selecting them and clicking on 
the Replace Selection button in the right of the Audioshop toolbar.  A selection of instrument samples is 
included with RipX but you can add your own – see Draw Sound Tool above for details on how to do 
this.   

Clone Pitch/Sound Tool 

 

Clone characteristics such as pitch variation (e.g. vibrato), sound (timbre with volume) & panning of a 
chosen (X /Ctrl-clicked) note and apply them to other notes.  Check From Start to keep the distance 
from the start of the note unchanged.  Change the duration of the brush with the slider to the right.  

Draw Pitch Tool 

 

Use this to draw the pitch of a note by clicking & dragging over it, moving the mouse pointer up/down 
to smoothly increase/decrease the pitch with respect to time.  To the right of Audioshop, click Map 
Pitch to open Pitch Mapper (see below) and apply a slide or other pitch contour to a selection of notes 

• Tip: To more accurately make fine edits, first zoom in on pitch by positioning the mouse pointer over 
the area you would like to zoom in on and using the mouse wheel whilst holding down 
x X /Ctrl+Shift.  Alternatively, click & drag vertically over the piano keyboard in the region of pitch 
that you’d like to zoom in on. 

• Tip: Once zoomed in, scroll vertically by using the mouse wheel whilst holding down x /Shift or by 
using the vertical scrollbar to the right of the Rip.  

Apply Pattern Tool 

 

Apply fluctuations in pitch, formant, volume, and panning to selected notes.  Choose the duration of the 
brush with the slider.  
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Smooth Region Tool 

 

Blend together the pitch, formant, timbre, volume and/or stereo panning of notes by clicking & dragging 
over them.  Choose the duration of the brush with the slider. 

Other tools 

The following tools are also available from the Tools / RipScripts menu:  

Chord Creator 

Utilize RipX’s built-in key recognition to automatically add chords to melodies.  

 

• Click Detect Key to automatically determine the key, or choose it manually by selecting whether 
it is major or minor and how many flats/sharps its key signature has.  

• Choose between Above and Below to add the chord above or below the note.  

• Click a note once to add a chord to it. Click it multiple times to view alternatives.  

• As you add chords to a melody, listen to the chord progression by clicking Play Chords. 

• If desired, arpeggiate the chords by choosing a duration in seconds beneath Stagger Notes. 

• Click Remove Chords to remove all chords that have just been added with Chord Creator.  

• Close the Chord Creator window once finished (or press Esc).  

Harmonic Editor 

View the harmonics of selected notes and edit them in powerful ways.  
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• Harmonic Editor can also be opened by pressing X /Ctrl+T.  

• Choose a tool by clicking on one of the buttons at the top.  A description of the selected tool and 
its keyboard shortcut is shown beneath the buttons.  

• Choose the Select/Edit/Mask Tool to hear ranges of harmonics and time by clicking & dragging 
over them, then press Up/Down/Backspace to increase/decrease/remove the selected sound.  
This tool can also be used to place a cursor.  Press Escape to remove it.   

• Click the Play button to hear the entire note/unpitched sound or only that part of it from the 
cursor onwards or within the selection.   

• You can change the duration and volume level of the brush with the sliders and choose which 
harmonics to apply the edits to.   

• The decibel (dB) level, harmonic number, frequency, and time at the position of the mouse 
pointer are shown at the bottom.   

• When Remove To Another Note is checked, if sound is removed, it is transferred to a newly 
created overlapping note so that it is not lost.   

• When the  button is selected, live edits such as formant adjustments for pitch shifts, plus 
effects and repairs using the Adjust / Effects and Repair / Clean menus are applied to the 
displayed harmonics. 

• Click the button to the right of the Play button to undo all edits made to the note/unpitched 
sound since it was last opened in Harmonic Editor.  

• Harmonic Editor can edit the frequency components of unpitched sound. However, it should be 
noted that sibilants, snare/tom drum and percussion sounds are usually a group of individual 
unpitched sound objects (which can be ungrouped in the usual way using Audio>Ungroup). Only 
one of these individual objects can be edited at a time. Clicking at different frequencies within a 
grouped unpitched sound object will open each of these in the editor. 

o Tip: Audioshop’s Edit Unpitched Tool (see above) can be used for editing a broader 
bandwidth of unpitched sound. 

• Note: If edits are made to the currently displayed note/unpitched sound with the Audioshop or 
Noise Removal RipScripts, Harmonic Editor automatically updates to display the new 
harmonics.  If for some reason a note is not updated, it is necessary to click the Refresh button 
to the left of the Contrast slider in the top-right corner of Harmonic Editor.  

Clean Phase 

Available from the Clean submenu, removes artifacts from selected notes by recalculating their phases.  
This is useful for improving the sound quality of a note.  Additional cleaning tools are available in the 
same submenu.  

Infinity Scale 

Available from the Effects submenu, use this tool to create an infinitely rising or falling glissando effect 
(based on the Shepard tone auditory illusion).  



© Hit’n’Mix Ltd 2009-2021 

 
29

  

 

• The number of bars per octave determines how quickly it rises or falls.   

• Select Up or Down to choose between a rising or falling effect and Double notes or Triple notes 
to determine whether it uses two or three notes at a time.   

• Click Scale Selected Notes to apply the effect. 

Inharmonicity 

Available from the Effects submenu, this tool adjusts how much the harmonics of selected notes depart 
from whole multiples of the fundamental.  Higher values make notes sound more metallic. Some 
instruments (such as the piano) have a higher inharmonicity than others.  

 

Beat Mapper 

Available from the Mappers submenu, select from the Swing, Sway and Custom presets to change the 
rhythmic feel of one or more bars.  

 

• Ensure bar lines are correctly positioned before use by clicking & dragging the handles beneath 
them.  (Subsequent bar lines update automatically so it is best to start with the first and work 
forwards through the Rip.)   

• When creating a Custom preset, click & drag to add and reposition a beat marker, click & drag 
an existing beat marker to reposition it and click & drag it to the far left or right to remove it.  

• Click Apply To Selected Bars or Apply To All Bars to apply the beat markers to the Rip as 
appropriate. 

Panning Mapper 

Available from the Mappers submenu, adjust the stereo panning over a selection.  Select Set To 
Mapping to set the panning to the absolute position shown rather than adjusting it by the amount 
shown.  
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Pitch Mapper 

Available from the Mappers submenu, apply a slide or other contour to a selection of notes over a range 
of two octaves.  Choose from one of the simple presets or choose Custom to apply a more complicated 
contour.  

 

Volume Mapper 

Available from the Mappers submenu, apply fades and custom volume envelopes to notes.  
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DeepAudio: Advanced Editing Techniques 

Here follow instructions for various types of advanced editing that can be performed with the DeepAudio 
module’s tools.  These are separated into main categories like Pitch, Rhythm, Unpitched Sound and Noise 
Removal.  This should be read after reading DeepRemix: Essential Step-By-Step Editing Instructions.  A 
detailed description of the tools mentioned below can be found in DeepAudio: Audioshop & Other Tools.   

Pitch 

• Use Audioshop’s Draw Pitch Tool to draw the pitch of a note by clicking & dragging over it, moving 
the mouse pointer up/down to smoothly increase/decrease the pitch with respect to time.   

o Tip: Use this to correct or enhance a performance by adding or editing slides/portamentos 
and vibrato.   

o Tip: When editing the pitches of notes connected by a slide, use this to adjust the slide so 
that it continues to connect them in a natural fashion.  

• Use the Pitch Mapper RipScript, available from the Tools/RipScripts>Mappers submenu, to make 
a selection of notes slide up or down by as a much as an octave in pitch or choose from the other 
available presets to apply a more complicated contour.   

• Use Audioshop’s Apply Pattern Tool to add vibrato whose speed and amplitude/strength varies 
with time:  

1. Choose the Sine pattern and Apply to Pitch;  

2. Set the amplitude/strength of the vibrato by clicking & dragging the slider button to 
specify the number of semitones by which the pitch should vary;   

3. Set the speed of the vibrato by clicking & dragging the slider button to specify the Period 
in seconds; 

4. Click & drag over part or all of the note to apply the vibrato.   

▪  Tip: Create a vibrato of growing intensity by applying the sine pattern multiple 
times across the same note, each time increasing the amplitude (e.g. from 0.2 to 
0.3 and then to 0.4 semitones).  If necessary, use Audioshop’s Draw Pitch Tool to 
smooth out the transitions between each vibrato.  

▪  Tip: Make the vibrato more realistic by also applying the sine pattern to the 
volume of the note.  For this, the amplitude is in decibels (dB).   

• Use Audioshop’s Clone Pitch/Sound Tool to clone pitch changes such as vibrato and slides from 
one note to another:  

1. Ensure that only Pitch Changes is selected,  

2. X /Ctrl-click on a note at the start of the vibrato or other pitch variation you’d like to 
clone,   

3. Click & drag over the other note to apply the pitch variation to it.  
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Rhythm 

• Draw new notes between the starts of existing notes with Audioshop’s Draw Sound Tool to 
increase the speed of the rhythm.  

• Use Beat Mapper (available from the Tools/RipScripts>Mappers submenu) to change the 
rhythmic feel of all or only selected bars by changing the relative lengths of the beats within them.  
Choose one of the presets (e.g. Swing) from the drop-down menu or follow the instructions to 
design a custom effect.  

Volume 

• Apply fades and other volume envelopes to selections of notes with Volume Mapper, available 
from the Tools/RipScripts>Mappers submenu and choose either:  

o Fade In, Fade Out, Fade In & Out or Fade Out & In from the Presets drop-down menu, or 

o Custom and then follow the instructions to apply a volume envelope of your own design.  

▪  Tip: Use this to add or remove expression such as a swell from a note.   

• Select Audioshop’s Smooth Region Tool, ensure that only Volume is selected, and then click & 
drag over the note.   

o Note: Any associated pitch vibrato can be removed with Flatten Pitch in the 
Adjust/Effects menu – see Quickly flatten, slide, or add constant vibrato to pitch.  

Unpitched Sound 

• Use Audioshop’s Edit Unpitched Tool to conveniently display all unpitched sound, spread out over 
the entire Rip, from its top to its bottom.  Click & drag over a region to select and edit it.  Pitched 
sounds/notes are displayed in the background for reference and cannot be selected or edited.  

Noise Removal, Repair & Timbre Editing 

Clean / Repair Unpitched Audio 

1. Select Audioshop’s Edit Unpitched Tool and, where the noise occurs, check if some or all of it has 
been recognized as unpitched sound by clicking & dragging over unpitched sound to listen to it.  
Then,  

a) If an unpitched sound contains the noise and nothing else, select it and press Delete. 

b) If it also contains a sound that is needed (such as a drum sound), check if that sound 
appears by itself elsewhere.  If it does, delete the unpitched sound containing the noise 
and replace it with the other noiseless unpitched sound by copying & pasting it across.  
(See Unpitched Sound in DeepRemix: Essential Step-By-Step Editing Instructions.)  

c) Otherwise, move on to the following step.  

2. Quickly remove any background or foreground noise from a selection with the Clean / Repair 
menu options – in particular, Filter Background, Limit Foreground, Clicks & Thuds and Tones & 
Hum. See below for details. 
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Clean / Repair Menu 

This menu works in a similar way to the Adjust / Effects menu - drag the slider to set the extent of 
the adjustment. 

These affect selected unpitched audio and pitched note timbre. You can view live adjustments to 
pitched notes (including automatic changes to formants by pitch shifts and other pitch effects) 
from within the Harmonic Editor – just ensure the 

 button at the top right is selected. To set live 
repairs and clean-up in stone, use Audio > Render 
Adjustments & Effects. 

Below is a brief description of each option. 

1. Filter Background – Removes unpitched audio 
and harmonic slices below a given dB level. 

2. Limit Foreground – Limits the dB level of 
unpitched audio and harmonic slices. 

3. Tones & Hum – Removes unwanted sounds like tones and hums, up to a maximum 
bandwidth. 

4. Purify – Evens out rough and random amplitude changes within unpitched audio and 
harmonics, to create a smoother sound. 

5. Overtone Level– Decreases/increases the level of overtones within pitched sounds, by 
adjusting harmonics. 

6. Fundamental Level – Decreases/increases the level of the fundamental (1st harmonic) within 
pitched sounds. This can even be used to regenerate a fundamental that was filtered out 
during a mixing/mastering process, adding more bass presence back to sounds like vocals. 

7. Filter Notes - Removes pitched notes below the selected dB level. This can be useful for 
removing quieter unwanted notes before exporting to MIDI. 

Edit Pitched Timbre 

• Use Harmonic Editor (available from the Tools/RipScripts menu or by pressing X /Ctrl+T) to view 
and edit the harmonics of a selected note.  

o Tip: Experiment with different edits made with different tools, listening to the effects that 
they have on the timbre of the note/unpitched sound.   

o Tip: Click & drag over part of the harmonics with the Select/Edit/Mask Tool to listen to 
that part only.  

• Use Audioshop’s Clone Pitch/Sound Tool with Sound selected to clone timbre (and volume) from 
one sound to another.   
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DeepAudio: Additional Keyboard & Mouse Shortcuts (macOS/Windows) 

Right-click Rip Open a menu at the position of the mouse pointer that includes various 
editing options and tools plus all of Audioshop’s tools.   

1 Select Audioshop’s Move/Resize tool.  

2 Select Audioshop’s Edit Unpitched tool.  

3 Select Audioshop’s Draw Sound tool.  

4 Select Audioshop’s Split tool.  

5 Select Audioshop’s Join tool.  

6 Select Audioshop’s Replace Sound tool.  

7 Select Audioshop’s Clone Pitch/Sound tool.  

8 Select Audioshop’s Draw Pitch tool.  

9 Select Audioshop’s Apply Pattern tool.  

0 Select Audioshop’s Smooth Region tool.  

 X T  
Ctrl+T  Open Harmonic Editor to view and edit the harmonics of a note/unpitched 

sound. 

1 Select the Select/Edit/Mask tool within Harmonic Editor.  

2 Select the Paint Sound tool within Harmonic Editor. 

3 Select the Erase Sound tool within Harmonic Editor.  

4 Select the Adjust Level tool within Harmonic Editor. 

5 Select the Remove Noise tool within Harmonic Editor. 

6 Select the Reduce Loud Harmonics tool within Harmonic Editor.  

7 Select the Smooth Harmonics tool within Harmonic Editor. 

8 Select the Clone From Time Slice tool within Harmonic Editor. 

9 Select the Reduce To Time Slice tool within Harmonic Editor. 

0 Select the Increase To Time Slice tool within Harmonic Editor. 

 x 1   
Shift+1   Select the Reduce By Time Slice tool within Harmonic Editor. 

 x 2   
Shift+2  Select the Increase By Time Slice tool within Harmonic Editor. 

 Xx R  
Ctrl+Shift+R  Open the Noise Removal RipScript to quickly remove foreground or 

background noise from a selection.  
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DeepAudio: Using RipX with DAWs 

Most leading DAWs (Digital Audio Workstations) can open audio clips for editing with RipX: DeepAudio.  Plug-
ins are installed with RipX so that it can be used with Pro Tools and DAWs that support VST3/ARA2.  For other 
DAWs, such as Logic Pro X and Ableton Live, it is possible to work with RipX by setting it as its external sample 
editor. 

Pro Tools AudioSuite 

For Pro Tools, the RipLink AudioSuite plug-in is automatically installed with RipX: DeepAudio.   

Note: Pro Tools version 12.2 (Windows) / 12.8.2 (macOS) or later is required. 

1) In Pro Tools, select audio in a single track and choose AudioSuite>Other>Edit In RipX. 

2) Click RipX in the window that opens.  

3) RipX will bring up the usual options for ripping the audio and then start processing. 
If the clip has been previously ripped and is in the RipList, RipX will first ask whether you’d like to open 
that instead.   

4) Once ripped, edit as you would normally. 

5) When you have finished, click File>Update in Pro Tools (zX S / Ctrl+Alt+S).  

Important: if you experience no audio playback within RipX whilst Pro Tools is running, try the following: 

• If Pro Tools is using ASIO4ALL as the playback engine, try changing it to another in Setup>Playback 
Engine… 

• Alternatively, close Pro Tools and select an alternative playback device not used by Pro Tools from 
RipX>Preferences… (macOS) or File>Preferences… (Windows).  Then restart Pro Tools and try again. 

• If no other devices are available, try installing and selecting ASIO4ALL, available to download from 
http://www.asio4all.org/.  ASIO4ALL is a widely used ASIO driver but as it is a third-party product, 
Hit’n’Mix Ltd takes no responsibility for its usage. 

VST3/ARA2 

Installed with RipX: DeepAudio is the RipLink plug-in for VST3/ARA2.  DAWs that support this include:  

Studio One (v 4 or later)   Cakewalk (v 2019.05 or later)  
REAPER (v 5.97 or later)   Cubase Pro/Nuendo (v 11.0.30 or later) 

 
Studio One 

1) Split the sections of each track that you would like to edit in RipX from the rest of the track by using 
the Split Tool.  

2) Switch to the Arrow Tool and click on one of the sections to select it. 

3) Open the Inspector (if it is not already open) and, next to Event FX, click Enable.  

4) In the Inserts panel that appears below, click on the + button.   

5) In the search box, start to type RipLink and click on it when it appears in the search results below.  

6) Repeat steps 3-5 for the other sections that you would like to edit in RipX. 
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7) Click RipX in the RipLink plugin window.  

8) RipX will bring up the usual options for ripping the audio.  Click Rip to start ripping.   

(Note: If the section has been previously ripped and is in the RipList, RipX will first ask whether you’d like to 
open that instead.) 

9) Once all sections have been ripped, edit them as you would normally. 

10) When you have finished, display each Rip and choose File>Update In Studio One (zX S / Ctrl+Alt+S) 
to update the audio in Studio One.  

Cubase Pro/Nuendo 

1) Split the sections of each track that you would like to edit in RipX from the rest of the track by using 
the Split Tool.  

2) Switch to the Object Selection Tool and click on one of the sections to select it. 

3) From the menu bar, select Audio > Extensions > RipLink.  

4) Repeat steps 2-3 for the other sections that you would like to edit in RipX. 

5) Click RipX in the RipLink plugin window.  

6) RipX will bring up the usual options for ripping the audio.  Click Rip to start ripping.   

(Note: If the section has been previously ripped and is in the RipList, RipX will first ask whether you’d like to 
open that instead.) 

7) Once all sections have been ripped, edit them as you would normally. 

8) When you have finished, display each Rip and choose File>Update In Cubase/Nuendo (zX S / 
Ctrl+Alt+S) to update the audio in Cubase/Nuendo. 

REAPER 

1) Split the sections of each track that you would like to edit in RipX from the rest of the track by clicking 
on the track and pressing S.  

2) Double-click on one of the sections.  

3) At the bottom of the Media Item Properties dialog box that opens, click Take FX… 

4) The Add FX dialog box opens.  In the tree on the left-hand side, click on Hit’n’Mix under Developers.  

5) Click on VST3: RipLink in the panel on the right and click Add (macOS) or OK (Windows). 

6) Repeat steps 2-5 for the other sections that you would like to edit in RipX. 

7) Click RipX in an FX dialog box.  

8) RipX will bring up the usual options for ripping the audio.  Click Rip to start ripping.   

(Note: If the section has been previously ripped and is in the RipList, RipX will first ask whether you’d like to 
open that instead.) 

9) Once all sections have been ripped, edit them as you would normally. 

10) When you have finished, display each Rip and choose File>Update In REAPER (zX S / Ctrl+Alt+S) to 
update the audio in REAPER.  
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Cakewalk 

1) Select the section you would like to edit in RipX.  

2) Right-click on the section and select Region FX > RipLink > Create Region FX.  

3) Repeat steps 1-2 for the other sections that you would like to edit in RipX. 

4) Click RipX in the RipLink plugin window.  

5) RipX will bring up the usual options for ripping the audio.  Click Rip to start ripping.   

(Note: If the section has been previously ripped and is in the RipList, RipX will first ask whether you’d like to 
open that instead.) 

6) Once all sections have been ripped, edit them as you would normally. 

7) When you have finished, display each Rip and choose File>Update In Cakewalk (zX S / Ctrl+Alt+S) to 
update the audio in Cakewalk.  

Other DAWs  

1) In your DAW, use its splitting tool to separate out the part of the track that you would like to edit in 
RipX 

2) Add the RipLink plug-in (from developer Hit’n’Mix) to that section of track. 

3) Ensure that the section of track is selected. 

4) Click RipX in the RipLink plug-in’s window.   

5) RipX will bring up the usual options for ripping the audio.  Click Rip to start ripping.   

(Note: If the section has been previously ripped and is in the RipList, RipX will first ask whether you’d like to 
open that instead.).   

6) Once all sections have been ripped, edit them as you would normally. 

7) When you have finished, choose File>Update In DAW (zX S / Ctrl+Alt+S) to update the audio in your 
DAW. 

Important: if you experience no audio playback within RipX whilst your DAW is running, check whether it has 
an option to disable audio when running in the background, or try using an alternative playback device in RipX 
from RipX>Preferences… (macOS) or File>Preferences… (Windows). 

Using As External Sample Editor 

Setting Up the DAW 

This only needs to be done once and tells the DAW where RipX can be found. For example: 

Windows:   C:\Program Files\Hit'n'Mix\RipX\RipX.exe 

macOS:  Applications/RipX 

Logic Pro X Version tested: 10. Select the File Editor tab from Logic Pro X > Preferences > Audio. (If 
this tab is not shown, click Advanced from the toolbar, then Show Advanced Tools and 
enable Audio, before returning to Audio > File Editor on the toolbar). Click the field next 
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to External Sample Editor and locate and choose the RipX executable. Close the dialog 
box. 

Ableton Live Version tested: 10. Open the Preferences (Windows: Options > Preferences or macOS: 
Live>Preferences) and select the File Folder tab. Click the Browse button next to Sample 
Editor and locate and choose the RipX executable. Close the dialog box. 

FL Studio Version tested: 20. Only worked on Windows. Open the External tools settings, found in 
OPTIONS > File settings (FL Studio 20) or TOOLS > External tools (earlier versions). Click 
the folder icon and locate and choose the RipX executable. Important: Ensure Launch 
with file/sample is selected. Close the dialog box. 

ACID Pro Version tested: 9. Open the Preferences (Options > Preferences) and select the Editing 
tab. Click the Browse button next to Editing application 1/2/3 and locate and choose the 
RipX executable. Important: Next, enter RipX next to Name. Click OK to close the dialog 
box. 

Digital Performer Version tested: 10. Click Audio > Use External Waveform Editor and locate and choose the 
RipX executable. 

Mixcraft Version tested: 8.1. Open the Preferences (File > Preferences) and select General from the 
left-hand side. Click the Browse button in the External Wave Editor section and locate and 
choose the RipX executable. Click OK to close the dialog box. 

 

Sending the Sample to RipX 

Logic Pro X Select an audio clip and choose Edit > Open in RipX from the toolbar menu or press x W. 

Ableton Live Double-click the title of the audio clip to edit, then right-click the waveform in the Sample 
Display/Note Editor (bottom of screen by default) and choose Manage Sample File from 
the menu. In the Replace Files pane (right of screen by default) the audio clip will be 
selected – click Edit next to it. Note that this also takes the sample off-line within Live. 

FL Studio Double-click the sample to open the Sample settings. Right-click over the waveform 
display and choose RipX from the menu. 

ACID Pro Right-click the sample in the timeline and choose Event Clip > Edit in RipX from the menu. 
(Alternatively, select the sample and use Tools > Edit in RipX from the menu  

Digital Performer Click the sample and choose Audio > Edit in Waveform Editor. 

Mixcraft Right-click the title of the audio clip to edit, then choose Edit In External Editor…. In the 
dialog box that appears, choose either to Edit A Copy Of The Sound, or Edit Actual Sound 
and then click Edit. Note that RipX automatically makes a copy of the audio before 
updating it. 

Editing and Updating the Sample 

RipX will bring up the usual options for ripping the audio and then start processing. If the clip has been 
previously ripped and is in the RipList, RipX will first ask whether you’d like to open that instead. 
Depending on the length of the sample, you may wish to do further work within the DAW or other rips 
within RipX whilst it takes apart the audio. 

Once ripped, edit as you would normally. 
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When you have finished, choose File > Update Source (zX S / Ctrl+Alt+S). RipX will check that you want 
to update the file before exporting it in the same file format as the source. 

As a precaution, RipX will also create a backup of the original file alongside it, with [Original] appended to 
the filename. This can be deleted using Finder/Explorer when you are sure you no longer require the 
original. 

Let the DAW Know About the Update (only required for the following DAWs) 

Ableton Live Click the Edit button next to the sample once again so that it is no longer highlighted. 

FL Studio Right-click the waveform in the Sample settings to bring up the menu and choose Reload. 

Mixcraft Click Done in the Waiting… dialog box. 

 

Pro Tools, Studio One, Cakewalk, Logic Pro X, Ableton Live, Logic Pro X, Digital Perfomer, ACID Pro, Mixcraft, Cubase, Nuendo & REAPER are trademarks or registered 
trademarks of their respective owners. 
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How To… 

The following section explains how to perform a number of common tasks with RipX. 

Change the Key of a Rip 

1. Click Edit>Select All Pitched (X x A / Ctrl+Shift+A) to select all pitched notes in the Rip.  

2. Press the Up/Down arrow key a number of times to shift the selected notes up/down by that number 
of semitones.  

• Tip: For best results, shift the notes in the direction that requires the smallest shift.  For example, 
shift the notes down one semitone to change the key from C major to B major instead of up 11 
semitones.  

3. If any notes are now too high or too low, select them and press X Down/Ctrl+Down or X Up/Ctrl+Up 
to shift them down or up an octave.  

4. To change the mode of the key from major to minor or vice-versa, click Set Musical Scale at the 
bottom-left of RipX and then select the appropriate scale from the menu.   

• Tip: Click Detect to find the key of the Rip and then change it from major to harmonic minor or 
vice versa.  

• Select Auto Pitch To Scale and RipX will automatically shift notes to the nearest semitone for the 
selected key and scale. 

A/B  

The best way to A/B between before and after edits, is to click File>Save Copy (X x S / Ctrl+Shift+S) 
before making any edits to the Rip, then press ^/Ctrl+Tab to quickly switch between the edited and 
original copy (which are both shown in the RipList Panel). 

Manually Separate/Re-assign Instruments 

For instruments other than voice, bass and drums, it may sometimes be necessary to correct the 
assignment of notes within RipX.  This can be done by listening to them, selecting them and then assigning 
them to another layer by clicking on the arrow button to the left of the layer name, in the Layers Panel in 
the bottom-right of RipX.  A new layer can be added to the Layers Panel by clicking Add Layer beneath the 
list of layers.   

Use RipX for Transcription 

1. Click File>Export (X /Ctrl+E) to open the Export dialog.   

2. Under File Format, choose MIDI Notes (.mid) and click Export.  (This format is designed specifically for 
transcription and contains just the overall pitch and amplitude for each note.)  

3. Import the exported MIDI file into notation software.   

• Tip: (DeepAudio only) If the Rip contains quiet notes that do not need to be transcribed, select the 
region in which they appear (e.g. by clicking & dragging a selection rectangle over them) and then 
use the Filter Notes tool in the Clean / Repair menu to filter them out.  
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De-Ess 

Sibilants (such as S, F, X and SH) are usually displayed at the pitch of the surrounding vocal notes to which 
they belong and can be selected by clicking on them.  Once selected, use the Level slider in the Adjust / 
Effects menu to reduce the volume of these sounds.  
• Tip: (DeepAudio only) Use Audioshop’s Edit Unpitched Tool to select sibilants that have not been 

linked to vocal notes by clicking & dragging a selection rectangle over them.  Then use the Level slider 
to reduce their volume.   
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Some Creative Applications 

The following shows how the above tools and effects can be used for music production, composition, 
sampling, song creation and sound design for audio post production and games plus more. Hopefully they will 
also inspire you in your own experimentation!  

Copy & paste notes between different Rips and different parts of the same Rip 

• Create harmony or layered textures by copying & pasting vocal/instrumental notes or sound effects on 
top of themselves then shifting them up or down in pitch.  Improve the effect by reducing the volume 
of the harmony notes with the Level effect and (DeepAudio only) adding subtle variations in pitch with 
Audioshop’s Draw Pitch Tool.  Note that harmony can also be added more quickly (but with less 
control over the notes) by simply applying the Harmony effect.   

• Create a dialog between two singers, actors, instruments, or sound effects by copying a single line or 
sound of one of them and pasting that between two lines or sounds of the other.  Upon pasting, click 
& drag its start and end to find the desired timing.  Alternatively, paste with X x /Ctrl+Shift+V to 
automatically fit to the destination BPM.  Use the Stereo Panning effect to make the different 
performers or sound effects come out of different speakers.  

• Add repetition at regular intervals by using Edit>Duplicate (X /Ctrl+D) on a selection or by copying & 
repeatedly pasting it at other rhythmic intervals.  Notes can then be shifted in pitch to create scales or 
arpeggiated effects.  Alternatively, the Delay effect can be used to create an echo effect. 

Create songs from samples 

1) Open a song that you’d like to add a new part to. 

2) Open the song that contains that new part.   

3) Once all ripping has completed, check that the bar lines are correctly positioned in both Rips.  If they 
are not, click & drag the handle beneath each bar line to move it.  Subsequent bar lines update 
automatically so it is best to start with the first one and work forwards through the Rip.   

o Tip: After viewing the two Rips in succession, quickly swap between them by pressing 
^/Ctrl+Tab. 

4) In the RipList Panel, hover the mouse pointer over the Rip of the first song to view its BPM (shown to 
the right of its name).  

5) Display the Rip of the second song and set its BPM to be the same as the BPM of the first song by using 
the Change Tempo RipScript (accessible by right-clicking on the background of the Rip when nothing is 
selected).   

o Note: This step can be skipped – see note below.   

6) Play back the first song to find the best place to add the new part to.   

o Tip: Create a loop with the Loop bar to listen to a section repeatedly.   

7) In the Rip of the second song, select the notes and/or unpitched sounds that you’d like to add to the 
first and copy them by pressing X /Ctrl+C.  

8) Swap back to the rip of the first song and paste the copied selection by pressing X /Ctrl+V.   
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o Note: If you chose not to change the BPM of the second song,  instead press X x /Ctrl+Shift+V 
to paste and automatically fit to the BPM of the first song. 

Create mashups of your tracks 

1) Rip two or more of your songs that you’d like to combine.  

2) In the Layers Panel (bottom-right of the window) mute (click M) and solo (click S) different layers in 
each Rip and play them back to pick out the best parts to use.  

3) Mute a layer that you’d like to remove from a song or delete all of its notes by right-clicking on its 
name in the Layers Panel and clicking Delete.  

o DeepAudio only: Identify, select and delete any residual unpitched sound associated with the 
layer by using the Edit Unpitched Tool.  

4) Select a layer in another Rip by opening that Rip and clicking on the name of the layer in the Layers 
Panel.  Alternatively, select a vocal phrase, riff or other part of a layer by soloing the layer and clicking 
& dragging a selection rectangle over the required notes/unpitched sounds.  

5) Copy & paste the selection to the Rip with the muted/deleted layer by pressing X /Ctrl+C, switching to 
that Rip, placing the cursor at the point where the selection should be pasted and then pressing 
X x /Ctrl+Shift+V to automatically fit the pasted selection to the new tempo.  

6) Group the selection by pressing X /Ctrl+G so that it can be easily edited as a single object to tweak its 
timing and pitch.  

7) To alter the timing and pitch of any of its individual notes/unpitched sounds, ungroup it by pressing 
X x /Ctrl+Shift+G or hold down z  /Alt whilst clicking & dragging them up/down or left/right.  

8) Experiment with copying & pasting other parts of the Rips together.   

Import MIDI tracks from your DAW 

The following contains steps that can only be performed with DeepAudio.  

1) Export a MIDI track from your DAW as a MIDI file.  

2) Click File>Open or press X /Ctrl+O to import the MIDI file and convert it into a Rip. 

3) Apply vocal, instrumental, and other sounds to selected notes by choosing the sound in the Sound 
Palette, selecting AudioShop’s Replace Sound Tool and then clicking Replace Selection in the area to 
the right of Audioshop.  

o Tip: All notes assigned to the same layer can be selected at once by clicking on the name of 
the layer in the Layers Panel.  

4) If you applied to notes an instrumental sound that differs from the one they had in the MIDI file, 
change the layer they are assigned to by selecting them and clicking on the arrow icon next to the 
appropriate instrument name in the Layers Panel.   

5) If required, add realism to notes in the following ways:  

o Click & drag the starts of notes so that they are no longer strictly in time.  (If Snap to Beat 
Markers is checked in the View menu, hold down z  /Alt whilst clicking & dragging.) 

o Add vibrato from the Adjust / Effects menu or with Audioshop’s Apply Pattern Tool. 
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o Add pitch slides and vibrato by hand with Audioshop’s Draw Pitch Tool or clone these from 
other notes with Audioshop’s Clone Pitch/Sound Tool. 

o Adjust the volume across notes with Volume Mapper, available from the Tools / 
RipScripts>Mappers submenu. 

6) Copy & paste notes into other Rips that you are working on.   

o Tip: When pasting, press X x /Ctrl+Shift+V so that the pasted notes are automatically 
adjusted to fit the destination BPM. 

Put notes onto a different scale 

1) Beneath the Rip, use Set Musical Scale and Add Scale Change to choose musical scales to apply to 
chosen bars.  (See Edit pitch over a musical scale for more information on how to do this.)  Ensure 
that Auto Pitch To Scale is not selected when you do this.  

2) Select the notes that you would like to put onto a different scale.   

o Tip: If the notes all belong to the same layer, solo it (by clicking the S button next to its name 
in the Layers Panel) or lock all other layers (by right-clicking on its name and clicking Lock All 
Others) so that you can quickly select the notes with a selection rectangle without worrying 
about selecting notes in other layers.  

3) Click Pitch To Scale in the Adjust/Effects menu to snap the selected notes to the scale.  

4) Repeat with other selections. 

o Tip: If you need to set different scales to notes in the same layer that are overlapping in time, 
first set the scale for one set, then click Audio>Render Adjustments & Effects or press z  
/Alt+R to set their pitch in stone. Then continue to set the scale for the other set of notes. 

DeepAudio: Give notes a special attack by applying the sound of another instrument, voice or 
sound effect to their starts 

1) In Audioshop’s Clone Pitch/Sound Tool, check Sound & From Start and ensure that all other options 
are unchecked.  

2) Choose a brush with a short duration (e.g. 0.3s).  

3) If the note is significantly quieter or louder than the notes to which it will be applied, compensate for 
this by adjusting the level in the Sound Palette. 

4) Choose the note with the sound you would like to apply to the starts of others by X /Ctrl-clicking it.  

5) Click near the starts of notes to apply that sound to them.  

DeepAudio: Build suspense with an infinite glissando (slide) 

1) Find a preferably long note with a pitch and volume that do not vary much.  

2) Copy & paste it to the point at which you would like the infinite glissando to start.  

3) If desired, shift the pitch of the note up or down (e.g. to the tonic of the key).   

4) Click & drag the end of the note to stretch it over several bars.   



© Hit’n’Mix Ltd 2009-2021 

 
45

  

5) Use Volume Mapper (from the Tools/RipScripts>Mappers submenu) to make the start of the note 
fade in.  (Note that the Custom preset can be used to apply a fade just to the start of the note.) 

6) Open Infinity Scale from the Tools/RipScripts>Effects submenu and choose the Up and Triple notes 
options.   

7) The best effect is achieved by choosing a number of Bars per octave that makes the glissando rise 
slowly yet fast enough that there is enough time for the effect to go through multiple cycles of 
glissando (slide). 

8) Click Scale Selected Notes to apply the effect.   

DeepAudio: Replace an instrumental phrase with a vocal phrase that has the exact same pitches & 
timing (vocal transplant) 

1) Select all notes belonging to an instrumental phrase (e.g. part of a guitar riff). 

2) Join them into one note (X /Ctrl+J) and, if necessary, assign them to the appropriate layer with the 
Layers Panel. 

3) For best results, find a vocal phrase that is not greatly different in length or pitch.  (It need not be from 
the same Rip.)  

4) Select all notes belonging to the vocal phrase then copy & paste them to the start of the instrumental 
phrase.  

5) Whilst still selected, join the vocal notes into one (X /Ctrl+J) and, if necessary, assign them to Voice 
with the Layers Panel.   

6) Click & drag the end of the vocal note so that it is in time with the rest of the music.   

In particular,  

• Fit the rhythm of the words to the drums, rhythm guitar or piano accompaniment, 

• Aligning the shapes of the phrases (e.g. their peaks) can sometimes be a quick way to find a 
good result,  

• Any fine adjustments can be made later.  

7) In Audioshop’s Clone Pitch/Sound Tool, check Pitch Changes, Pitch and From Start. 

8) X /Ctrl-click the instrumental note and then click & drag over the entire length of the vocal note to 
reshape it. 

9) Select and delete the part of the instrumental note that overlaps the vocal note plus any part of the 
vocal note that does not overlap the instrumental note. 

10) If necessary, make fine adjustments to sync the voice to the music by selecting parts of the vocal note 
and moving their starts and ends.  

11) Use the Level effect to adjust the level of the voice to fit with the rest of the music.  
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DeepAudio: RipScript Editor 

Audioshop and tools such as the Clone Pitch/Sound Tool 
and Volume Mapper are all RipScripts, which are based on 
the easy and popular Python 3 programming language.  It is 
possible to write your own RipScripts with the RipScript 
Editor which can be opened from the Tools/RipScripts 
menu.  From the same menu, an introduction to RipScripts 
can be viewed by clicking Create RipScript…, selecting 
Introduction to RipScripts and clicking OK. 

Please email RipScripts to ripscripts@hitnmix.com.  The most useful ones will be featured on our website. 

Notes about some features of the editor: 

Indents RipScripts run in a computer language called Python 3.  It requires that code uses 
indentation rather than brackets for grouping instructions, and each indent can be 
either 4 spaces or 1 tab.  The RipScript editor enters 1 tab each time the Tab key is 
pressed, which particularly for beginners, prevents any confusion that the correct 
number of spaces has been entered.  It is however possible to enter spaces using the 
Spacebar instead, although they cannot be mixed with usage of tabs in a RipScript.  
Code indented using spaces copied & pasted into your RipScript will be automatically 
converted to use tabs if it already uses tabs for indentation. 

Auto-complete As you type, the editor will predict what you want to enter and offer a list of 
selections.  The more you type, the shorter the list will become.  Click on an item to 
enter, or use the keyboard Up & Down arrows and press Enter. 

Object descriptions As you move through different predictions in Auto-complete, RipX will also show you a 
description of the function or attribute and often provide sample code which you can 
insert into your RipScript. To do this, click & drag over the code snippet to select it. 
Then, on macOS, copy by right-clicking over the text and choosing Copy from the 
menu; on Windows, press Ctrl+C. Finally, paste into your RipScript by placing the caret 
at the position you’d like to insert, and using Edit>Paste from the menu bar or X /Ctrl-
V. Descriptions are also shown when you hover the mouse pointer over function 
names, attributes, and some Python keywords in RipScripts. 

Placeholders After selecting a function (followed by brackets) from the auto-complete list, it is 
entered into the RipScript and, depending on the function, will be followed by a list of 
arguments to fill in.  Press Tab to jump to the next argument to fill (for example, if you 
are finished with entering one, or do not need to enter a value). Shift-Tab jumps to 
the previous argument.  Enter finishes entering of arguments and places the cursor 
after the final bracket. 

Arguments that must be filled in are followed by the equals sign: = 

Arguments that are optional are followed by this sign: ≈ 

RipScript reference For a tree diagram showing how various RipScript objects are related to each other, 
with links to a complete online reference of the full API: When the RipScript editor is 
open, choose How To Create RipScripts from the menu (macOS: the menu bar Help 
menu; Windows: the pop-up menu, by right-clicking over the editing section of the 
editor window). 
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Glossary of Terms 

Amplitude Amplitude is related to Volume. However, it does not describe how loud a note 
sounds, but is a physical property of how audio is constructed and defines the height 
of a wave for a slice in a harmonic. In a RipScript it is a value between 0 (silent) and 1 
(full volume). In a 16-bit WAV file it is measured between 0 and 32767. 

ASIO driver A Windows audio device driver, which can be selected from File>Preferences…. ASIO 
is a trademark and software of Steinberg Media Technologies GmbH. 

Decibel (dB) A decibel (abbreviated to dB) is a relative unit of volume. Adding 10 dB to a note 
makes it sound twice as loud. Taking off 10 dB halves the volume. +/- 1 dB is seen as 
the lowest perceivable change in volume for an average person.  

Formant A formant is a grouping of strong harmonics that define different sounds in speech. 
Transposing the pitch of a note without altering the frequency of its formants allows it 
to stay more natural sounding. 

Frequency Frequency, measured in Hertz (Hz), is related to Pitch. It is a physical property of how 
audio is constructed and defines the number of wave cycles per second for a slice in a 
harmonic. 

Full-mix track An audio track that has had all the separate instrument recordings (stems) merged 
into one, requiring software such as RipX to separate them to make them once again 
individually editable. 

Harmonic A musical note or sound is comprised of harmonics, waves at multiples of the 
fundamental frequency (the one you perceive) giving it its timbre or sound. 

Loudness A measure of how loud a note sounds, different from Amplitude (see above). 

MIDI Number MIDI is a standard for playing notes using electronic instruments. The MIDI number is 
a scale of note pitches between 0 and 127 which each have a unique number. For 
example, middle C is 60. 

Panning Panning is the apparent position of a sound, for example between left and right 
speakers. 

Phase Phase is an angle which determines where in a wave’s cycle a particular slice 
represents. 

Pitch Pitch determines how high or low a note sounds. Also see MIDI Number and 
Frequency. 

Python 3  An easy-to-use and popular programming language used for running RipScripts. 

Rip A Rip is an audio file that has been source separated into individual notes, harmonics, 
frequencies, amplitudes, phases and slices by the Ripper. 

RipCut One or more RipCuts can belong to a Rip. They can be listed by clicking the arrow 
button to the left of the Rip’s name in the RipList Panel. Examples of their use are: 

• To store snippets of audio from a Rip you may want to regularly use: Select notes 
in the Rip and then choose Edit>Copy to RipCut from the menu. 
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• RipScripts can use RipCuts to store notes temporarily: For example, to play a 
selection in reverse without affecting the original notes, it could copy the notes to 
a new RipCut, reverse them, play them back and then remove the RipCut. 

• The Sound Palette RipScript uses them to store samples of instruments and other 
sounds.  

• Ripples are also stored as RipCuts. 

RipList A RipList is a collection of Rip files, akin to a playlist, shown at the top-right of the RipX 
window. 

Ripper The Ripper uses sophisticated algorithms to split audio into separate notes, 
harmonics, frequencies, amplitudes, phases and slices, creating a Rip file. 

Ripple A Ripple is an automatic recording of edits make to a loop during its playback.  It is 
created in the Rip format and kept beneath the Rip from which it was created in the 
RipList Panel.  

RipScript A RipScript is a script (or small computer program) written in Python 3 that can 
automate audio processing and provide a user interface in RipX. 

Sample An audio clip in waveform format. 

Slice A separate value for pitch, volume, panning and phase is stored by RipX at regular 
intervals of time, just under 1/100th second. Each interval of time is called a Slice. 

Timbre The character of a note that is unique to the voice, instrument or sound that 
performed it. 

Volume Volume determines how loud a note sounds.  Also see Amplitude, Decibel and 
Loudness. 

Wave For example, a sine wave, is a simple regular to and fro motion which notes are 
generally comprised of at the most basic level. Waves are stored in traditional audio 
formats and represent the movements a speaker needs to make for air to vibrate so 
that sound can be heard by a person. 

Waveform An audio file containing the speaker positions needed to recreate a recorded sound. 

Widget A user interface item such as a button, check box, combo box, or slider that can be 
added to a window in a RipScript. 
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Addendum 

Created by Martin Dawe, Richard Cheng, David Dawe, Chunhua Hu and Jeremy Lloyd. 

 

Copyright 

RipX © Hit’n’Mix Ltd 2009-2021 

MPEG Layer-3 audio coding technology licensed from Fraunhofer IIS and Thomson. 

LAME (mp3dev.org) and mpg123 (mpg123.de) licensed under the LGPL. 

GPAC (github.com/gpac), FFmpeg (ffmpeg.org) and libsndfile licensed under the LGPL. 

GCC runtime library licensed under the GCC Runtime Library Exception. 

Python Copyright © 2001-2018 Python Software Foundation; All Rights Reserved. 

Tcl/Tk © Regents of the University of California, Sun Microsystems, Inc., Scriptics Corp et al. 

jedi, parso and typeshed ©2013-2019 David Halter and others, licensed under MIT/Apache. 

Scintilla Copyright © 1998-2003 by Neil Hodgson neilh@scintilla.org. 

FLAC Copyright © 2000-2009 Josh Coalson, Copyright ©2011-2016 Xiph.Org Foundation. 

PIL © 1997-2011 Secret Labs AB, 1995-2011 by Fredrik Lundh, Pillow ©2010-2019 by Alex Clark et al. 

PyTorch © Facebook, Inc, Idiap Research Institute, Deepmind Technologies, NEC Laboratories America, NYU. 

vocal-remover ©2019 tsurumeso and Ultimate Vocal Remover GUI ©2020 Anjok07, licensed under MIT. 

Demucs © Facebook, Inc. and its affiliates, licensed under MIT. 

r8brain-free-src © 2013-2021 Aleksey Vaneev, licensed under MIT. 

 

Terms of Use 

RipX is not intended for use by users which would infringe the copyright of any piece of music owned by a third party and 
is intended for lawful use only; Hit’n’Mix Ltd in no way authorizes any user of RipX to carry out an act in contravention of 
the provisions of the Copyright Designs and Patents Act 1988; and Any use of RipX in conjunction with such music should 
only be carried out with the permission of the copyright owner in question. 

See also https://hitnmix.com/terms-of-use/ 

 

Trademarks 

RipX, DeepRemix, DeepAudio, DeepPlayer, Future Audio Platform, Audioshop and Hit’n’Mix are trademarks or 
registered trademarks of Hit’n’Mix Ltd. See hitnmix.com for more information about Hit’n’Mix Ltd and its products. 

ARA Audio Random Access is a trademark of Celemony Software GmbH. 

VST and ASIO are trademarks and software of Steinberg Media Technologies GmbH. 

Pro Tools and AudioSuite are trademarks of Avid Technology, Inc. 

CUDA is a registered trademark of NVIDIA Corporation. 
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