English
Ask Your Question
0

Auto SpellCheck STILL not working (4.0)

asked 2013-06-24 04:48:57 +0200

Frustrated gravatar image

I don't think I've ever had this work out-of-the-box. I'm not sure why this is an on going problem with LibreOffice/OpenOffice.

Has anyone been able to get this to work?

Everything is selected in the options menu. However, it's still not working. I'm hoping the solution is a simple fix.

Thanks in advance.

edit retag flag offensive close delete

Comments

Well, you didn't write much information so we can help you... did you try to explore options in Tools -> Options -> Languages first? Then, are you sure you installed spell check dictionary? (http://askubuntu.com/questions/72099/how-to-install-a-libreoffice-dictionary-spelling-check-thesaurus) In order to enable Auto Spell Check, I need to click on toolbar icon "Automatically spell check as you type" in standard toolbar... I hope this will help you at least a little bit.

Ljiljan ( 2013-06-24 07:21:17 +0200 )edit

In addition to the queries by @Ljiljan, please provide your operating system, whether you are using PPA or website version of LO, your locale / UI, and which language packs you have installed.

oweng ( 2013-06-25 03:32:26 +0200 )edit

5 answers

Sort by » oldest newest most voted
1

answered 2013-12-09 15:02:20 +0200

input gravatar image

updated 2013-12-09 15:03:11 +0200

sudo apt-get install myspell-en-us

For me on linux mint 15 this solved my issue, install and restart libreoffice.

Source: http://forums.linuxmint.com/viewtopic.php?f=47&t=110929

PS. For the English - myspell-en-gb

edit flag offensive delete publish link more
1

answered 2013-06-25 20:57:45 +0200

manj_k gravatar image

updated 2013-06-25 21:02:44 +0200

Please have a look at this check list (with regard to your required language).

edit flag offensive delete publish link more
1

answered 2013-10-23 12:19:23 +0200

Abu Raziel gravatar image

Options > Language Settings > Languages > under default languages for documents, set Western language as English (USA)

This works because Spell Check is defined only for a few Language Packages. You can see which have spell check support by looking for a blue tick on the right side of the language name.

edit flag offensive delete publish link more
0

answered 2013-06-25 06:22:09 +0200

ROSt52 gravatar image

Autospell checking has to do with language recognition. Please have look at fdo#66051 comment 2 and other links there. This could provide solutions / work arounds and reported bugs where you can add information.

This is for Windows.

edit flag offensive delete publish link more
0

answered 2013-07-17 10:56:24 +0200

This shows up in other threads however it is relevant to version 4.0.4.2, and may work for earlier versions. It assumes you are running Windows 7 64 or 32 bit.

Make sure Libre Office is closed. In Windows Explorer go to your user account in the left pane. If there isn't one then the following may show up in the Administrators account. To find the profile navigate to AppData > Roaming > Libre Office. There should be a list of sub folders starting with 4. Delete all sub folders below Libre Office. Close Windows Explorer. Open Libre office and it re-creates the profile just deleted. The spellchecker should now work assuming the settings in Options are set correctly for the required language.

Seems to be a bug in the install routine in that the chosen language of the download file isn't picked up, or if it is then it is ignored.

edit flag offensive delete publish link more

Comments

Just to confirm: the suggestion above (deleting the profile for 4) worked (with a restart of LO) for latest version.

This bug dating back several years for all sorts of versions, for me back to v3 I have never really got spellcheck stable. I've tried to find bugs reported, like https://bugs.freedesktop.org/show_bug.cgi?id=57789 and https://bugs.freedesktop.org/show_bug.cgi?id=39203

These date back to 2011. I'll not make a new one. I wonder why this is still featuring in new installs of LO?

Derek ( 2014-01-18 00:42:56 +0200 )edit

Above suggestion by @Griffon is commonly referred to as resetting the user profile. Sometimes this can fix an issue, but the general problem of spell-check not working as expected is generally unrelated.

oweng ( 2014-01-24 07:57:13 +0200 )edit

I had this same issue with a clean installation of LibreOffice Version: 4.1.4.2 for Microsoft Windows 7. Upon following this solution, I now have spellcheck functionality within LibreOffice once again.

My question is, why has this very old bug not been resolved yet? As well, since the LibreOffice installation routine is capable of creating this folder chain in the first place then why hasn't someone simply wrote into the installation code a line that deletes said folder chain. This can either at the end of installation or through the creation of a 'run once' batch file to delete the folder chain upon first initialization of LibreOffice. This would be quite beneficial to both the people using ...(more)

RegLinUsr ( 2014-01-24 08:27:41 +0200 )edit

I can't answer the question of why this particular bug (old as it is) has not yet been fixed, however I can say that the developers are working hard to improve LO. The upcoming v4.2.0 contains more bug fixes and improvements than any prior release and will also mark a significant improvement in general code quality. In some ways LO is just starting to get under way as the transition from OOo to LO has been lengthy. Hopefully this issue will be addressed soon.

oweng ( 2014-01-24 08:35:18 +0200 )edit
Login/Signup to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2013-06-24 04:48:57 +0200

Seen: 10,870 times

Last updated: Jan 23