Which options are required to obtain spell checking in multiple languages?


working from windows 7
i work on documents in both English and French and whenever I change the language then I have no longer spell checker.

I would think it comes from the option between selection/text/paragraph where when you select a different one than the selection it messes the whole process of spell checking.

thanks in advance for ur help

@dtlopez – that works fine for me.

What version of LibreOffice? What file format?

Does AutoSpellcheck work fine with monolingual documents (English/French)?

How do you “change the language” (step-by-step)?

10 “karma points” for you to upload a sample document, and to add comments to an answer.

hello manj and sorry for long time its just that i did not set up any notification email…version is even when i start a new document i have this pb. I just tested here: i wrote what is youur name and no correction - for the selection, there is a tick in front of english (uk) and for the two other options (paragraph and full text) nothing is ticked

A new check list :wink:

Are the English and French dictionaries shown in “Tools → Extension Manager” (without any error message)?

(1) Is “English (UK)” shown in in the language field of the “Status Bar” when you open a new empty Writer document?

(2) Menu "Tools → Options → Language Settings → Writing Aids → Available language modules”:

Is “:ballot_box_with_check: Hunspell SpellChecker” enabled?

(3) Menu "Tools → Options → Language Settings → Writing Aids → Available language modules → Edit…

→ Language English (UK) / → Language French (France):

Are the English and French dictionaries shown with an “ABC check-mark”?

(4) Is “Spelling :ballot_box_with_check: Hunspell SpellChecker” enabled for English (UK) / French (France)?

(5) Menu “Tools → Options → Language Settings → Writing Aids → Options”:

Is “:ballot_box_with_check: Check spelling as you type” enabled?

Please, could you upload a sample document (English/French) with the spellcheck issue?

Does this works for Italian language?

sorry but I can not upload “english (uk)” in menu - tools - options - language settings - writing aids - Hunspell SpellChecker - edit - language english (UK). It is shown as “indian” like this -
image description
But when I make changes in the option (that is in options - language - selecting UK english (which shows abc in front of it) though this appears -
image description

After doing this I click on close, nothing changes… the old problem persist and that problem is I can not have dictionary set to UK english. What to do?