Writer: nach Bearbeitung einer Formel wird nur Object n angezeigt

gefragt 2017-09-05 20:19:37 +0200

ufo Gravatar-Bild

updated 2017-09-07 11:36:50 +0200

Writer stellt keine Formeln dar. Bearbeiten geht, im Formeleditor sieht es auch ok aus, aber sobald ich den Formeleditor verlasse, wird nur ein Fenster mit der Ausschrift "Objekt n" (n ist eine laufende Nummer) angezeigt. Dies ist auch genauso in der Seitenvoransicht ("Page Preview").[Anmerkg ufo, 2017-09-07 09:34UTC: mittlerweile erscheint der Objektname nicht mehr in der Preview, s. updates unten, ich bin mir aber sicher, daß das ursprünglich so war.] Andere odt-kompatible Editoren können die Dokumente lesen und die Formeln darstellen. Öffne ich ein dort abgespeichertes Dokument mit Formel in LO, wird die Formel zunächst auch ordentlich im Text gezeigt, sobald ich sie aber einmal zum Bearbeiten geöffnet habe, ist das Problem wieder da.

Update 2017-09-07 08:36UTC: ich habe jetzt ein neues Dokument angelegt und darin eine einfache Formel erstellt, dann auch diejenige aus dem Problemdokument eingefügt, alles ohne das besagte Problem. Danach habe ich auch noch Graphiken (2 Pixelbilder, *.png) und eine Tabelle aus dem Problemdokument in das neue Testdokument kopiert, auch danach blieb das Problem aus. Daraufhin habe ich noch ein weiteres neues Textdokument angelegt und den gesamten Inhalt des Problemdokumentes per C'n'P dorthineinkopiert. Ich werde mal versuchen, tabellarisch darzustellen, was passiert (U: urspr. Dokument, N1: erstes neues Dokument, N2: zweites neues Dok., -E:Editor, -P: Page Preview. "ok"-> Darstellung in Ordnung, - : keinerlei Darstellung, <obj..>-> Objektname in Rahmen). Die alte Formel wurde per C'n'P aus U nach N1 und N2 kopiert, die neue Formel aus N1 nach U und N2.

                  U -E     U-P        N1-E     N1-P         N2-E      N2-P
alte Formel    <object1>   -          ok       -             ok       -
neue Formel    <object2>   -          ok       ok            ok       -

Update 2017-09-07 09:26UTC: Wenn ich den Inhalt von U in ein neues Dokument kopiere und danach Formeln darin erzeuge, werden diese im Editor angezeigt, erscheinen aber nicht in PagePreview oder in exportiertem PDF. Lege ich dagegen vor dem Einkopieren des U-Inhaltes im neuen Dokument eine Formel an, so wird diese normal angezeigt, auch im PagePreview oder PDF-Export, und ich kann nach dem Einkopieren des Inhaltes von U auch weitere Formeln im neuen Dokument anlegen, die sich normal verhalten.

ufo

edit retag flag offensive close merge delete

Comments

Bitte LibreOffice Version und Betriebssystem mit angeben. Evt. auch noch andere Parameter (Grafikkarte, Einstellungen unter Extras - Optionen -> LibreOffice : Ansicht und Speicher).

Toxitom Gravatar-BildToxitom ( 2017-09-06 07:08:34 +0200 )edit

LO Version: 4.3.7.2 Build ID: 4.3.7.2-2.el6_9.1 OS: RHEL 6.9 HW: Lenovo Thinkpad T420 VGA scheint von der CPU zu kommen, siehe lspci: 00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

LO Memory: Graphics Cache Use for LO: 20MB, Memory per object: 5.2MB, Remove from memory after 00:10 ; Cache for inserted objects -- numbre of objects: 20

ufo Gravatar-Bildufo ( 2017-09-06 21:31:52 +0200 )edit

Ich tippe auf Menu Ansicht > Bilder und Diagramme.

Regina Gravatar-BildRegina ( 2017-09-07 02:37:11 +0200 )edit

Hallo, Regina, in der engl. Oberfläche, die ich nutze, gibt es wohl [View], darunter aber keinen Listeneintrag [Pictures and Diagrams]. In [Tools]-[options]-[LOWriter]-[View] ist u.a. der Eintrag "Graphics and Objects" aktiviert. Und: speichere ich die Datei unter einem anderen odt-fähigen Programm ab und öffne sie in LO, wird die Formel bis zum Aufruf des Formeleditors im Editor angezeigt, in der page preview bleibt der Formelplatz mittlerweile aber ganz leer.

ufo Gravatar-Bildufo ( 2017-09-07 10:20:05 +0200 )edit

Hallo ufo, bei den aktuellen 5.x Versionen ist der Eintrag im Menü View. Die Version 4.3.7 ist ziemlich alt. Du solltest auf 5.2.7 umsteigen, evtl zunächst die "portable" Version benutzen bis alle Dokumente umgestellt sind. Beim Öffnen des Dokuments sieht man die Vorschaugrafiken der Formeln. Deshalb wird bei Fremddokumenten das Problem erst sichtbar, wenn durch das Aktivieren der Formel die alte Vorschaugrafik gelöscht wird.

Regina Gravatar-BildRegina ( 2017-09-07 11:26:21 +0200 )edit

Hallo, Regina, auch mit "Nichtfremddokumenten" ist das Verhalten inkonsistent (siehe meine Updates der Problembeschreibung oben). Ich akzeptiere aber, daß die Version alt ist (und evtl. Bugs in neueren weg sind), werde also ein neues LO bei Gelegenheit probieren.

ufo Gravatar-Bildufo ( 2017-09-07 12:58:41 +0200 )edit