Frage stellen
0

Calc - migration einer komplexen Tabelle von OOo nach LO

gefragt 2017-09-21 07:46:57 +0100

crossgolf_rebel Gravatar-Bild

Ich habe vor LibreOffice Zeiten schon eine komplexe Tabellenauswertung erstellt. Aufgabe ist es eine Liga Auswertung zu führen, wo ich nur die Punkte eintrage und automatisch eine aktuelle Rangliste am Ende bekomme.

Nachdem LibreOffice auf den Markt kam, bin ich zu dem umgeschwenkt und eine Zeit lang lief alles super. Irgendwann wurde bei den Formelbefehlen etwas geändert, so das ich wieder OpenOffice installieren musste, um meine Auswertung nutzen zu können.

Meine Frage an euch, kennt sich jemand mit den Calc Formeln gut genug aus und kann mir helfen die für LibreOffice kompatibel zu gestalten?

Das Teil könnt ihr euch hier runter laden und ansehen - http://www.mcl-crossgolf.de/temp_date...

Ich würde mich freuen, wenn ihr helfen könnt.

edit retag flag offensive close merge delete

Comments

Eintragen von Namen, Adresse usw. funktioniert bei mir problemlos (LO 5.4.1.2, OpenSUSE 42.2)

RobertG Gravatar-BildRobertG ( 2017-09-21 15:52:04 +0100 )edit
0

geantwortet 2017-09-21 08:40:45 +0100

Toxitom Gravatar-Bild

updated 2017-09-22 09:39:29 +0100

Hmm, was genau funktioniert denn nicht? Schau ich mir Deine Tabelle an, sieht doch alles gut aus. Die "Div/0" ist natürlich ein Fehler deinerseits, diesen Fall müsstest Du mit einer Wenn-Bedungen abfangen - oder so. Ansonsten: Es ist ungünstig, eine Makro-Warnung zu erhalten (obwphl gar keins bzw. lediglich ein leeres Modul drin ist) - schafft nicht gerade Vertrauen. Außerdem sind die Tabellen geschützt mit einem PW, also kann auch niemand etwas an den Formeln testen.

Kann ich Dir auch nicht weiterhelfen;)

VG Tom

Edit: Leere Zellen ("") werden nicht als "0" gewertet! Ändere Deine Formel in den Spalten "Punkte" (Tabelle Spiele Werten) wie folgt um (bsp. H7: =WVERWEIS(WENN(G7="";14;G7);Plazierung.$B$1:$O$2;2)+ZEILE()/100000) - dann passt es wieder. PS: Wozu addierst Du eigentlich diesen "Miniwert" +ZEILE()/100000 noch hinzu? Zu Sortierzwecken?

edit flag offensive delete link mehr

Comments

Jetzt sehe ich erst deine Antwort. Danke erst mal und Entschuldigung, das ich so lange nicht geantwortet habe.

Der Miniwert ist wirklich zur Sortierung. Spieler die die gleiche Punktzahl über mehrere Spiele haben aber einer nur 3 und ein anderer 4 Spiele dafür benötigen, da sollte der persönliche Einsatz mehr Turniere gespielt zu haben auch in die Wertung einfließen. Das aber mit einem sehr geringen Wert.

Ich werde die Formel mal umstellen und mich dann noch mal melden

crossgolf_rebel Gravatar-Bildcrossgolf_rebel ( 2017-10-19 06:58:19 +0100 )edit

So, ich habe deinen Vorschlag mal eingebaut und es scheint jetzt zu gehen. Wobei mir LibreOffice noch einen Fehler beim in die Zelle Kopieren genannt hat und das selbstständig repariert hat.

deine Idee =WVERWEIS(WENN(G7="";14;G7);Plazierung.$B$1:$O$2;2)+ZEILE()/100000) die Änderung von LibreOffice =WVERWEIS(WENN(G7="";14;G7);Plazierung.$B$1:$O$2;2)+ZEILE()/100000 Da war die letzte Klammer zu viel.

Kannst du mir bitte noch erklären, warum es jetzt eine Funktion in der Formel mehr braucht?

crossgolf_rebel Gravatar-Bildcrossgolf_rebel ( 2017-10-20 14:28:11 +0100 )edit

Die alte Formel sah ja so aus =WVERWEIS(G8;Plazierung.$B$1:$O$2;2)+ZEILE()/100000

Es funktioniert ja jetzt anscheinend aber es lässt mich auch ein wenig Ratlos zurück, warum ich jetzt noch eine WENN abfrage brauche?

crossgolf_rebel Gravatar-Bildcrossgolf_rebel ( 2017-10-20 14:32:54 +0100 )edit
0

geantwortet 2017-09-21 10:31:16 +0100

crossgolf_rebel Gravatar-Bild

Hallo, also ich bekomme eine #NV sobald ich anfange Daten einzutragen. Die Tabelle habe ich vor Jahren mit OOo zusammen mit ein paar anderen entworfen. und das "Div/0" funktioniert ja in OOo ohne Probleme und die Funktion hat auch ihren Sinn (auch wenn ich es jetzt nicht genau erklären kann)

Das Passwort für die Tabelle steht auf Seite 1 in der Beschreibung und ist nur gedacht, wenn ich die intern an die anderen Veranstalter zum eintragen ihrer Ergebnisse weiter reiche. Ich möchte nicht, das auf diesem Weg was an den Formeln passiert.

Du kannst mit "Tabelle" den Schutz aufheben ;)

edit flag offensive delete link mehr

Comments

Siehe Kommentar von mir - geändert.

Toxitom Gravatar-BildToxitom ( 2017-09-22 09:34:39 +0100 )edit
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

1 follower

Stats

Asked: 2017-09-21 07:46:57 +0100

Seen: 29 times

Last updated: Sep 22