Frage stellen
0

Mendeley plugin funktioniert nicht mit Libreoffice (Juni 2018)

gefragt 2018-06-06 23:45:48 +0200

kurtbockhorst Gravatar-Bild

Wenn ich den Menedely Plugin mit MS Word benutze zum Einfuegen von Literaturreferenzen in ein Manuscript funktioniert alles wunderbar. Inklusive Erstellung der Literaturliste am Ende des Manuscripts.

Wenn ich es mit Libreoffice benutze gibt es eine 'exception error message' type com.sun.star.lang.IllegalArgumentExceptionMessage: At line 1042. Nix geht mehr.

Ich habe es zuerst in der Kombination Libreoffice/Mendeley probiert, dann das gleiche Dokument in MSWord gesichert und in der Kombination Word/Mendeley bearbeitet. Letzteres ohne Probleme, ersteres geht absolut nicht.

Vor ca 1-2 Monaten hatte ich auch in der Kombination Libreoffice/Mendeley keine Probleme. Damals hatte ich Libreoffice 5.4 benutzt. Jetzt hatte ich zuerst ebenfalls ein neueres 5.4 benutzt, dann, weil nix klappte, 6.0 versucht. Ohne Erfolg, beides.

Bearbeiten Tags ändern Melden schließen vereinen löschen

1 Antwort

0

geantwortet 2018-06-08 15:08:40 +0200

Toxitom Gravatar-Bild

Diese Frage kann Dir leider nur der Hersteller/Programmierer von Mendeley beantworten. Er nutzt in seinem Code die Funktionen zur API Steuerung von LibreOffice. Die Fehlermeldung weist auf ein Problem seines Programms in Zeile 1042 hin, er übergibt offensichtliche einer API Funktion einen inkorrekten Parameter.

Wie gesagt: Die Fehlermeldung muss an den Plug-In Ersteller gerichtet werden.

Ein Vergleich mit MS Office ist weder hilfreich noch sinnvoll - beide Programme haben unterschiedliche APIs und der Plugin-Hersteller wird unterschiedliche Programmcodes für beide Systeme geschrieben haben.

VG Tom

Bearbeiten Melden löschen Link mehr
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

1 Beobachter

Statistik

Gefragt: 2018-06-06 23:45:48 +0200

Angesehen: 15 Mal

Aktualisiert: Jun 08