Frage stellen
0

WENN FINDEN ODER

gefragt 2019-02-15 13:35:28 +0100

Valerius Gravatar-Bild

updated 2019-02-15 14:17:26 +0100

Hallo liebe Community,

ich habe folgendes Problem bei dem mir leider bisher niemand helfen konnte und hoffe auf eure Hilfe.

Ich habe eine Excel-Tabelle die ich für Versandaufkleber verwende. Ich versende normalerweise mit Arriva (private Post). Nun ist es so, dass Arriva nicht landesweit zustellt. Sendungen die nicht mit Arriva verschickt werden können, werden deshalb von Arriva gegen eine Zusatzgebühr an die Deutsche Post übergeben. Ich möchte diese Sendungen deshalb selbst frankieren. Ich habe eine Excelliste von Arriva mit allen Postleitzahlen bzw. Arriva-Zustellgebieten und möchte diese mit meiner Excel Versandaufkleber-Datei verknüpfen.

Hier ein Beispiel: Beispiel.png

In der B Spalte sollte dabei (falls Arriva in dem Gebiet zustellt) der Text "Arriva" erscheinen, ansonsten bleibt das Feld leer. Mit dieser Formel funktioniert es soweit ganz gut: =WENN(ISTFEHLER(FINDEN("99999";A3));"";"Arriva")

Jedoch ist diese Formel nur auf eine PLZ beschränkt. Ich habe allerdings eine Liste mit ca 10.000 Postleitzahlen mit denen die Postleitzahl in der Versandaufkleber-Datei abgeglichen werden muss.

Hat jemand von euch hierzu eine Lösung?

Viele Grüße

Valerius

Bearbeiten Tags ändern Melden schließen vereinen löschen

2 Antworten

0

geantwortet 2019-02-15 18:05:32 +0100

Opaque Gravatar-Bild

updated 2019-02-16 12:36:12 +0100

Hallo,

nun ja - FIND ist irgendwie nicht die richtige Funktion dafür, weil die nur in einem Text und nicht in einem Bereich sucht. Ich würde hier VLOOKUP verwenden. Mal wie in dem Beispiel.png angenommen, dass die linken 5 Ziffern in Feld A3 die PLZ enthalten und der Tabelle PLZ alle "erlaubten" Postleitzahlen stehen, dann würde das in etwa so lauten:

=IF( ISERROR(VLOOKUP(LEFT(A3;5);$PLZ.A1:A99999;1;0)); "Deutsche Post"; "Arriva")

Das sind natürlich die Formeln, wie sie in LibreOffice verwendet würden. Wie die zu VLOOKUP entsprechende Excel Funktion auf Deutsch heißt, kann ich mangels einer aktuellen Excel Version nicht sagen (Den Bereich bis A99999 habe ich so gewählt, weil es ja nur 5 stellige PLZ gibt und daher nicht mehr Zeilen existieren können)

Bearbeiten Melden löschen Link mehr
0

geantwortet 2019-02-19 13:15:19 +0100

Valerius Gravatar-Bild

Hallo! Super, es funktioniert! Vielen, vielen Dank!

Bearbeiten Melden löschen Link mehr

Kommentare

Wenn die Antwort korrekt war und für Dich beantwortet, dann wäre es nett hier auch auf das Häkchen zu klicken, so dass das für andere Nutzer auch als benatwortete Frage sichtbar wird.

Opaque Gravatar-BildOpaque ( 2019-02-19 13:21:58 +0100 )Bearbeiten

Wo finde ich das Häckchen?

Valerius Gravatar-BildValerius ( 2019-02-19 14:36:44 +0100 )Bearbeiten

;-) Neben meiner ersten Antwort. Der noch graue Haken, der grün wird, wenn man mit der Maus drüber fährt und einen entsprechen Erklärtext zeigt.

Opaque Gravatar-BildOpaque ( 2019-02-20 09:57:18 +0100 )Bearbeiten
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

2 Beobachter

Statistik

Gefragt: 2019-02-15 13:35:28 +0100

Angesehen: 34 Mal

Aktualisiert: Feb 19