Frage stellen
1

Zählenwenn [Geschlossen]

gefragt 2019-04-10 16:09:32 +0100

Derd Gravatar-Bild

Ich muss in einer Spalte alle Nachnamen zählen die mit D beginnen, =ZÄHLENWENN(A05:A15;"D*"), funktioniert leider nicht und zeigt mir immer null an. Komischerweise funktioniert die Formel im Excel. Gibt es da was eigenes für LibreCalc?

Lg

Bearbeiten Tags ändern Melden wieder öffnen vereinen löschen

Geschlossen aus folgendem Grund Die Frage wurde beantwortet, die korrekte Antwort als „Akzeptiert“ markiert von erAck
Abschlussdatum 2019-04-30 14:21:19.896833

Kommentare

Für Rückinformationen editiere bitte deine Frage oder schreibe einen Kommentar.

ebot Gravatar-Bildebot ( 2019-04-10 16:35:48 +0100 )Bearbeiten

Kann es sein, dass Deine Namen vorne dran noch ein Leerzeichen oder ein sonstiges unsichtbares Zeichen haben, dann findet nämlich "D*" nichts?

Opaque Gravatar-BildOpaque ( 2019-04-10 17:06:35 +0100 )Bearbeiten

ich habe eigentlich alle formatierungen extra rausgehauen, aber das änderte nichts, also damit hat es glaub ich nicht zu tun

Derd Gravatar-BildDerd ( 2019-04-10 17:21:28 +0100 )Bearbeiten

3 Antworten

0

geantwortet 2019-04-10 16:32:23 +0100

ebot Gravatar-Bild

updated 2019-04-10 16:32:55 +0100

@Derd , ich habe mit folgender Funktionsangabe Erfolg:

Bildbeschreibung

Was mir auffällt, ist deine Angabe "A05". Wenn ich diese in einfacher Form verwende, wird es von Calc in "A5" gewandelt. Ansonsten kann ich auch keinen Unterschied sehen. Vielleicht hilft dir das kleine Bildchen von mir.

Bearbeiten Melden löschen Link mehr

Kommentare

Bei mir Windows 10, Version 1809, 64-Bit | LibreOffice, Version: 6.2.2.2 (x64).

Wenn meine Antwort dein Problem gelöst hat, klicke bitte auf das große Häkchen im Kreis links von dieser Antwort. Es zeigt dann den anderen Teilnehmern an, dass die Frage richtig beantwortet wurde.

ebot Gravatar-Bildebot ( 2019-04-10 16:34:00 +0100 )Bearbeiten
0

geantwortet 2019-04-10 17:15:27 +0100

Derd Gravatar-Bild

Es funktionierte mit einem Punkt also =ZÄHLENWENN(A05:A15;"D.*")

lg derd

Bearbeiten Melden löschen Link mehr

Kommentare

Wenn ich zwischen 'D' und 'stern' einen Punkt setzte, also 'D.stern', ist das Ergebnis "0". Also insofern muss in deinen Zellen A5:A15 etwas anders sein. Überprüfe doch bitte deine Zellen, auch darauf welche Formatierung vorhanden ist. Hast du Deine Zellen evtl. von Excel übernommen?

ebot Gravatar-Bildebot ( 2019-04-10 17:23:12 +0100 )Bearbeiten

Nur zu Erklärung, was da jetzt vorging. Deine Lösung funktioniert weil Du offensichtlich unter Extras -> Optionen -> LibreOffice Calc -> Berechnen die Option Reguläre Ausdrücke in Formeln ermöglichen aktiviert hattest während bei @ebot das nicht der Fall zu sein scheint und daher seine Lösung funktioniert. Bei ihm wird Deine Lösung nicht klappen.

Opaque Gravatar-BildOpaque ( 2019-04-10 17:26:13 +0100 )Bearbeiten

Das kann ich insofern bestätigen, dass wenn ich dort aktiviere, bei mir auch "0" angezeigt wird.

ebot Gravatar-Bildebot ( 2019-04-10 18:04:56 +0100 )Bearbeiten
0

geantwortet 2019-04-16 16:03:14 +0100

erAck Gravatar-Bild

Um die MS-Excel kompatiblen simplen Wildcards (*?~) verwenden zu können müssen diese unter Extras -> Optionen -> LibreOffice Calc -> Berechnen eingeschaltet sein.

Es gibt dort drei Optionen, Reguläre Ausdrücke, Wildcards (weiss jetzt nicht wie das übersetzt heisst), oder Keine.

Bearbeiten Melden löschen Link mehr

Antwortwerkzeuge

1 Beobachter

Statistik

Gefragt: 2019-04-10 16:09:32 +0100

Angesehen: 96 Mal

Aktualisiert: Apr 16