LibreOffice 6 auf Win10 öffnet keine Dokumente mehr

gefragt 2019-06-04 11:54:22 +0100

radioxA Gravatar-Bild

Auf einem frisch installierten Windows 10 PC (1809) und einer ebenfalls neu installierten LO 6 Version (aktuell 6.2.1.2, verschiedene getestet, mit demselben Ergebnis, u.a. 6.0.7 o. 6.1) kann man nach kurzer Zeit keine Dokumente mehr öffnen. Im Taskmanager befindet sich ein Prozess (soffice.bin), den man schließen muss. Danach kann wieder EIN Dokument geöffnet werden. Die Prozedur muss dann jeweils wiederholt werden, nach dem Schließen des geöffneten Dokuments weitere zu öffnen. Das kuriose ist nun. Lässt man das letzte Dokument geöffnet, können weitere geöffnet werden.

Wir stellen seit einiger Zeit in unserem betrieblichen Umfeld auf Windows 10 um. Anfangs kam es nur auf ein bis zwei Rechnern zu diesem Fehler, mittlerweile sind immer mehr betroffen. Leider findet sich zu diesem Problem nichts im Internet oder in den Foren. Es scheint ähnlich dem alten Problem in LO 5 zu sein, bei dem ein Prozess die anderen blockierte und man teilweise 10+ Prozesse schließen musste. Allerdings, wenn, trat das Problem eher sporadisch auf und es sollte doch in der Version 6 behoben worden sein.

Wir nutzen für unsere Nutzer Ordnerumleitungen, da einige wechselnde Arbeitsplätze haben. LibreOffice 6 ist bei uns ohne Erweiterungen installiert. Die Profile wurden neu angelegt und können jederzeit gelöscht werden. Das hilft für kurze Zeit (ein oder zwei Dokumente öffnen), dann tritt das Problem wieder auf.

Hat einer Idee oder tritt dieses Problem auch bei anderen noch auf? Sollte das als Bug gemeldet werden?

Bearbeiten Tags ändern Melden schließen vereinen löschen

Kommentare

Was bedeutet hier "Ordnerumleitungen" genau. Befinden sich Dateien und/oder User Profile auf Netzwerklaufwerken?

Opaque Gravatar-BildOpaque ( 2019-06-04 13:13:10 +0100 )Bearbeiten

Wurde auch mal probiert, das User Profile zu resetten? (https://wiki.documentfoundation.org/U... bzw. https://wiki.documentfoundation.org/U...)

Dennis R. Gravatar-BildDennis R. ( 2019-06-04 13:43:23 +0100 )Bearbeiten

Ja, genau. Als Alternative zu Roaming Profilen bietet Windows bzw. wird empfohlen Ordernerumleitungen einzurichten. Dabei sind wichtige Ordner u.a. AppData\Roaming, Dokumente usw. auf einem Netzlaufwerk. Also befindet sich auch das LO Profil dort. Die Probleme mit LO treten sowohl bei Personen auf die an unterschiedlichen PCs arbeiten, wie auch bei Mitarbeitern, die immer am selben PC sitzen. Die Ordnerumleitung ist aber für alle gleichermaßen eingerichtet.

radioxA Gravatar-BildradioxA ( 2019-06-04 13:45:41 +0100 )Bearbeiten

Die Profile wurden auch schon zurückgesetzt. Was aber nicht geholfen hat (s.o.). Arbeiten im SafeMode haben wir noch nicht ausprobiert. Ich werde das gleich mal testen.

radioxA Gravatar-BildradioxA ( 2019-06-04 13:53:52 +0100 )Bearbeiten

Ok - wenn sich das alles auf Netzwerklaufwerken abspielt, befürchte ich, seid Ihr auch Opfer der hier immer wieder berichteten Probleme von LibreOffice mit SAMBA Shares und/oder Windows Shares. Ein Teil der Probleme und gemeldeten Bugs hängt wohl mit der Erstellung der Lockfiles zusammen. Das Problem, was ich damit habe: In meiner Umgebung ist das noch nie aufgetreten und mir fällt es schwer deshalb weitergehende Ratschläge zu geben. Ob einer der existierenden Bug Reports auf Deinen Fall passt, müsstest Du dann unter https://bugs.documentfoundation.org prüfen (wobei es mir als mit Software-Entwicklung wenig bis gar nicht befasstem User schon schwer fällt, die entsprechenden Bugs zu finden). Wenn Du nichts findest, was auf Deinen Fall passt, kannst Du selber einen Bugbericht erstellen.

PS: Version 6.2.1(.2) finde ich persönlich als noch "zu buggy" - In Eurem Fall würde ich mich auf still=6.1.6 oder fresh=6.2.4 fixieren.

Opaque Gravatar-BildOpaque ( 2019-06-04 14:19:10 +0100 )Bearbeiten

Ich habe nun den SafeMode getestet. Beim ersten Versuch ließ sich LO nicht im SafeMode starten. Nach dem der Splash Screen zu sehen war, passierte lange Zeit nichts und auch der Prozess im Taskmanager verschwand. Danach ließen sich auch im normalen Mode keine Dokumente mehr öffnen. Der Prozess erschien kurz und verschwand dann wieder.

Nachdem das Profil zurückgesetzt wurde, ließen sich wieder Dokumente öffnen. Ein erneuter Versuch LO im SafeMode zu starten schlug wiederum fehl. Allerdings konnten nun Dokumente auch im normalen Modus noch immer geöffnet werden.

radioxA Gravatar-BildradioxA ( 2019-06-04 15:11:30 +0100 )Bearbeiten

@Opaque Danke für Deine Hinweise. Ich habe mir mal die Sache mit den Samba/Windows Shares angeschaut. Bin mir nicht so sicher, dass es damit zu tun hat. Zumal das Verhalten von LO anders ist als bei uns. Hier blockiert ja offensichtlich ein Prozess, der erst geschlossen werden muss bevor ein anderes Dokument geöffnet werden kann. Wenn ich allerdings danach suche komme ich immer wieder nur zu dem Bug, der in LO 5 existierte und mit LO 6 behoben sein sollte. Also nichts aktuelles.

Wir hatten auch schon verschiedene Versionen ausgetestet und, ich meine, auch die 6.1.6. Doch auch die hat nichts an unserem Problem geändert.

radioxA Gravatar-BildradioxA ( 2019-06-04 15:36:37 +0100 )Bearbeiten

Auf einem frisch installierten Windows 10 PC (1809)

Nur so am Rande, zwischenzeitlich ist WIN10 mit dem Release (1903) erhaeltlich. Wenn es nicht automatisch updatet kannst du es hier herunterladen.

ebot Gravatar-Bildebot ( 2019-06-04 16:23:00 +0100 )Bearbeiten

@ebot Sorry, aber bevor wir im Unternehmensumfeld gleich den neusten Release (1903) auf Rechnern installieren, lassen wir lieber dem ganzen in der "freien Wildnis" etwas Zeit sich zu entwickeln und Microsoft kann für die wichtigsten Dinger schonmal Patches liefern.

Ganz abgesehen davon, war zu dem Zeitpunkt als wir den PC "frisch installiert" hatten, Release 1903 noch nicht draußen.

radioxA Gravatar-BildradioxA ( 2019-06-05 11:57:43 +0100 )Bearbeiten

@radioxA das wuerde ich an deiner Stelle auch nicht anders machen. Trotzdem, viel Erfolg!

ebot Gravatar-Bildebot ( 2019-06-05 12:23:20 +0100 )Bearbeiten

Hier mal ein paar Gedanken, was man noch untersuchen könnte: Wo ist LibreOffice installiert, wie wurde es installiert? Auf jedem Einzelrechner? Windows 10 pro? Ist sichergestellt, dass auch tatsächlich jeder Benutzer sein eigenes LibreOffice-user-Verzeichnis hat? Gehört der Prozess, den ihr dann im Taskmanager löscht dem aktuellen Benutzer? Habt ihr bei irgendeiner der Installationen den Schnellstarter an, ggf. mit welchen Rechten? Bleibt der Rechner an, wenn der Benutzer wechselt? Wie werden die Dokumente geöffnet, Doppelklick auf Datei oder vom innerhalb von LibreOffice? Wo liegen die Dokumente, die geöffnet werden sollen? Bei Server-Mehrbenutzer-Umgebungen denke ich immer sofort an Rechte-Probleme.

Wenn es ein filelocking Problem ist, dann schalte das mal aus, siehe https://ask.libreoffice.org/en/questi....

Regina Gravatar-BildRegina ( 2019-06-13 00:45:18 +0100 )Bearbeiten

Wir haben nun alles mögliche probiert und scheinbar ist die Lösung des Problems das Deaktivieren der Offlinedateien im Sychronisierungscenter in den Systemeinstellungen. Bei den PCs, die das Problem hatten waren Oflinedateien aktiviert. Seit der Änderung sind die Libreoffice Probleme verschwunden.

radioxA Gravatar-BildradioxA ( 2019-07-04 16:05:57 +0100 )Bearbeiten