Frage stellen
0

Eigene Makros nicht ausführbar trotz niedriger Sicherheitseinstellungen, wieso?

gefragt 2019-08-07 07:46:16 +0200

Reth Gravatar-Bild

Hallo zusammen,

also LibreOffice treibt mich langsam in den Wahnsinn (v.a. finde ich in das Basic nicht wirklich rein). Hab ein paar eigene Makros geschrieben, die auch immer normal liefen. Nun hatte ich das Dokument geschlossen und dabei gespeichert. Als ich es wieder geöffnet hab konnte ich kein Makro mehr ausführen, auch mit Makro-Sicherheitseinstellungen auf "Nachfragen" bzw. sogar auf "Niedrig". Es erscheint immer wieder die Fehlermeldung: "Aus Sicherheitsgründen ist diese Makro nicht ausführbar! Für weitere ..."

Kann mir jemand bitte sagen, woran das liegt/liegen kann und wie ich meine Makros wieder zum Laufen bekomme?

Vielen Dank schon mal und

Viele Grüße

Bearbeiten Tags ändern Melden schließen vereinen löschen

Kommentare

Warum postest Du nicht die ganze Meldung, die erscheint? Kann es sein, dass Da eine Sicherheitseinstellung des Betriebssystems mit rein spielt? Ich habe noch nie eine auf ein bestimmtes Makro bezogene Fehlermeldung gesehen, und das scheint bei Dir nach dem Anfangstext ja der Fall zu sein. Vielleicht benutzt Du ja z.B. den Shell()-Befehl, der auf die Konsole Deines Systems zugreifen will.

RobertG Gravatar-BildRobertG ( 2019-08-07 09:17:32 +0200 )Bearbeiten

Nicht vergessen, die "niedrig" gesetzte Makro-Sicherheit wieder mindestens auf "mittel" anzuheben.
"Niedrig" ist einfach zu gefährlich.

Lupp Gravatar-BildLupp ( 2019-08-07 18:06:17 +0200 )Bearbeiten

1 Antwort

0

geantwortet 2019-08-07 12:34:18 +0200

Reth Gravatar-Bild

Nein, nichts davon. Sind normale Basic Makros, die ich in einem bestehenden Calc-Dok. angelegt hatte und die auch immer funktionierten, solange ich das Dokument nicht geschlossen hatte - hab nach längerer Suche im Web was dazu gefunden:

Da meine Makros in einer eigenen Bibliothek sind, musste ich erst eine Sub in der Main-Bibliothek anlegen, die meine Bibliothek lädt. Allerdings bin ich in LibreOffice und v.a. seinen Makros kompletter Neuling, daher wusste ich das nicht (ist das auch irgendwo in ner offiziellen Doku oder so beschrieben?).

Aber warum liefen dann die Makros, als ich sie im Dokument erstellt hatte noch ohne Laden der Bib.?

Ciao

Bearbeiten Melden löschen Link mehr

Kommentare

Wo genau hast Du die Makros denn abgespeichert? Nicht im Dokument? Auch nicht unter "Meine Makros" > "Standard"?

Makros werden aus anderen Bibliotheken dann geladen, wenn sie im Editor in dem Objektkatalog (linke Seite) ausgeklappt sind (einzelne SUB-Prozeduren erscheinen mit ihrer Überschrift).

RobertG Gravatar-BildRobertG ( 2019-08-07 14:58:19 +0200 )Bearbeiten
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

1 Beobachter

Statistik

Gefragt: 2019-08-07 07:46:16 +0200

Angesehen: 33 Mal

Aktualisiert: Aug 07