pdf export mit relativen links

gefragt 2019-11-02 17:07:06 +0100

zzz59 Gravatar-Bild

updated 2019-11-05 21:34:49 +0100

Hi, ich habe ca. 100 Seiten Dokument mit ca. 100 klickbaren links zu zitierten Quellen (hauptsächlich weitere pdf Dateien) im gleichen Ordner bzw. in einem Unterordner. Beim pdf export des odt-Dokuments werden alle relativen links zu absoluten links und das ganze läßt sich auf einem anderen Rechner mit anderer Ordnerstruktur nicht mehr verwenden.
Hat jemand eine Idee?

Danke Grantler für Deinen Bericht/Kommentar. Leider schaffe ich es nicht, das bei mir (mint 18.3 xfce / LO Version: 6.0.2.1) nachzuvollziehen. Der Vortrag https://conference.libreoffice.org/as... legt nahe, dass es ein prinzipielles Problem gibt oder zumindest gab. Ich habe noch nicht gefunden, ob es bereits geändert wurde. Ich kann zwar absolute smb:// links oder https:// links erzeugen aber bei relativen links scheitert schon die Umsetzung eines "/". Relative file:// links gehen bei mir gar nicht. Wenn ich als Dokument Pfad linklist/an-org.pdf eingebe, dann wird das automatisch zu URL verschoben/umgewandelt und beim Draufklicken bekomme ich schon im odt eine Fehlermeldung Die Adresse »file:///media/xxx/DATA/yyy/zzz/linklist%2Fan-org.pdf« konnte nicht geöffnet werden. Das "/" vom relativen link wird zu %2F ??????? Der relative Link wird schon im odt zum absoluten Link umgewandelt Wenn ich es ohne Unterordner "linklist/"einfüge, wird automatisch http:// daraus und er findet den Server nicht.

Bearbeiten Tags ändern Melden schließen vereinen löschen

Kommentare

Meine Feststellung hierzu ist, dass sich im PDF-Export relative Pfade einstellen lassen, verschiedene Anzeigeprogramme aber unterschiedlich reagieren:

  • Adobe Acrobat (9.5.5 für Linux): Keine Reaktion
  • Foxit 2.4.4 (für Linux): möchte www-Adressen abrufen
  • Xreader/Evince konnte die verlinkten Adressen aufrufen, auch nach Änderung des Ordnernamens

OS: LinuxMint 19.2-64 Mate

Grantler Gravatar-BildGrantler ( 2019-11-03 18:54:03 +0100 )Bearbeiten

.

LO Version: 6.0.2.1

Ich würde schon mal mit LO 6.2.8.2 arbeiten. Ich finde, die 6.0-er Version war schon recht stark mit Bugs durchsetzt. Anleitungen zur Installation findest du hier: http://de.openoffice.info/viewforum.p... bzw. hier: http://de.openoffice.info/viewtopic.p... . - Ciao

Grantler Gravatar-BildGrantler ( 2019-11-07 10:08:20 +0100 )Bearbeiten

Ich habe todesmutig gleich 6.3.3.2 genommen und habe jetzt ein neues Problem: alle Tabellen werden immer auf gleiche Spaltenbreite formatiert. Vergleiche auch: https://ask.libreoffice.org/de/questi... Auch wenn ich die Breite manuell festlege, sind beim nächsten Öffnen wieder alle gleich breit. Das ist besonders bitter, nachdem es jahrelang funktioniert hat.

zzz59 Gravatar-Bildzzz59 ( 2019-11-10 15:50:00 +0100 )Bearbeiten