Frage stellen
0

Tabellenformatierung wird nicht gespeichert

gefragt 2020-07-22 12:44:42 +0200

steinhmor Gravatar-Bild

updated 2020-07-22 12:48:52 +0200

Liebe Community, ich habe seit heute eine sehr seltsame und erschreckende Problematik in LibreOffice: Gestern Abend habe ich ein Dokument editiert, alles hat bestens funktioniert. Es war etwas träge, da das Dokument ~50MB hat aber sonst gab es keine Schwierigkeiten. Heute morgen öffne ich es wieder und alle Tabellen, welche ich mit der Auto-Format-Funktion und weiteren Anpassungen formatiert hatte, sind nicht mehr formatiert. Es fehlen nicht nur die Farben, sondern auch die Spaltenbreiten haben sich verändert. Ich habe die Datei in meiner Nextcloud synchronisiert und dort alte Versionen nochmals geöffnet - auch diese weisen den gleichen Fehler auf.

Ich arbeite unter Linux Mint 20 (LO 6.4.4.2), habe die Dateien aber auch soeben unter Windows mit LO 6.4.5 und 7.0.0.2 versucht zu öffnen, das Problem besteht überall.

Ich vermute, dass das Problem im Dokument besteht. Wenn ich ein neues Dokument erstelle und eine Tabelle mit der Autoformat-Funktion formatiere, speichere, schließe und wieder öffne tritt der Fehler nicht auf. Wenn ich das mit meinem Problem-Dokument mache ist die Formatierung direkt wieder weg. Bzw. Schriftart und z.B. der Schrifteffekt (Fett) bleiben bestehen, die Farben und die Spaltenbreiten verschwinden allerdings. Dagegen spricht allerdings, dass ich in den letzten Tagen immer wieder mit dem Problem-Dokument gearbeitet habe, die Tabellen fehlerfrei waren und nun auch in den alten Versionen (in denen die Tabellen definitiv noch korrekt angezeigt wurden) die Tabellen nicht mehr korrekt formatiert sind ...

Ich habe mithilfe von Timeshift mein LinuxMint-System um zwei Tage "zurückversetzt" - zu diesem Zeitpunkt trat der Fehler nicht auf. Es hat leider nichts an dem Problem geändert. Auch die Flatpak-Version von LO auf meinem Rechner und der ColaboraViewer auf meinem Handy haben das gleiche Problem mit dem Dokument.

Da das Dokument über 100 Tabellen enthält, für die ich alle wieder die Spaltenbreiten, etc. anpassen müsste, hoffe ich, dass es eine Möglichkeit gibt, den Fehler zu beheben. Hat jemand eine Idee?

Liebe Grüße Moritz

Bearbeiten Tags ändern Melden schließen vereinen löschen

Kommentare

... sondern auch die Spaltenbreiten haben sich verändert.

Das erinnert mich ein wenig an Bug #tdf127036. Daher die Fragen:

  1. Speicherst Du im .odt format und - wenn ja
  2. Hast Du die Option Datei -> Eigenschaften...-> Reiter: Schriftart -> [x] Nur in Dokumenten verwendete Schriftarten einbetten gesetzt ?

Wenn beides zutrifft, könnte der Bug Dein Problem verursachen und das Deaktivieren der Option könnte ein Workaround sein (Ich weiß, der Zusammenhang klingt absonderlich, ist aber ein bestätigter und nicht beseitigter Bug).

Opaque Gravatar-BildOpaque ( 2020-07-22 13:03:43 +0200 )Bearbeiten

Ja, tatsächlich war das das Problem (und offenbar auch der Grund für die so große Datei). Vielen Dank! Eine wiederherstellung der Formatierung kann ich damit aber nicht erreichen, oder? LG Moritz

steinhmor Gravatar-Bildsteinhmor ( 2020-07-22 13:14:39 +0200 )Bearbeiten

1 Antwort

1

geantwortet 2020-07-22 13:39:15 +0200

Opaque Gravatar-Bild

updated 2020-07-22 13:43:28 +0200

Antwort (für die Akten) nach Rückmeldung im letzten Kommentar:

Hallo,

das ist Bug #tdf127036. Workaround: Deativieren der Option Datei -> Eigenschaften...-> Reiter: Schriftart -> [x] Nur in Dokumenten verwendete Schriftarten einbetten.

PS: Eine Neuformatierung der Datei kann durch die Deaktivierung der Option nicht erreicht werden, da ja der Bug zu einer Rücksetzung der Dokumenteigenschaften führt und damit die ursprünglichen Eigenschaften nicht mehr im Dokument gespeichert sind, sondern falsche ( "falsch" im Sinne des Anwenders) Eigenschaften gespeichert sind.

Ich hoffe das hilft.

Bearbeiten Melden löschen Link mehr
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

1 Beobachter

Statistik

Gefragt: 2020-07-22 12:44:42 +0200

Angesehen: 38 Mal

Aktualisiert: Jul 22