Frage stellen
0

jede zweite zelle einer zeile summieren?

gefragt 2016-02-03 16:12:27 +0100

Dieser Post ist als Wiki-Post markiert

Das ist ein Wiki-Beitrag. Jeder mit Karma >75 darf diesen Beitrag verbessern.

Ist es möglich mit einer Formel jede zweite Zelle in einer Zeile (nicht Kolonne) zu summieren? z.b. A1+B1+C1...?

Besten Dank für Lösungen!

(Es war wohl A1+C1+E1... gemeint. Siehe auch Antwort unten! Bearbeitung durch Lupp)

Bearbeiten Tags ändern Melden schließen vereinen löschen

1 Antwort

0

geantwortet 2016-02-03 22:11:48 +0100

Lupp Gravatar-Bild

updated 2016-02-03 22:16:04 +0100

A1 + B1 + C1 ...

Da sehe ich drei (und dann mehr) aufeinanderfolgende Zellen. Ist etwa

A1 + C1 + E1 ...

gemeint?

Naja, außer durch Angabe jedes einzelnen Summanden geht das mit verschiedenen Tricks. Ein Beispiel:

=SUMMENPRODUKT(A1:F1;ISTUNGERADE(SPALTE(A1:F1))

oder, wenn, mit A1 beginnend, die variable Anzahl von Summanden, die in $A$2 angegeben ist, addiert werden soll:

=SUMMENPRODUKT(VERSCHIEBUNG($A$1;0;2*(SPALTE(VERSCHIEBUNG($A$1;0;0;1;$A$2))-1)))  bzw. 
{=SUMME(VERSCHIEBUNG($A$1;0;2*(SPALTE(VERSCHIEBUNG($A$1;0;0;1;$A$4))-1)))}  als Array-Formel.

Ganz nebenbei: Wenn ein solches Bedürfnis auftritt, ist meistens der Entwurf (die Struktur) des Rechenblattes unzweckmäßig.

Bearbeiten Melden löschen Link mehr

Kommentare

Besten Dank, Lupp, genauso wars gemeint! Klappt wunderbar!

mjerkel Gravatar-Bildmjerkel ( 2016-02-13 16:31:45 +0100 )Bearbeiten
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

1 Beobachter

Statistik

Gefragt: 2016-02-03 16:12:27 +0100

Angesehen: 820 Mal

Aktualisiert: Feb 03 '16