Frage stellen
0

Writer Feldbefehle: Ausgabe der Zeichenanzahl eines bestimmten Textes

gefragt 2017-01-05 12:53:39 +0200

Capricornum Gravatar-Bild

updated 2017-01-05 12:54:15 +0200

Hallo,

ich schreibe regelmäßig Einsendeaufgaben für mein Fernstudium. Da durch unterschiedliche Schriftarten nicht jedes Mal die Zeilenanzahl passt, habe ich mir angewöhnt nach Zeichen zu rechnen. Das wird auch akzeptiert.

Nun möchte ich mir die Zeichen eines bestimmten Textabschnitts ausgeben lassen, denn davor und danach steht noch Text, der nicht zählt. Ich finde aber weder in Google, noch in der Hilfe oder wo ich sonst noch gesucht habe eine Anleitung dazu, wie ich die Feldbefehle dafür einspannen kann. Mir durch die Statistik die Zeichenanzahl direkt ausgeben zu lassen bekomme ich hin. Aber wie ich es auf einen bestimmten Abschnitt beschränken kann, ist mir ein Rätsel. Habt ihr einen Tipp für mich?

Liebe Grüße, Sonja

Bearbeiten Tags ändern Melden schließen vereinen löschen

Kommentare

Liebe Sonja, die Struktur hier im ask.libreoffice ist extrem unübersichtlich und m.A. für ein solches Thema nicht mehr geeignet. Schlage vor: Eröffne doch bitte einen Threat (Thema) hier : http://de.openoffice.info/ im Unterforum Writer. Viele Antworter von hier sind auch dort aktiv..und es ist übersichtlicher:) VG Tom

Toxitom Gravatar-BildToxitom ( 2017-01-12 15:56:41 +0200 )Bearbeiten

1 Antwort

0

geantwortet 2017-01-05 19:17:52 +0200

Toxitom Gravatar-Bild

Hallo Sonja,

so leider gar nicht. Die Dokumentenvariablen sind eben nur "Dokumentenweit" einsetzbar - nicht Abschnittweise.

Lösbar wäre es evt. mit einem Makro, aber auch hier hast Du natürlich die Problematik, den zu zählenden Bereich eindeutig zu kennzeichnen. Das könnte über Bereiche gehen, die Du entsprechend benennst - aber auch dann ist das so einfach nicht;)

Andere Alternative: Bau Dir doch Dein Dokument aus einzelnen Dokumenten auf - dann kannst Du die Statistik für jedes einzelne Dokument verwenden und zum Beispiel ein Globaldokument verwenden, um das Gesamtwerk zu begutachten :)

Viele Grüße Tom

Bearbeiten Melden löschen Link mehr

Kommentare

Hallo Tom,

vielen Dank für deine schnelle und produktive Antwort. :)

Dein Vorschlag klingt sehr interessant. Vielleicht liegt darin meine Lösung. Ich lerne immer gern etwas Neues. Hast du einen Link, den du mir empfehlen kannst, so dass ich mich mehr in das Thema einlesen kann?

Liebe Grüße, Sonja

Capricornum Gravatar-BildCapricornum ( 2017-01-05 21:27:00 +0200 )Bearbeiten

Hallo Sonja,

schaust Du hier bei Writer, Kapitel 13: https://de.libreoffice.org/get-help/d...

und Video auf YouTube hier: https://www.youtube.com/watch?v=LYrMB...

Beschreibung zum Video: https://wiki.documentfoundation.org/D...

Grüße Harald

ebot Gravatar-Bildebot ( 2017-01-06 10:53:29 +0200 )Bearbeiten

Hallo Harald,

vielen lieben Dank für die Links. Ich werde sie mir ansehen. :) Soll ich den Thread noch offen lassen oder kann ich ihn gar nicht schließen?

Liebe Grüße, Sonja

Capricornum Gravatar-BildCapricornum ( 2017-01-07 15:48:19 +0200 )Bearbeiten

Hallo,

ich habe alles genauso gemacht, wie in der Anleitung und im Video beschrieben. Aber sobald ich den Schritt mit dem Abspeichern als .odm mache, bekomme ich den Fehler "Dokument konnte nicht erzeugt werden".

Ich habe danach im Internet gesucht und bin bei OpenOffice auf den Fehler gestoßen. http://www.oooforum.de/viewtopic.php?... Leider behebt sich mein Problem nicht mit der Änderung auf Überschrift 1.

Woran liegt es? Soll ich dafür ein neues Topic eröffnen?

Liebe Grüße, Sonja

Capricornum Gravatar-BildCapricornum ( 2017-01-07 16:05:50 +0200 )Bearbeiten

Hallo Sonja,

ich habe mir Deinen Link angesehen, bzw. die Beschreibung des Bugs. Der Bug scheint ja schon älter zu sein und anscheinend noch nicht behoben (?). Auf anhieb habe ich hier im Thread nichts gefunden, aus dem Deine verwendete LibO-Version hervorgeht und Betriebssystem. Vielleicht versuchst Du es mal mit einer aktuellen LibO-Version, die kannst Du hier herunter laden: https://de.libreoffice.org/download/l...

ebot Gravatar-Bildebot ( 2017-01-09 17:02:10 +0200 )Bearbeiten

Ansonsten wird ja im Beitrag von Deinem LINK empfohlen Formatvorlagen zu verwenden. Da gibt es mehrere, z.B für Absätze, für Seiten. Die Empfehlung be´zieht sich auf die "Überschrift 1". Wie Formatvorlagen angewandt werden kannst Du hier nachschauen, Writer, Kpitel 6 und 7: https://de.libreoffice.org/get-help/d... und ein Video auf YouTube hier: https://www.youtube.com/watch?v=ts2lk... und die Beschreibung zum Video: https://wiki.documentfoundation.org/D... Viel Erfolg

ebot Gravatar-Bildebot ( 2017-01-09 17:03:01 +0200 )Bearbeiten

Hallo ebot,

vielen Dank für deine Tipps. Ich verwende LibO 5.1.6.2. Das müsste die Aktuellste sein. Ich verwende außerdem einen Mac mit Sierra 10.12.

Das mit den Überschriften habe ich auch schon ausprobiert, hilft bei mir aber nichts. Ich habe auf Überschrift 1 umgestellt und alles wie in der Anleitung ausprobiert. Zuerst dachte ich, es liegt an den Kopf- und Fußzeilen. Aber dann habe ich es in ganz neuen, einfachen odt's versucht und auch da der gleiche Fehler.

Liebe Grüße!

Capricornum Gravatar-BildCapricornum ( 2017-01-13 20:02:33 +0200 )Bearbeiten

Sorry, beim Mac kenne ich mich nicht aus. Möglicher Workaround wäre. Den jeweils neuen Textteil mit Copy&Past in ein neues Dokument zu packen um dort die Anzahl zeichen zu eruieren.

ebot Gravatar-Bildebot ( 2017-02-14 06:36:48 +0200 )Bearbeiten

Ja, so mache ich es momentan. :D

Danke für deine Hilfe! :) Ich gebe nicht auf und probier es weiter. Vielleicht mache ich nur was falsch. Man sagt ja immer, dass das Problem vor dem Rechner sitzt. ;D

Capricornum Gravatar-BildCapricornum ( 2017-04-20 15:09:50 +0200 )Bearbeiten
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

1 Beobachter

Statistik

Gefragt: 2017-01-05 12:53:39 +0200

Angesehen: 117 Mal

Aktualisiert: Jan 05 '17