Ask Your Question
0

Why is Times New Roman font always in italic [closed]

asked 2013-01-18 19:47:44 +0200

anonymous user

Anonymous

Hi, using LibreOffice 3.6.4.3 on Windows XP. I have notice that when using Times New Roman font I ALWAYS get text in italic despite italic not being selected. When I select text and click on italic it looks exactly the same as without italic.

I have also selected other fonts e.g. Arial and this problem (italic text) does not appear.

I first notice this problem in the latest version, opening one document which is using Times New Roman font in whole document - I have been using italic and non-italic type of font but now all of the text is "italic" despite not being selected as "italic".

Is this some kind of bug or something?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by manj_k
close date 2013-01-24 00:49:12.349139

Comments

The font problem has been solved → Bug 59660 comment #8.

manj_k gravatar imagemanj_k ( 2013-01-24 00:31:23 +0200 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2013-01-19 07:44:07 +0200

froz gravatar image

@Geekasaurus This looks like a bug to me. Like I have written in first post, this only happens with current version of LibreOffice and did NOT happen in previous versions.

I did additional tests (open fresh new document): 1. Select Times New Roman font. Type in some text any I get italic despite italic not being selected. (This is not OK, I expect text to not be italic by default). 2. Mark the same text and choose bold, and text becomes bold, but it is NOT italic any more. (This is OK). 3. Mark the same text and choose italic (so bold + italic are now selected) and text becomes bold + italic (This is OK).

I have tried the same 3 above steps for Arial font and it is working fine in all of three steps.

P.S. Don't get it how to reply to user's answer in this forum.

edit flag offensive delete link more

Comments

I think the reason you cannot comment directly below an Answer to your Question is that the software requires you to have at least 10 karma points. Stupid requirement. I hope this gets changed as soon as we get new moderators.

Joe1234 gravatar imageJoe1234 ( 2013-01-19 10:36:21 +0200 )edit

@froz : Upvoted (10 karma points) for adding comments (3 karma points required).

manj_k gravatar imagemanj_k ( 2013-01-19 20:37:27 +0200 )edit
0

answered 2013-01-18 20:04:51 +0200

Geekasaurus gravatar image

I suspect that this is a compatibility issue.

Back in the bad old days of teletype terminals, the keyboards did not have a [TAB] button. If there was a requirement to rapidly move the print head, the key sequence [CTRL][I] was used. The print head or cursor would move 8 spaces to the right for each [CTRL][I] sequence that was part of the datastream.

Microsoft redefines [CTRL][I] as "Make the next characters in Italic Font, until [CTRL][I] is inserted again.

Ray Noorda, founder of Novell said it: "Thats one on the nice things about standards; there are so many to choose from".

If we did a hex dump on your document, I am willing to bet good money that we would find that [CTRL][I] sequence embedded. That is decimal 09, or binary 00001001.

edit flag offensive delete link more
0

answered 2013-01-19 20:05:07 +0200

horst gravatar image

Hi guys, I could not replicate this behavior with LO3.6.4, LO3.6.5 or LO3.5.7 on Win7 64-bit.

Maybe you should check the "default" style. Could have been altered and saved as the Default Template.

edit flag offensive delete link more

Comments

Not reproducible with LO 3.6.4.3 on WinXP. @froz : How do you open a new document? How do you select the font (Times New Roman)? Do you use a customized default template?

manj_k gravatar imagemanj_k ( 2013-01-19 20:48:58 +0200 )edit

I closed LibreOffice, renamed the profile directory from: C:\Documents and Settings[user]\Application Data\LibreOffice\3 to "_path_\LibreOffice\3_old" and started LibreOffice. I see directory "...\LibreOffice\3" was recreated. Opened new document and typed text and I get italic font again!

froz gravatar imagefroz ( 2013-01-21 13:59:50 +0200 )edit
1

I reported a bug report: https://bugs.freedesktop.org/show_bug.cgi?id=59660 See bug report with all of the sample documents attached.

froz gravatar imagefroz ( 2013-01-21 14:26:33 +0200 )edit

@froz : Thanks, I've added a comment to fdo#59660.

manj_k gravatar imagemanj_k ( 2013-01-21 18:27:17 +0200 )edit

Question Tools

Stats

Asked: 2013-01-18 19:47:44 +0200

Seen: 2,643 times

Last updated: Jan 19 '13