Ask Your Question
1

LibreOffice 5.2 crash (debian 9.0) - solved

asked 2017-06-21 05:27:51 +0100

harritapio gravatar image

updated 2017-10-25 11:45:13 +0100

ratrace gravatar image

I made a clean installation of debian 9.0 with Gnome desktop and now LibreOffice crashes always when I want to open either writer or base document. The documents were created with LO4.3 (debian 8.8). LibreOffice calc document can be opened.

When I click LibreOffice Writer icon on "toolbar", "LibreOffice 5" window opens for few seconds in the middle of display and in the "top bar" LibreOffice Writer is displayed about for 15 seconds.

My computer is pentium5 with 2G ram, debian stretch (stable version) with Gnome desktop.

Any advice how to find the reason for this problem is welcome!

Harri

edit retag flag offensive close merge delete

Comments

1

same too... Every time open document using libre office writer, then closed again... I try to disable startup logo using this link https://wiki.archlinux.org/index.php/... Then nothing happen.

Indra Pranata gravatar imageIndra Pranata ( 2017-06-21 06:10:23 +0100 )edit

Problem solved when I made a 64bit installation of debian 9.0.0 with gnome desktop!

harritapio gravatar imageharritapio ( 2017-06-24 07:14:40 +0100 )edit

These is a bug report that i submitted for the crashing of libreoffice, after updating from debian jessie to stretch.

ratrace gravatar imageratrace ( 2017-08-22 17:41:36 +0100 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2017-07-21 17:06:36 +0100

updated 2017-07-21 17:07:05 +0100

This problem doesn't affect the 64bit-version, it only affects 32bit and only libreoffice-writer. It can be solved by removing the package "libreoffice-gtk2", for instance by performing apt-get remove libreoffice-gtk2 as root.

edit flag offensive delete link more

Comments

Perfect! That fixed it for me. t'm running 32--bit Debian 9 with the LXDE desktop.

(I created an account on this system and logged in specifically to upvote your answer in gratitude, but apparently don't have enough karma.)

HowardRoark gravatar imageHowardRoark ( 2017-07-24 17:45:20 +0100 )edit

Thanks, that also worked for me. I'm running 32-bit Debian 9 with XFCE4.

cleitonmoya gravatar imagecleitonmoya ( 2017-08-28 14:58:53 +0100 )edit
0

answered 2017-06-23 01:44:44 +0100

harritapio gravatar image

updated 2017-06-24 07:38:45 +0100

To be sure I made a reinstallation of debian 9 one more time and the result is the same.

dpkg --status libreoffice

did not find any problems in dependencies.

from /var/log/messages log file I found that kind of a message always when writer fails to start:

Jun 23 14:04:00 debian-p5 gnome-terminal-[3037]: Allocating size to GtkScrollbar 0x814f4210 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

maybe this message is related to writer start problem.

solved on 24.06.2017

Problem solved when I made a 64bit installation of debian 9.0.0 with gnome desktop!

edit flag offensive delete link more
0

answered 2017-06-22 17:23:35 +0100

erAck gravatar image

Sounds like a broken installation. Are you sure all necessary packages and dependencies are installed? Please check. If yes then please search and if there's not already a bug then submit one with the Debian bug tracker.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-06-21 05:27:51 +0100

Seen: 4,719 times

Last updated: Oct 25 '17